在线检测未来函数

同花顺挨套专业户主图指标公式

来源:Internet,编辑:股旁网,2016-08-04

MA5:MA(CLOSE,5),ColorCCCCCC,LINETHICK1;
MA10:MA(CLOSE,10),colorgreen,LINETHICK1;
MA20:MA(CLOSE,20),colorliblue,LINETHICK1;
MA30:MA(CLOSE,30),colormagenta,LINETHICK1;
MA60:MA(CLOSE,60),colorff8868,LINETHICK1;
MA120:MA(CLOSE,120),color93db70,LINETHICK1;
年:MA(CLOSE,250),Colorff3399,LINETHICK2;
小99:EMA(C,99),POINTDOT,linethick1,coloryellow;
庄144:EMA(CLOSE,144),POINTDOT,linethick1,colorred;
大318:MA(CLOSE,318),Color70dbdb,LINETHICK1;
超453:EMA(C,453),linethick1,colorcyan;
底550:MA(CLOSE,550),colorblue,LINETHICK2;
忙610:MA(CLOSE,610),Color777700,LINETHICK1;
奇730:MA(CLOSE,730),Coloreaadea,LINETHICK1;
疯880:MA(CLOSE,880),Color781f87,LINETHICK2;
买线:=ZIG(3,10);
卖线:=MA(买线,2);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWTEXT(bu,L*0.99,'▲'),LINETHICK3,colormagenta;
DRAWTEXT(sel,H*1.0,'▼'),linethick3,colorgreen;
STICKLINE(CROSS(买线,卖线),OPEN,CLOSE,7,0),colormagenta,LINETHICK3;
STICKLINE(CROSS(卖线,买线),OPEN,CLOSE,7,0),colorblue,LINETHICK3;
V10:=PEAKBARS(3,15,1)<10;
V12:=IF(V10=1,50,0);
V9:=TROUGHBARS(3,15,1)<10;
V11:=IF(V9=1,50,0);
DRAWTEXT(IF( IF(V11=50,50,0)>REF(IF(V11=50,50,0),1),L,0),L*0.96,'↖底 '),colormagenta;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA
((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR11:=VARF<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,1) ;
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,2);
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
VAR21:=(HIGH+LOW+CLOSE)/3;
VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14));
VAR23:=(VAR21-MA(VAR21,70))/(0.015*AVEDEV(VAR21,70));
VAR24:=IF(VAR22>=150 AND VAR22<200 AND VAR23>=150 AND VAR23<200,10,0);
VAR25:=IF(VAR22<=-150 AND VAR22>-200 AND VAR23<=-150 AND VAR23>-200,-10,VAR24);
DRAWTEXT(VAR20 AND COUNT(VAR20,1)=1,H*0.99,'$') , colormagenta;
DRAWTEXT(VAR24 AND COUNT(VAR24,1)=1,L*1.1,'$') , color00FF00;
aaa2:=EMA((H+C+O)/3,18);
STICKLINE(MA(C,13)>O AND C>MA(C,13) AND O<C,O,C,8,0),coloryellow;
STICKLINE(MA(C,13)>O AND C>MA(C,13),H,L,0.8,1),coloryellow;
aaa2:=EMA((H+C+O)/3,18);
STICKLINE(MA(C,13)>O AND C>MA(C,13) AND O<C,O,C,8,0),coloryellow;
STICKLINE(MA(C,13)>O AND C>MA(C,13),H,L,0.8,1),coloryellow;
A1:=REF(V,1);A2:=DVOL;A3:=A2/A1;
LNX:=A3-REF(A3,1),COLOR00CCCC,LINETHICK1;
E1:=REF(C,1);E2:=DCLOSE;E3:=(E2-E1)/E1*100;
QMX:=E3-REF(E3,1),COLOR00CCCC,LINETHICK2;
XG:=CROSS(LNX,500) AND CROSS(QMX,10);
DRAWTEXT(XG=1,L*0.985,'↖↖∏'),COLORFF8868;
中线趋势20:=MA(CLOSE,20),colorred,linethick1;
生命线:=MA(CLOSE,30),colorwhite,linethick3;
多空趋势60:=MA(CLOSE,60),colorliblue,linethick1;
半年线:=MA(CLOSE,120),colorligreen,linethick1;
年线:=MA(CLOSE, 250),colorblue;
DRAWTEXT(CROSS(中线趋势20,生命线),生命线*0.98,'↖强'),coloryellow,linethick2;
DRAWTEXT(CROSS(生命线,多空趋势60),多空趋势60*0.98,'↖牛'),coloryellow,linethick2;

同花顺挨套专业户主图指标公式

 

相关文章