在线检测未来函数

通达信未来长短指标公式

来源:Internet,编辑:股旁网,2016-08-05

P1:=7;
P2:=5;
-20, POINTDOT,COLORGREEN;
VAR2:=LLV(LOW,P1);
VAR3:=HHV(HIGH,P1);
短: EMA((CLOSE-VAR2)/(VAR3-VAR2)*100,P2),LINETHICK1,COLORMAGENTA;
OK: EMA(0.667*REF(短,1)+0.333*短,3),LINETHICK1,COLORGREEN;
VAR4:=(2*CLOSE+HIGH+LOW)/4;
VAR5:=LLV(LOW,34);
VAR6:=HHV(HIGH,34);
长: EMA((VAR4-VAR5)/(VAR6-VAR5)*100,12),COLORWHITE;
线: EMA(0.667*REF(长,1)+0.333*长,4),LINETHICK2,COLORRED;
VAR7:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);
VAR8:=EMA(VAR7,7);
VARA:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100;
VARB:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5;
波段买入: IF(VARA+VARB<7 AND CROSS(VAR7,VAR8) AND VAR8<-18 AND VAR8<VARB,60,50),LINETHICK2, COLORBLUE;
DRAWICON((CROSS(长,30) OR CROSS(长,65) OR CROSS(长,75)) AND 线<长,线,1);
DRAWICON(CROSS(线,长) AND 线>75,85,2);
低吸: IF(CROSS(长,线) AND 长<25,25,10),COLORYELLOW;
高减: IF(CROSS(线,长) AND 线>80,75,90),COLORCYAN;
VAR9:=REF(LOW,1);
VAR10:=SMA(ABS(LOW-VAR9),13,1)/SMA(MAX(LOW-VAR9,0),13,1)*11;
VAR11:=EMA(VAR10,13);
VAR12:=LLV(LOW,34);
VAR13:=EMA(IF(LOW<=VAR12,VAR11,0),3);
VAR14:=EMA(CLOSE,5);
VAR15:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(-10);
VAR16:=IF(VAR13>100,100,VAR13);
主力进场:STICKLINE(VAR13>REF(VAR13,1),0,VAR13,2,1),COLORRED;
洗缓:STICKLINE(VAR13<REF(VAR13,1),0,VAR13,2,1),COLORGREEN;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
STICKLINE(XL3,0,VAR13*3,4,0),COLOR006EFF;
买:DRAWICON(XL3,0,4),COLORRED;
VAR111:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR122:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR133:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR144:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR155:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR166:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR1A:=EMA(VAR19,100);
VAR1B:=2*(VAR19-VAR1A);
VAR1C:=POW(VAR1B,3)*0.1+POW(VAR1B,1);
VAR1D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR1E:=EMA(VAR1D*0.97,3);
VAR1F:=(HIGH+LOW+CLOSE)/3;
VAR20:=(VAR1F-MA(VAR1F,14))/(0.015*AVEDEV(VAR1F,14));
VAR21:=CROSS(VAR1E,LOW);
组合买:= (VAR111+VAR133+VAR155+VAR17)-10;
组合卖:= (VAR122+VAR144+VAR166+VAR18)-10;
DRAWICON(组合买>-10,组合买-5,1);
DRAWICON(组合卖>-10,组合卖-5,9);

通达信未来长短指标公式

 

相关文章