在线检测未来函数

通达信组合顶底指标公式

来源:Internet,编辑:股旁网,2016-08-08

顶:100,POINTDOT,COLORGREEN;
底:15,POINTDOT,COLORWHITE;
中:50,POINTDOT,COLORWHITE;
DRAWTEXT(ISLASTBAR,顶,'顶'),COLORGREEN;
DRAWTEXT(ISLASTBAR,底,'底'),COLORRED;
DRAWTEXT(ISLASTBAR,中,'中'),COLORWHITE;
A0:=(H+L+C*2)/4;
A1:=HHV(A0,21);
A2:=LLV(A0,21);
A3:=A1-A2;
趋势:EMA((A0-A2)/A3,2)*100,COLORRED,LINETHICK2;
趋势1:=MA(趋势,3);
趋势2:IF(趋势<趋势1,(趋势-(趋势1-趋势)),趋势);
IF(趋势>=趋势1,趋势,DRAWNULL),COLORRED,LINETHICK2;
IF(趋势<=趋势1,趋势,DRAWNULL),COLORGREEN,LINETHICK2;
C1:=LLV(L,21);
C2:=HHV(H,21);
C3:=REF(C,1);
C4:=EMA((C-C1)/(C2-C1),3)*100;
C5:=SMA(MAX(C-C3,0),5,1)/SMA(ABS(C-C3),5,1)*100;
C6:=(C4-LLV(C4,21))/(HHV(C4,21)-LLV(C4,21))*100;
IF(CROSS(C6,90) AND C4<40,50,10),COLORYELLOW,LINETHICK2;
IF(CROSS(C5,18) AND REF(C4,5)<20 AND REF(C4,3)<20,50,10),LINETHICK2;
IF(CROSS(85,C5),70,90),COLOR99FF33,LINETHICK2;
IF(CROSS(85,C4),70,90),COLORCYAN,LINETHICK2;
B1:=(L+H+2*C)/4;
B2:=REF(B1,1);
B3:=SMA(B1-B2,6,1)/SMA(ABS(B1-B2),6,1)*100;
B4:=MA(B3,1)+50;
STICKLINE(B4>=100,103,101,3,0),COLORYELLOW;
STICKLINE(B4<=0,-10,-8,3,0),COLORGREEN;

通达信组合顶底指标公式

 

相关文章