在线检测未来函数

通达信共振自动划线主图指标公式

来源:Internet,编辑:股旁网,2016-08-11

CYS:=(C-(0.01*EMA(AMOUNT,13)/EMA(V,13)))/(0.01*EMA(AMOUNT,13)/EMA(V,13))*100;
A:=L<MA(C,15) AND L<REF(HHV(C,20),1)*0.9 AND MA(C,15)<REF(HHV(C,20),1)*0.9;
B:=CROSS(CYS,0);
小妖线:EMA(CLOSE,20),COLORCYAN,DOTLINE;
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
QD:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;
马线:=MA(QD,5);
买卖线:=MA(QD,2);
STICKLINE(QD>=买卖线 AND C<O,C,O,2.8,0),COLORRED;
STICKLINE(QD>=买卖线 AND C>O,C,O,2.8,1),COLORRED;
STICKLINE(QD>=买卖线,H,MAX(C,O),0,0),COLORRED;
STICKLINE(QD>=买卖线,L,MIN(C,O),0,0),COLORRED;
STICKLINE(QD<买卖线 AND C<O,C,O,2.8,0),COLORCYAN;
STICKLINE(QD<买卖线 AND C>O,C,O,2.8,1),COLORCYAN;
STICKLINE(QD<买卖线,H,MAX(C,O),0,0),COLORCYAN;
STICKLINE(QD<买卖线,L,MIN(C,O),0,0),COLORCYAN;
DRAWICON(CROSS(QD,买卖线),L*0.99,7);
DRAWICON(CROSS(买卖线,QD),H*1.01,8);
主力成本线:QD,COLORYELLOW;
资金生命线:马线,COLORRED;
水平面:MA(C,60),COLORGREEN;
小妖:=CROSS(C,小妖线) AND CROSS(C,QD) AND QD<小妖线 ;
小妖2:=CROSS(小妖线,QD);
小妖3:=CROSS(C,小妖线) AND CROSS(C,QD) AND QD<小妖线 AND A;
小妖4:=(小妖 OR 小妖2 OR 小妖3) AND B;
共振:=(小妖 AND 小妖2) OR (小妖 AND 小妖3) OR (小妖2 AND 小妖3) OR (小妖 AND 小妖2 AND 小妖3);
STICKLINE(小妖,C,O,2.1,0);
STICKLINE(小妖,C,O,2.8,0);
STICKLINE(小妖,C,O,1.5,0);
DRAWTEXT(小妖,L*0.98, '★小妖'),COLOR00FF00;
STICKLINE(小妖2,C,O,2.1,0);
STICKLINE(小妖2,C,O,2.8,0);
STICKLINE(小妖2,C,O,1.5,0);
DRAWTEXT(小妖2,L*0.96, '★小妖2'),COLOR00FF00;
STICKLINE(小妖3,C,O,2.1,0);
STICKLINE(小妖3,C,O,2.8,0);
STICKLINE(小妖3,C,O,1.5,0);
DRAWTEXT(小妖3,L*0.94, '★小妖3'),COLOR00FF00;
STICKLINE(小妖4,C,O,2.1,0);
STICKLINE(小妖4,C,O,2.8,0);
STICKLINE(小妖4,C,O,1.5,0);
DRAWTEXT(小妖4,L*0.92, '★小妖4'),COLOR00FF00;
STICKLINE(共振,C,O,2.1,0);
STICKLINE(共振,C,O,2.8,0);
STICKLINE(共振,C,O,1.5,0);
DRAWTEXT(共振,L*0.90, '★共振'),COLOR00FF00;
DRAWLINE(共振,H,REF(共振,1),REF(H,1),1),COLORRED;

通达信共振自动划线主图指标公式

 

相关文章