在线检测未来函数

通达信黑马出击指标公式

来源:Internet,编辑:股旁网,2016-08-11

VAR1:=EMA((C-(LLV(L,25)))/((HHV(H,25))-(LLV(L,25)))*100,5);
VAR2:=VAR1,COLORRED,LINETHICK2;
VAR3:=MA((V-REF(V,1))/REF(V,1),5);
VAR4:=(C-MA(C,24))/MA(C,24)*100;
VAR5:=VAR4*(1+VAR3);
VAR6:=REF(VOL,1);
VAR7:=SMA(MAX(VOL-VAR6,0),6,1)/SMA(ABS(VOL-VAR6),6,1)*100;
VAR8:=VAR5>REF(VAR5,1) AND VAR2<REF(VAR2,1) AND VAR7>REF(VAR7,1);
VAR9:=VAR5<REF(VAR5,1) AND VAR2>REF(VAR2,1) AND VAR7>REF(VAR7,1);
VAR10:=VAR5>REF(VAR5,1) AND VAR2<REF(VAR2,1) AND VAR7<REF(VAR7,1);
VAR11:=VAR5<REF(VAR5,1) AND VAR2>REF(VAR2,1) AND VAR7<REF(VAR7,1);
VAR12:=VAR5>REF(VAR5,1);
VAR13:=VAR5<REF(VAR5,1);
VAR14:=VAR2<REF(VAR2,1);
VAR15:=VAR2>REF(VAR2,1);
VAR16:=VAR8 OR VAR10;
VAR17:=VAR9 OR VAR11;
VAR18:=VAR13 AND VAR14;
VAR19:=VAR16 OR VAR18;
VAR20:=VAR12 AND VAR15;
XG:=LAST(VAR19,7,1) AND VAR20,COLORRED,STICK;
UP:=CROSS(XG,VAR19) AND VAR20<2.1 AND C>O;
STICKLINE(UP,50,0,4,0),COLOR0000FF;
STICKLINE(UP,50,0,3,0),COLOR6600FF;
STICKLINE(UP,50,0,2,0),COLORFF00FF;
STICKLINE(UP,50,0,1,0),COLORFF99FF;
STICKLINE(UP,50,0,0.3,0),COLORFF3366,;
DRAWTEXT(UP,53,'出击'),COLORWHITE;
均价线:3*SMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,5,1),3,1),COLORLIBLUE,LINETHICK2;
你恐慌我贪婪:IF(均价线<=8,30,0),COLORRED,LINETHICK2;
DRAWTEXT(CROSS(你恐慌我贪婪,8),33,'我贪婪'),COLORYELLOW;
JS:=IF(MACD>=0,MACD,DRAWNULL);
MACD:=IF(MACD<0,-MACD,DRAWNULL);
高位:90,DOTLINE,COLORLIRED;
平衡:50,DOTLINE,COLORYELLOW;
区间:20,DOTLINE,COLORLIGRAY;
底位线:5,DOTLINE,COLORYELLOW;
DRAWTEXT_FIX(1,0.21,0.42,1,'【关注均价线在底位线区间的数值!!!】'),COLORYELLOW;

通达信黑马出击指标公式

 

相关文章