在线检测未来函数

通达信麟龙四量决策指标公式

来源:Internet,编辑:股旁网,2016-08-18

M3:=MA(CLOSE,3),COLORRED;
M13:=MA(CLOSE,13),COLORRED;
M34:=MA(CLOSE,34),COLORRED;
X:=BARSLAST(REF(CROSS(C,MA(C,120)),1)) AND CROSS(MA(C,20),MA(C,120));
STICKLINE(M3>=M13 AND M34>=REF(M34,1),8,9,1,1 ),COLORRED;
STICKLINE(M3<M13 AND M34>=REF(M34,1),8,9,1,1 ),COLORYELLOW;
STICKLINE(M3<M13 AND M34<REF(M34,1),8,9,1,1 ),COLORGREEN;
STICKLINE(M3>=M13 AND M34<REF(M34,1),8,9,1,1 ),COLORMAGENTA;
XG:=(M3>=M13 AND M34<REF(M34,1))OR (M3>=M13 AND M34>=REF(M34,1))AND REF((M3<M13 AND M34<REF(M34,1)),1);
XG1:=(M3>=M13 AND M34>=REF(M34,1))AND REF((M3<M13 AND M34>=REF(M34,1)),1);
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORGREEN{COLORRED};
马线:=MA(牛线,6),COLORMAGENTA{COLORYELLOW};
STICKLINE(C>牛线,6,7,2,0),COLORRED{COLORGREEN},LINETHICK2;
STICKLINE(C<马线,6,7,2,0),COLORGREEN{COLORRED},LINETHICK2;
STICKLINE(牛线>=C AND C>=马线,6,7,2,0),COLORGREEN{COLORMAGENTA}{COLORYELLOW},LINETHICK2;
A:=MAX(MA(C,60),MA(C,120));
B:=MIN(MA(C,60),MA(C,120));
STICKLINE(C>=A,4,5,2,0),COLORRED{COLORGREEN},LINETHICK2;
STICKLINE(C<=B,4,5,2,0),COLORGREEN{COLORRED},LINETHICK2;
STICKLINE(A>=C AND C>=B,4,5,2,0),COLORGREEN{COLORMAGENTA}{COLORYELLOW},LINETHICK2;
E:=MAX(MA(C,45),MA(C,90));
F:=MIN(MA(C,45),MA(C,90));
STICKLINE(C>E,2,3,2,0),COLORRED{COLORGREEN},LINETHICK2;
STICKLINE(C<F,2,3,2,0),COLORGREEN{COLORRED},LINETHICK2;
STICKLINE(E>=C AND C>=F,2,3,2,0),COLORGREEN{COLORMAGENTA}{COLORYELLOW},LINETHICK2;
J:=MAX(MA(C,30),MA(C,60));
K:=MIN(MA(C,30),MA(C,60));
STICKLINE(C>J,0,1,2,0),COLORRED{COLORGREEN},LINETHICK2;
STICKLINE(C<K,0,1,2,0),COLORGREEN{COLORRED},LINETHICK2;
STICKLINE(J>=C AND C>=K,0,1,2,0),COLORGREEN{COLORMAGENTA}{COLORYELLOW},LINETHICK2;
{DRAWICON(XG OR XG1,10,13);}
全绿:=((J>=C AND C>=K) OR C<K) AND ((E>=C AND C>=F) OR C<F) AND ((A>=C AND C>=B) OR C<=B) AND
((牛线>=C AND C>=马线) OR C<马线);
全红:=C>J AND C>E AND C>=A AND C>牛线 AND (M3>=M13 AND M34>=REF(M34,1));
RSV:=(CLOSE - LLV(LOW,18))/(HHV(HIGH,18) - LLV(LOW,18))*100;
KK:=EMA(RSV,3);
D:=EMA(KK,3);
JJJ:=(3*KK-2*D);
KDJ1:=REF(COUNT(JJJ<REF(JJJ,1),5)>=3,1) AND REF(JJJ,1)<20;
KDJ2:=JJJ>REF(JJJ,1);
JJ:=MAX(MA(C,30),MA(C,60));
KKK:=MIN(MA(C,30),MA(C,60));
全绿A:=((JJ>=C AND C>=KKK) OR C<KKK) AND ((E>=C AND C>=F) OR C<F) AND ((A>=C AND C>=B) OR C<=B) AND
((牛线>=C AND C>=马线) OR C<马线);
全绿选股:IF(FILTER(KDJ1 AND KDJ2,3)AND 全绿A,10,-2),COLOR00FFFF,LINETHICK1;
DRAWICON(全绿选股=10,-1,1);
全红选股:IF(全红 AND REF(全红,1)=0,10,-2),COLORFF00FF,LINETHICK1;
DRAWICON(全红选股=10,-1,1);

通达信麟龙四量决策指标公式

 

相关文章