在线检测未来函数

通达信MACD女排精神指标公式

来源:Internet,编辑:股旁网,2016-08-23

EMA12:=EMA(C,12);
EMA26:=EMA(C,26);
DIF:=(EMA12-EMA26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
CCI:=CCI.CCI;
RSI:=RSI.RSI1;
女排精神:DIF,COLORFF00FF,NODRAW;
中国骄傲:DEA,COLOR00FFFF,NODRAW;
团结拼搏:MACD,COLORSTICK;
技术过硬:CCI,COLORFF2222,NODRAW;
坚持不懈:RSI,COLORFFF555,NODRAW;
零上最大界面:=MAX(CONST(HHV(DIF,100)),CONST(HHV(MACD,100)));
零下最大界面:=REVERSE(MIN(CONST(LLV(DIF,100)),CONST(LLV(MACD,100))));
最大界面:=MAX(零上最大界面,零下最大界面);
LLCST:=IF(CURRBARSCOUNT<=150, IF(CONST(HHV(DIF,100))>=0,REVERSE(最大界面),DRAWNULL),DRAWNULL);
HHCST:=IF(CURRBARSCOUNT<=150, IF(CONST(HHV(DIF,100))>=0,最大界面,DRAWNULL),DRAWNULL);
HLCST:=(HHCST+LLCST)/2;
HLCSTH:=((HHCST+LLCST)/2+HHCST)/2;
HLCSTL:=((HHCST+LLCST)/2+LLCST)/2;
HLMAX:=HHCST;{设定所要叠加副图比例的最大值}
HLMIN:=LLCST;{设定所以叠加副图比例的最小值}
HLMN1:=HLCST;{取设定所要叠加副图比例的最大最小值的中间值}
HLMN2:=HLMAX-HLMIN;{取设定所要叠加副图比例的最大最小值的差值}
HLMN3:=(100+0)/2;
HLMN4:=100-0;
RSI叠加:=(RSI-HLMN3)*HLMN2/HLMN4+HLMN1;
CCI叠加:=(CCI/4+50-HLMN3)*HLMN2/HLMN4+HLMN1;
DRAWBAND((80-HLMN3)*HLMN2/HLMN4+HLMN1,RGB(150,165,150),(75-HLMN3)*HLMN2/HLMN4+HLMN1,DRAWNULL);
DRAWBAND((25-HLMN3)*HLMN2/HLMN4+HLMN1,RGB(150,165,150),(20-HLMN3)*HLMN2/HLMN4+HLMN1,DRAWNULL);
DRAWBAND(RSI叠加,RGB(30,95,65),REVERSE(RSI叠加),RGB(77,66,77));
DRAWBAND(DIF,RGB(105,46,56),DEA,RGB(40,60,120));
CCIFX1:=IF(CCI>=150,(98-HLMN3)*HLMN2/HLMN4+HLMN1,IF(CCI<=-150,(2-HLMN3)*HLMN2/HLMN4+HLMN1,DRAWNULL));
CCIFX2:=IF(CCI>=150,(102-HLMN3)*HLMN2/HLMN4+HLMN1,IF(CCI<=-150,(-2-HLMN3)*HLMN2/HLMN4+HLMN1,DRAWNULL));
STICKLINE(C>0,CCIFX1,CCIFX2,3.3,-1),COLOR22DDEE;
STICKLINE(IF(PERIOD<5,CCI.CCI#DAY,CCI.CCI#WEEK)>100,(98.7-HLMN3)*HLMN2/HLMN4+HLMN1,(101.3-HLMN3)*HLMN2/HLMN4+HLMN1,2,0),COLORFF0000;
STICKLINE(IF(PERIOD<5,CCI.CCI#DAY,CCI.CCI#WEEK)>200,(99.3-HLMN3)*HLMN2/HLMN4+HLMN1,(100.7-HLMN3)*HLMN2/HLMN4+HLMN1,1.5,0),COLOR00FF00;
STICKLINE(IF(PERIOD<5,MACD.MACD#DAY,MACD.MACD#WEEK)>0,(1.3-HLMN3)*HLMN2/HLMN4+HLMN1,(-1.3-HLMN3)*HLMN2/HLMN4+HLMN1,2,0),COLOR999999;
STICKLINE(IF(PERIOD<5,MACD.DIF#DAY,MACD.DIF#WEEK)>0,(0.7-HLMN3)*HLMN2/HLMN4+HLMN1,(-0.7-HLMN3)*HLMN2/HLMN4+HLMN1,1.5,0),COLORFF00FF;
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),MACD,0,1.2,0),COLOR000088;
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),MACD,0,0.7,0),COLOR000099;
STICKLINE(MACD>0 AND MACD>=REF(MACD,1),MACD,0,0.3,0),COLOR0000AA;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,1.2,0),COLORFF8888;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.7,0),COLORFF9999;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.3,0),COLORFFAAAA;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),MACD,0,1.2,0),COLOR660055;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),MACD,0,0.7,0),COLOR770066;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1) ,MACD,0,0.3,0),COLOR880077;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,1.2,0),COLOR666600;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,0.7,0),COLOR777700;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,0.3,0),COLOR888800;
女排精神,COLORFF00FF,LINETHICK2;
中国骄傲,COLOR00FFFF;
RSI叠加,COLORFFF555,DOTLINE;
CCI叠加,COLORFF2222;

通达信MACD女排精神指标公式

 

相关文章