在线检测未来函数

大智慧超级黄牛主图指标公式

来源:Internet,编辑:股旁网,2016-08-25

DRAWTEXTABS(2,5,'所属板块:' + BKNAME),LINETHICK1,COLORFF50FF;
VAR0:=((FINANCE2(35)) / (10000));
VAR1:=((FINANCE2(37)) / (10000));
DRAWTEXTABS(15,20,'总股本:' + NUMTOSTRN(VAR0,2) + '亿'),LINETHICK1,COLORYELLOW;
DRAWTEXTABS(160,20,'流通盘:' + NUMTOSTRN(VAR1,2) + '亿'),LINETHICK1,COLORYELLOW;
VAR2:=((((C - O) / O) * (100)) > 4);
VAR3:=((((C - (REF(C,1))) / (REF(C,1))) * (100)) > 8);
VAR4:=(((((REF(C,1)) * (1.1)) - C) < (0.01)) AND (H = C));
VAR5:=((20 * H + 19 * (REF(H,1)) + 18 * (REF(H,2)) + 17 * (REF(H,3)) + 16 * (REF(H,4)) + 15 * (REF(H,5)) + 14 * (REF(H,6)) + 13 * (REF(H,7)) + 12 * (REF(H,8)) + 11 * (REF(H,9)) + 10 * (REF(H,10)) + 9 * (REF(H,11)) + 8 * (REF(H,12)) + 7 * (REF(H,13)) + 6 * (REF(H,14)) + 5 * (REF(H,15)) + 4 * (REF(H,16)) + 3 * (REF(H,17)) + 2 * (REF(H,18)) + REF(H,20)) / (210));
黄牛线:(EMA(VAR5,90)),LINETHICK2,COLORGREEN;
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;{涨停};
HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210;
黄牛线1:=EMA(HH,5);
黄牛线2:=EMA(HH,10);
黄牛线3:=EMA(HH,30);
黄牛线4:=EMA(HH,60);
黄牛线5:=EMA(HH,90);
黄牛线6:=EMA(HH,120);
黄牛线7:=EMA(HH,250);
E5:EMA(C,5);
离合:=(黄牛线1-((H-黄牛线1)*H-黄牛线1)/黄牛线1);
离合1:=(黄牛线2-((H-黄牛线2)*H-黄牛线2)/黄牛线2);
离合2:=(黄牛线3-((H-黄牛线3)*H-黄牛线3)/黄牛线3);
离合3:=(黄牛线4-((H-黄牛线4)*H-黄牛线4)/黄牛线4);
离合4:=(黄牛线5-((H-黄牛线5)*H-黄牛线5)/黄牛线5);
离合5:=(黄牛线6-((H-黄牛线6)*H-黄牛线6)/黄牛线6);
离合6:=(黄牛线7-((H-黄牛线7)*H-黄牛线7)/黄牛线7);
最大临界线:MAX(离合6,MAX(离合5,MAX(离合4,MAX(离合3,MAX(离合2,MAX(离合1,离合))))));
最小临界线:=MIN(离合6,MIN(离合5,MIN(离合4,MIN(离合3,MIN(离合2,MIN(离合1,离合))))));
{STICKLINE(最小临界线<=最大临界线,最小临界线,最大临界线,0,0);}
上升离合:=(黄牛线1+((C-黄牛线1)*C-黄牛线1)/黄牛线1);
上升离合1:=(黄牛线2+((H-黄牛线2)*H-黄牛线2)/黄牛线2);
上升离合2:=(黄牛线3+((H-黄牛线3)*H-黄牛线3)/黄牛线3);
上升离合3:=(黄牛线4+((H-黄牛线4)*H-黄牛线4)/黄牛线4);
上升离合4:(黄牛线5+((H-黄牛线5)*H-黄牛线5)/黄牛线5);
上升离合5:=(黄牛线6+((H-黄牛线6)*H-黄牛线6)/黄牛线6);
上升离合6:=(黄牛线7+((H-黄牛线7)*H-黄牛线7)/黄牛线7);
TP1:=CROSS(最大临界线,黄牛线1);
TP3:=CROSS(C,最大临界线);
TP6:=CROSS(上升离合4,E5);
持股线:((MA(C,3) + MA(C,6) + MA(C,12) + MA(C,24)) / 4),LINETHICK2;
VAR6:=((黄牛线) - ((((C - (黄牛线)) * C) - (黄牛线)) / (黄牛线)));
VAR7:=(黄牛线 + (((C - (黄牛线)) * C) - (黄牛线)) / (黄牛线));
涨速线:(IF((黄牛线) > (VAR6),(黄牛线) * (0.9),VAR6)),LINETHICK2,COLORYELLOW;
VAR8:=(((REF(黄牛线,2)) >= (REF(黄牛线,1))) AND ((REF(黄牛线,1)) < (黄牛线)));
VAR9:=(CROSS(黄牛线,VAR6));
VAR10:=(CROSS(VAR6,黄牛线));
VAR11:=(CROSS(C,VAR6));
VAR12:=(CROSS(VAR7,C));
DRAWTEXT(VAR9,L,'加'),COLORWHITE;
DRAWTEXT((VAR9) AND (VAR4),L,'↖金元宝'),LINETHICK4,COLORRED;
DRAWTEXT((VAR11) AND (VAR4),L,'↖精准导弹'),LINETHICK4,COLORWHITE;
DRAWTEXT(TP6 AND ZT,L,'↖超级主升'), LINETHICK4,COLORWHITE;
DRAWTEXT(VAR11,L,'买'),LINETHICK4,COLORRED;
VAR13:=(REF(H,BARSLAST(V = (HHV(V,30)))));
VAR14:=(REF(H,BARSLAST(V = (HHV(V,60)))));
VAR15:=(REF(H,BARSLAST(V = (HHV(V,120)))));
VAR16:=(REF(H,BARSLAST(V = (HHV(V,250)))));
VAR17:=(REF(H,BARSLAST(H = (HHV(H,60)))));
VAR18:=(REF(H,BARSLAST(H = (HHV(H,120)))));
股价平台250:(REF(H,BARSLAST(H = (HHV(H,250)))));
VAR19:=((CROSS(C,VAR15)) AND (VAR4));
VAR20:=((NOT((REF(VAR15,1)) = (REF(VAR14,1)))) AND ((VAR15) = (VAR14)));
VAR21:=((NOT((REF(VAR15,1)) = (REF(VAR16,1)))) AND ((VAR15) = (VAR16)));
VAR22:=((NOT((REF(VAR15,1)) = (VAR15))) AND (VAR4));
DRAWTEXT(VAR22,L,'量爆'),COLORRED;
VAR23:=(REF(HHV(H,BARSCOUNT(C)),1));
史高线:(STICKLINE((CROSS(C,VAR23)) AND ((HHV(H,3)) = (HHV(H,0))),VAR23,VAR23,10,0)),COLORWHITE;

大智慧超级黄牛主图指标公式

 

相关文章