在线检测未来函数

通达信清晰趋势主图指标公式

来源:Internet,编辑:股旁网,2016-08-27

卖线:EMA(((SLOPE(CLOSE,34) *20) + CLOSE),75),COLOR0055FF;
买线:EMA(CLOSE,15),COLORBLACK;
VAR1:=(买线 - 卖线);
STICKLINE((VAR1 >= 0),买线,卖线,0.5,0),COLORRED;
STICKLINE((VAR1 < 0),买线,卖线,0.5,0),COLORBLUE;
买买:=EMA(((100 * (CLOSE - LLV(LOW,34))) / (HHV(HIGH,34) - LLV(LOW,34))),3);
卖卖:=SMA((((HHV(HIGH,34) - CLOSE) / (HHV(HIGH,34) - LLV(LOW,34))) * 100),2,1);
大盘:=EMA(((100 * (INDEXC - LLV(INDEXL,34))) / (HHV(INDEXH,34) - LLV(INDEXL,34))),3);
换手:=(((VOL / CAPITAL) * 100) >= 2);
涨:=(((CLOSE / REF(CLOSE,1)) - 1) * 100);
A:=(CROSS(买买,卖卖) AND (买买 >= 45));
B:=(CROSS(买买,大盘) AND (买买 >= 45));
D:=(CROSS(买买,75) AND (涨>= 2));
DD:=(CROSS(买买,20) AND (涨>= 2));
DRAWTEXT((A > 0),(LOW * 0.99),'←阻击龙头'),LINETHICK0,COLORFFFF00;
DRAWTEXT((B > 0),(LOW * 1.02),'←决战龙头'),LINETHICK0,COLOR0055FF; DRAWTEXT((D > 0),(LOW * 1.05),'←绝对龙头'),LINETHICK0,COLORRED;
DRAWTEXT((DD > 0),(LOW * 1.05),'←短线金股'),LINETHICK0,COLORRED; TJ:=((CLOSE > OPEN) OR ((CLOSE = OPEN) AND (CLOSE > REF(CLOSE,1))));
STICKLINE(TJ,LOW,HIGH,0.8,0),COLORRED;
STICKLINE(TJ,OPEN,CLOSE,8,0),COLORRED;
STICKLINE(TJ,OPEN,CLOSE,6,0),COLOR8B6AFD;
STICKLINE(TJ,OPEN,CLOSE,2,0),COLORC6B6FE;
STICKLINE(TJ,OPEN,CLOSE,1,0),COLORF9F7FF;
STICKLINE(NOT(TJ),LOW,HIGH,0.1,0),COLORFF0000;
STICKLINE(NOT(TJ),OPEN,CLOSE,8,0),COLORFF0000;
STICKLINE(NOT(TJ),OPEN,CLOSE,6,0),COLORFF7578;
STICKLINE(NOT(TJ),OPEN,CLOSE,2,0),COLORFFBFC1;
STICKLINE(NOT(TJ),OPEN,CLOSE,0.5,0),COLORFFFFF7;

通达信清晰趋势主图指标公式

 

相关文章