在线检测未来函数

通达信震荡指标公式

来源:Internet,编辑:股旁网,2016-08-30

VAR1:=10;VAR2:=11;VAR3:=12;VAR4:=13;
VAR5:=14;VAR6:=15;VAR7:=16;VAR8:=17;
VAR9:=18;VARA:=19;VARB:=20;
VARC:=SMA(((CLOSE-LLV(LOW,VAR1))/(HHV(HIGH,VAR1)-LLV(LOW,VAR1)))*(100),4,1);
VARD:=SMA(((CLOSE-LLV(LOW,VAR2))/(HHV(HIGH,VAR2)-LLV(LOW,VAR2)))*(100),4,1);
VARE:=SMA(((CLOSE-LLV(LOW,VAR3))/(HHV(HIGH,VAR3)-LLV(LOW,VAR3)))*(100),4,1);
VARF:=SMA(((CLOSE-LLV(LOW,VAR4))/(HHV(HIGH,VAR4)-LLV(LOW,VAR4)))*(100),4,1);
VAR10:=SMA(((CLOSE-LLV(LOW,VAR5))/(HHV(HIGH,VAR5)-LLV(LOW,VAR5)))*(100),4,1);
VAR11:=SMA(((CLOSE-LLV(LOW,VAR6))/(HHV(HIGH,VAR6)-LLV(LOW,VAR6)))*(100),4,1);
VAR12:=SMA(((CLOSE-LLV(LOW,VAR7))/(HHV(HIGH,VAR7)-LLV(LOW,VAR7)))*(100),4,1);
VAR13:=SMA(((CLOSE-LLV(LOW,VAR8))/(HHV(HIGH,VAR8)-LLV(LOW,VAR8)))*(100),4,1);
VAR14:=SMA(((CLOSE-LLV(LOW,VAR9))/(HHV(HIGH,VAR9)-LLV(LOW,VAR9)))*(100),4,1);
VAR17:=SMA(((CLOSE-LLV(LOW,VARB))/(HHV(HIGH,VARB)-LLV(LOW,VARB)))*(100),4,1);
(SMA((VAR17-50)*(2),3,1)+SMA((VAR13-50)*(2),3,1))/(2),COLOR339933;
(SMA((VAR14-50)*(2),3,1)+SMA((VAR10-50)*(2),3,1))/(2),COLORFF9966;
(SMA((VAR13-50)*(2),3,1)+SMA((VARF-50)*(2),3,1))/(2),COLORFF9966;
(SMA((VAR12-50)*(2),3,1)+SMA((VARE-50)*(2),3,1))/(2),COLORFFFF00;
(SMA((VAR11-50)*(2),3,1)+SMA((VARD-50)*(2),3,1))/(2),COLORFFCC33,COLORFFFF99;
(SMA((VAR10-50)*(2),3,1)+SMA((VARC-50)*(2),3,1))/(2)COLORSTICK,COLORCYAN;
((3)*(VAR17-50))*(2)-(2)*(SMA((VAR17-50)*(2),3,1)),COLOR00FFFF;
VAR18:=(HIGH+LOW+CLOSE)/(3);
VAR19:=(VAR18-MA(VAR18,14))/((0.015)*(AVEDEV(VAR18,14)));
VAR1A:=(VAR18-MA(VAR18,70))/((0.015)*(AVEDEV(VAR18,70)));
VAR1B:=IF((VAR19>=150) AND (VAR19<200) AND (VAR1A>=150) AND (VAR1A<200),(-10),0);
VAR1C:=IF((VAR19<=(-150)) AND (VAR19>(-200)) AND (VAR1A<=(-150)) AND (VAR1A>(-200)),10,0);
VAR1D:=((CLOSE-MA(CLOSE,13))/(MA(CLOSE,13)))*(100);
VAR1E:=100-ABS(VAR1D);
IF((BARSCOUNT(CLOSE)<13),100,IF((VAR1E<88) AND (VAR1D>0),85,100)),COLORCCFFCC;
IF((BARSCOUNT(CLOSE)<13),(-100),0-IF((VAR1E<92) AND (VAR1D<0),85,100)),COLOR008000;
IF((BARSCOUNT(CLOSE)<70),120,IF((VAR1A>=200) AND (VAR19>=150),(-15),VAR1B)+120),COLORCCFF66;
IF((BARSCOUNT(CLOSE)<70),(-120),IF((VAR1A<=(-200)) AND (VAR19<=(-150)),15,VAR1C)-120),COLOR0000FF;

通达信震荡指标公式

 

相关文章