在线检测未来函数

通达信葫芦娃及选股指标公式

来源:Internet,编辑:股旁网,2016-08-31

AA:=SUMBARS(VOL,CAPITAL);
天量:=IF(CAPITAL=0,AMOUNT=HHV(AMOUNT,34),VOL>MA(VOL,AA)*33/10 ),NODRAW;
{DMI}
MTR2:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),5);
HD2 :=HIGH-REF(HIGH,1);
LD2 :=REF(LOW,1)-LOW;
DMP2:=EXPMEMA(IF(HD2>0 OR HD2>LD2,HD2,0),5);
DMM2:=EXPMEMA(IF(LD2>0 OR LD2>HD2,LD2,0),5);
PDI2:=DMP2*100/MTR2,COLORWHITE,LINETHICK3;
MDI2:=DMM2*100/MTR2,COLORYELLOW,LINETHICK2;
ADX2:=EXPMEMA(ABS(MDI2-PDI2)/(MDI2+PDI2)*100,6),COLORFF00FF;
ADXR2:=EXPMEMA(ADX2,6),COLORGREEN;
DRAWBAND(PDI2,RGB(100,0,50),MDI2,RGB(256,96,96));
{}
周MA:="MACD.MACD#WEEK" ,LINETHICK4;
AH1:=100*((EMA(EMA(H,26),9))-C);
ZM1:=COUNT(周MA<REF(周MA,1),5)>=1 AND 周MA>0;
ZM2:=COUNT(周MA>REF(周MA,1),5)>=1,;
葫芦娃:10*((COUNT(天量,120)>=1 AND (REF(CROSS(MDI2,PDI2),2) OR REF(CROSS(MDI2,PDI2),3) OR
(REF(PDI2>MDI2,2) AND REF(PDI2>MDI2,3))) AND (REF(MDI2>PDI2,1) OR (REF(MDI2>PDI2,1) AND
REF(MDI2>PDI2,2))) AND (CROSS(PDI2,MDI2) OR (PDI2>MDI2))) AND AH1<0 AND ZM2 AND
MA(C,20)>REF(MA(C,20),1)AND REF(O<MA(C,20),1) AND C>O);

{
选股公式:

AA:=SUMBARS(VOL,CAPITAL);
天量:=IF(CAPITAL=0,AMOUNT=HHV(AMOUNT,34),VOL>MA(VOL,AA)*33/10 );
MTR2:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),5);
HD2 :=HIGH-REF(HIGH,1);
LD2 :=REF(LOW,1)-LOW;
DMP2:=EXPMEMA(IF(HD2>0 OR HD2>LD2,HD2,0),5);
DMM2:=EXPMEMA(IF(LD2>0 OR LD2>HD2,LD2,0),5);
PDI2:=DMP2*100/MTR2,COLORWHITE,LINETHICK3;
MDI2:=DMM2*100/MTR2,COLORYELLOW,LINETHICK2;
ADX2:=EXPMEMA(ABS(MDI2-PDI2)/(MDI2+PDI2)*100,6),COLORFF00FF;
ADXR2:=EXPMEMA(ADX2,6),COLORGREEN;
周MA:="MACD.MACD#WEEK" ,LINETHICK4;
AH1:=100*((EMA(EMA(H,26),9))-C);
ZM1:=COUNT(周MA<REF(周MA,1),5)>=1 AND 周MA>0;
ZM2:=COUNT(周MA>REF(周MA,1),5)>=1,;
葫芦娃:(COUNT(天量,120)>=1 AND (REF(CROSS(MDI2,PDI2),2) OR REF(CROSS(MDI2,PDI2),3) OR
(REF(PDI2>MDI2,2) AND REF(PDI2>MDI2,3))) AND (REF(MDI2>PDI2,1) OR (REF(MDI2>PDI2,1) AND
REF(MDI2>PDI2,2))) AND (CROSS(PDI2,MDI2) OR (PDI2>MDI2))) AND AH1<0 AND ZM2 AND
MA(C,20)>REF(MA(C,20),1)AND REF(O<MA(C,20),1) AND C/REF(C,1)<1.05 AND C>O;
}

通达信葫芦娃及选股指标公式

 

相关文章