在线检测未来函数

飞狐跟庄通道主图指标公式

来源:Internet,编辑:股旁网,2016-09-13

N:=14;N1:=28;
均价:=(2*C+(H-L)/2+L)/3;
价差:=SUM(均价-REF(均价,1),2)/2;
高低:=(均价+价差);
实价:=(高低+均价)/2;
DIR:=ABS(实价-REF(实价,5));
VIR:=SUM(ABS(实价-REF(实价,1)),5);
ER:=DIR/VIR;
CS:=ER*(0.8-2/12)+2/12;
CQ:=CS*CS;
GD:EMA(DMA(实价,CQ),3),COLORWHITE,LINETHICK2;
Partline( GD/REF(GD,1)>0.997,GD),COLORYELLOW,LINETHICK2;
Partline(GD/REF(GD,1)>1.001,GD),COLORMAGENTA,LINETHICK2;
aa:=eMA(((SLOPE(实价,N)*20)+实价),N*3);
bb:=eMA(((SLOPE(均价,N)*20)+均价),N*3);
多空线:=(AA+bb)/2,COLORRED,PRECISION2,LINETHICK1;
角:=ATAN((多空线/ref(多空线,1)-1)*100)*180/3.1416,LINETHICK,COLORGREEN;
DRAWTEXT(filter(角>=30 and 多空线>ref(多空线,1),8),多空线*0.98,'∠30'),colorwhite,ALIGN0;
DK:=多空线;
FL:=DK+ABS(DK-REF(DK,1)),COLORWHITE;
FS:=2*DK-REF(DK,1),COLORWHITE;
BBI:IF(DK<FS,FS,DK),COLORRED,LINETHICK2;
PARTLINE(BBI>FS,BBI),COLOR00bb00,LINETHICK2;
行情1:=EMA(EMA(EMA((AA+BB)/2,7),21),63),COLORYELLOW,LINETHICK2;
AaA:=eMA(((SLOPE(实价,N*2)*20)+实价),n*6),COLORYELLOW,LINETHICK1;
BbB:=eMA(((SLOPE(均价,N*2)*20)+均价),n*6),COLORYELLOW,LINETHICK1;
行情2:=(AAA+BBB)/2,COLORWHITE,LINETHICK2;
行情线:=EMA((行情1+行情2)/2,n1),COLOR7F00FF,COLORYELLOW,LINETHICK2,PRECISION2;
CC:=(ABS(实价-DK)/DK+ABS(实价-行情线)/行情线+V/CAPITAL)/3;
中:DMA(均价,CC),COLORYELLOW;
上:(1+6.7/100)*中,COLORWHITE;
下:(1-6.7/100)*中,COLORGREEN;

飞狐跟庄通道主图指标公式

 

相关文章