在线检测未来函数

通达信MACD作战图指标公式

来源:Internet,编辑:股旁网,2016-09-13

{使用说明:0轴以上表多头,红柱(0轴上方死叉为白柱);0轴以下表空头,蓝柱(0轴下方金叉为浅蓝柱)。出现叠加黄柱为买入及持有阶段,0轴以下离0轴远的(不易量化)、一片蓝柱的,出现黄柱要谨慎。0轴附近的黄柱可能预示一只牛股。}

DIFF:EMA(C,5)-EMA(C,55),COLORWHITE;
DEA:EMA(DIFF,10),COLORGREEN;
MACD:=2*(DIFF-DEA);
STICKLINE(DEA>=0,DEA,0,1,0),COLORWHITE;
STICKLINE(DEA<0,DEA,0,1,0),COLORD4FF7F;
STICKLINE(DIFF<0,DIFF,0,1,0),COLORB00058;
STICKLINE(DIFF>=0,DIFF,0,1,0),COLORRED;
JJ:=(CLOSE+HIGH+LOW)/3;
E:=EMA(JJ,5);
D:=REF(E,1);
持股:STICKLINE(DEA>=0 AND DIFF>=0 AND E>D,DIFF,DEA,2,0),LINETHICK1,COLORYELLOW;
STICKLINE(DEA>=0 AND DIFF<0 AND E>D,DIFF,0,2,0),LINETHICK1,COLORYELLOW;
STICKLINE(DEA<0 AND DIFF>=0 AND E>D,DEA,0,2,0),LINETHICK1,COLORYELLOW;
STICKLINE(DEA<0 AND DIFF<0 AND E>D,DEA,DIFF,2,0),LINETHICK1,COLORYELLOW;

通达信MACD作战图指标公式

 

相关文章