在线检测未来函数

同花顺趋势顶底金叉指标公式

来源:Internet,编辑:股旁网,2016-09-18

龙值:100-100*(HHV(HIGH,5*8)-CLOSE)/(HHV(HIGH,5*8)-LLV(LOW,5*8)),DOTLINE,LineThick1;
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
长期线:A+100,colorcyan,LINETHICK2;
短期线:B+100,colormagenta;
中期线:D+100,coloryellow,LINETHICK2;
变速率:(中期线-长期线),COLORSTICK;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:3*K-2*D,colorwhite;
VARC:=(2*C+H+L)/4;
VARE:=LLV(L,26);
VAR11:=HHV(H,34);
VAR12:=EMA((VARC-VARE)/(VAR11-VARE)*100,16);
VAR13:=EMA(VAR12,4);
压力线:IF(35+EMA(VAR13,80)<100,35+EMA(VAR13,80),100),ColorD98719,LineThick2;
中短50买:中期线>=短期线+50;
DRAWICON(中短50买,-5,1);
DRAWTEXT(中短50买,-10,'五买'),coloryellow;
中短50买长:(中短50买 AND 中期线>=长期线);
DRAWICON(中短50买长,110,7);
DRAWTEXT(中短50买长,115,'五长'),coloryellow;
中短50卖:短期线>=中期线+50;
DRAWICON(中短50卖,110,5);
DRAWTEXT(中短50卖,115,'五卖'),coloryellow;
多:SUM(IF(变速率>0,变速率*1.003,变速率*1.003>0),34)/34,colormagenta;
空:SUM(IF(变速率<=0,变速率*0.97,变速率*0.97<0),34)/34,colorgreen;
见顶:=((REF(中期线,1)>85 AND REF(短期线,1)>85 AND REF(长期线,1)>65) AND CROSS(长期线,短期线));
顶部区域:(中期线<REF(中期线,1) AND REF(中期线,1)>80) AND (REF(短期线,1)>95 OR REF(短期线,2)>95 ) AND 长期线>60 AND 短期线<83.5
AND 短期线<中期线 AND 短期线<长期线+4,colorgreen;
顶部:=FILTER(顶部区域,4);
STICKLINE(顶部,99,103,20,1 ),colorred,LINETHICK2;
底部区域:(长期线<12 AND 中期线<8 AND (短期线<7.2 OR REF(短期线,1)<5) AND (中期线>REF(中期线,1) OR 短期线>REF(短期线,1)))
OR (长期线<8 AND 中期线<7 AND 短期线<15 AND 短期线>REF(短期线,1)) OR (长期线<10 AND 中期线<7 AND 短期线<1) ,colorgreen;
STICKLINE( 底部区域,-4,0,22,0 ),colorgreen;
低位金叉:50*(长期线<15 AND REF(长期线,1)<15 AND 中期线<18 AND 短期线>REF(短期线,1) AND CROSS(短期线,长期线) AND 短期线>中期线
AND (REF(短期线,1)<5 OR REF(短期线,2)<5 ) AND (中期线>=长期线 OR REF( 短期线,1)<1 )),colorred;
STICKLINE( 低位金叉,0,5,11,0 ),colorred;
短买:CROSS(短期线,中期线);
短买长:短买 AND 中期线>=长期线;
STICKLINE(短买长,105,110,8,0 ),ColorD98719;
短60买:短期线<=REF(短期线,1)-60;
DRAWICON(短60买,80,3);
DRAWTEXT(短60买,75,'六买'),coloryellow;
短60买长:短60买 AND 中期线>=长期线;
DRAWICON(短60买长,88,1);
DRAWTEXT(短60买长,93,'六长'),coloryellow;
短60卖:短期线>=REF(短期线,1)+60;
DRAWICON(短60卖,96,2);
DRAWTEXT(短60卖,90,'六卖'),coloryellow;
STICKLINE(CROSS(中期线,长期线),95,103,8,0 ),colorcyan;
STICKLINE(CROSS(长期线,中期线),95,103,8,0 ),coloryellow;
STICKLINE(CROSS(中期线,压力线),95,103,8,0 ),colorred;
MACD2:=变速率;
DIF:=中期线;
DEA:=长期线;
STICKLINE(MACD2>=0 AND MACD2>REF(MACD2,1),0,MACD2,8,1),colorblue;
STICKLINE(MACD2>=0 AND MACD2<REF(MACD2,1),0,MACD2,8,1),colorcyan;
STICKLINE(MACD2<0 AND MACD2<REF(MACD2,1),0,MACD2,8,1),colorwhite;
STICKLINE(MACD2<0 AND MACD2>REF(MACD2,1),0,MACD2,8,1),colormagenta;
建仓:IF(DIF<0,DIF,0),coloryellow,LINETHICK2;
加仓:IF(DIF<0,0,DIF),colormagenta,LINETHICK2;
白线破仓:IF(DIF<DEA,DIF,DEA),colorwhite,LINETHICK2;
趋势强弱:IF(DIF>DEA,DEA,DEA),Color32CD99,LINETHICK2;
TJ:=MACD2>0;T:=MACD2<0;
DRAWTEXT(BARSLAST(TJ)=1,MACD2,'1'),coloryellow;
DRAWTEXT(BARSLAST(TJ)=2,MACD2,'2'),coloryellow;
DRAWTEXT(BARSLAST(TJ)=3,MACD2,'3'),coloryellow;
DRAWTEXT(BARSLAST(TJ)=5,MACD2,'5'),coloryellow;
DRAWTEXT(BARSLAST(TJ)=8,MACD2,'8'),coloryellow;
DRAWTEXT(BARSLAST(TJ)=13,MACD2,'13'),coloryellow;
DRAWTEXT(BARSLAST(TJ)=21,MACD2,'21'),coloryellow;
DRAWTEXT(BARSLAST(TJ)=34,MACD2,'34'),coloryellow;
DRAWTEXT(BARSLAST(TJ)=55,MACD2,'55'),coloryellow;
DRAWTEXT(BARSLAST(T)=1,MACD2,'1'),colorgreen;
DRAWTEXT(BARSLAST(T)=2,MACD2,'2'),colorgreen;
DRAWTEXT(BARSLAST(T)=3,MACD2,'3'),colorgreen;
DRAWTEXT(BARSLAST(T)=5,MACD2,'5'),colorgreen;
DRAWTEXT(BARSLAST(T)=8,MACD2,'8'),colorgreen;
DRAWTEXT(BARSLAST(T)=13,MACD2,'13'),colorgreen;
DRAWTEXT(BARSLAST(T)=21,MACD2,'21'),colorgreen;
DRAWTEXT(BARSLAST(T)=34,MACD2,'34'),colorgreen;
DRAWTEXT(BARSLAST(T)=55,MACD2,'55'),colorgreen;

同花顺趋势顶底金叉指标公式

 

相关文章