在线检测未来函数

通达信超前优化MACD指标公式

来源:Internet,编辑:股旁网,2016-09-22

重心1:=(2*C+H+L+O)/5;
BBI1:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
偏差量1:=重心1-BBI1;
RSV1:=(偏差量1-LLV(偏差量1,9))/(HHV(偏差量1,9)-LLV(偏差量1,9))*100;
K1:=SMA(RSV1,3,1);
D1:=SMA(K1,3,1);
DIF1:=EMA(CLOSE,6) - EMA(CLOSE,13);
DEA1:=EMA(DIF1,5);
MACD1:=2*(DIF1-DEA1),STICK;
MACD2:=EMA(MACD1,3);
STICKLINE(MACD1>MACD2,0,MACD1,1,0),COLOR0000EE;
STICKLINE(MACD1>MACD2,0,MACD1,0.5,0),COLOR5555FF;
STICKLINE(MACD1>MACD2,0,MACD1,0.2,0),COLOR8080FF;
STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLOR2BAA00;
STICKLINE(MACD1<MACD2,0,MACD1,0.5,0),COLOR35D500;
STICKLINE(MACD1<MACD2,0,MACD1,0.2,0),COLOR40FF00;
DIF8: DIF1,COLORRED,LINETHICK2;
DEA8: DEA1,COLORYELLOW,LINETHICK2;
IF(DIF8<DEA8,DIF8,DRAWNULL),LINETHICK2,COLORGREEN;
IF(DIF8<DEA8,DEA8,DRAWNULL),LINETHICK2,COLORFF8000;

通达信超前优化MACD指标公式

 

相关文章