在线检测未来函数

通达信多周期共振MACD指标公式

来源:Internet,编辑:股旁网,2016-09-23

DIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA1:=EMA(DIF1,9);
MACD1:(DIF1-DEA1)*2,COLORSTICK;
DIF11:=EMA(CLOSE,16) - EMA(CLOSE,34.5);
DEA11:=EMA(DIF11,12);
MACD11:(DIF11-DEA11)*2,COLORSTICK;
DRAWBAND(DIF1,RGB(155,50,50),DEA1,RGB(0,100,50));
DIF:=EMA(CLOSE,6) - EMA(CLOSE,13);
DEA:=EMA(DIF,4.5);
MACD:(DIF-DEA)*2,COLORSTICK;
STICKLINE(MACD11>0,0,MACD11,1.5,0),COLOR8800FF;
STICKLINE(MACD11<0,0,MACD11,1.5,0),COLORFFFF00;
STICKLINE(MACD1>0,0,MACD1,1,0),COLORRED;
STICKLINE(MACD1<0,0,MACD1,1,0),COLORBLUE;
STICKLINE(MACD>0,0,MACD,0.5,0),COLORYELLOW;
STICKLINE(MACD<0,0,MACD,0.5,0),COLOR00DD00;
DIFFFF:DIF11,COLOR8800FF,LINETHICK0;
DEAAAA:DEA11,COLORFFAA00,LINETHICK0;
DIFFF:DIF1,COLORRED,LINETHICK0;
DEAAA:DEA1,COLORBLUE,LINETHICK0;
DIFF:DIF,COLORYELLOW,LINETHICK0;
DEAA:DEA,COLORGREEN,LINETHICK0;
动力线:MA(MACD1,5),,COLORYELLOW,LINETHICK1;
中区:0,COLORBLUE,LINETHICK0;
主动:IF(MACD1>=动力线 AND 动力线<=中区,动力线,DRAWNULL),COLORYELLOW,LINETHICK2;
主拉:IF(动力线>=中区,动力线,DRAWNULL),COLORRED,LINETHICK2;
翻空:IF(动力线<中区 AND 动力线>MACD1,动力线,DRAWNULL),COLORGREEN,LINETHICK2;
AA:=BARSLAST(REF(CROSS(DIF1,DEA1),1));
BB:=REF(CLOSE,AA+1)>CLOSE AND DIF1>REF(DIF1,AA+1) AND CROSS(DIF1,DEA1);
JCCOUNT:=COUNT(CROSS(DIF1,DEA1),BARSLAST(DEA1>=0));
二金:=CROSS(DIF1,DEA1) AND DEA1<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWICON(二金,DEA*1.04,15) ;
DRAWTEXT(二金,-0.02,' 2'),COLORFF00FF;
VAR1:=EMA(CLOSE,12)-EMA(CLOSE,25);
VAR2:=EMA(VAR1,3);
VAR3:=VAR1>VAR2;
VAR4:=VAR1<VAR2;
STICKLINE(VAR3,VAR1,VAR2,1,0),COLORRED;
STICKLINE(VAR4,VAR1,VAR2,1,0),COLORGREEN;

通达信多周期共振MACD指标公式

 

相关文章