在线检测未来函数

通达信冠军1号VOL指标公式

来源:Internet,编辑:股旁网,2016-09-26

股价:VOL,VOLSTICK;
短3:=XMA(XMA(股价,3),3),LINETHICK0,COLORWHITE;
短5:=XMA(XMA(股价,5),5),LINETHICK0,COLORWHITE;
短6:=XMA(XMA(股价,6),6),LINETHICK0,COLORWHITE;
短7:=XMA(XMA(股价,8),8),LINETHICK0,COLORWHITE;
短8:=XMA(XMA(股价,10),10),LINETHICK0,COLORWHITE;
短9:=XMA(XMA(股价,12),12),LINETHICK0,COLORWHITE;
短中:=(短7+短8+短9+短3+短5+短6)/6,LINETHICK0,COLORWHITE;
短顶:=短中*1.35,LINETHICK0,COLORGREEN;
短底:=短中*0.65,LINETHICK0,COLORGREEN;
中1:=XMA(XMA(股价,16),16),LINETHICK0,COLORWHITE;
中2:=XMA(XMA(股价,19),19),LINETHICK0,COLORWHITE;
中3:=XMA(XMA(股价,22),22),LINETHICK0,COLORWHITE;
中4:=XMA(XMA(股价,25),25),LINETHICK0,COLORWHITE;
中5:=XMA(XMA(股价,28),28),LINETHICK0,COLORWHITE;
中6:=XMA(XMA(股价,31),31),LINETHICK0,COLORWHITE;
中中2:=(中1+中2+中3+中4+中5+中6)/6,LINETHICK0,COLORGREEN;
中顶2:=中中2*1.4,LINETHICK0,COLORGREEN;
中底2:=中中2*0.6,LINETHICK0,COLORGREEN;
中40:=XMA(XMA(股价,40),40),LINETHICK0;
中50:=XMA(XMA(股价,50),50),LINETHICK0;
中60:=XMA(XMA(股价,60),60),LINETHICK0;
中中3:=(中40+中50+中60)/3,LINETHICK0,COLORWHITE;
中顶3:=中中3*1.5,LINETHICK0,COLORRED;
中底3:=中中3*0.5,LINETHICK0,COLORRED;
长90:=XMA(XMA(股价,90),90),LINETHICK0,COLORWHITE;
长120:=XMA(XMA(股价,120),120),LINETHICK0,COLORWHITE;
长150:=XMA(XMA(股价,150),150),LINETHICK0,COLORWHITE;
长中:=(长90+长120+长150)/3,LINETHICK0,COLORYELLOW;
长顶:=长中*1.3,LINETHICK1,COLORWHITE;
长顶顶:=长中*1.8,LINETHICK1,COLORRED;
长底:=长中*0.5,LINETHICK1,COLORYELLOW;
MA短中:=EMA(短中,10),LINETHICK0,COLORWHITE;
MA中中2:=EMA(中中2,10),LINETHICK0,COLORGREEN;
V2:IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1),NODRAW,COLORRED;
STICKLINE(V2>=1,0,VOL,2,0),COLORYELLOW;
VVOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
大底VOL:=短底<中底2 AND 中底2<中底3 AND 中底3<长底,LINETHICK5,COLORRED;
中底VOL:=短底<中底2 AND 中底2>中底3 AND 中底2<长底,LINETHICK2,COLORGREEN;
小底VOL:=短底<中底2 AND 中底2<中底3 AND 中底2>长底,LINETHICK1,COLORYELLOW;
STICKLINE(中中2>MA中中2,0,VOL,2,1),COLORFF00FF;
STICKLINE(短中>MA短中,0,VOL,2,0),COLORRED;
STICKLINE(中中2>MA中中2 AND VOL<长底,0,VOL,3,0),COLORWHITE;
STICKLINE(中中2>MA中中2 AND VOL<中底3 AND VOL<中底2 AND VOL>长底,0,VOL,3,0),COLORBLUE;
STICKLINE(中中2<MA中中2,0,VOL,2,0),COLORGREEN;
STICKLINE(中中2<MA中中2 AND 短中>MA短中,0,VOL,2,0),COLORYELLOW;
STICKLINE(中底VOL=1 OR 小底VOL=1,0,VOL,2,0),COLORBLUE;
STICKLINE(中中3>REF(中中3,1) AND 股价<长底,0,VOL,3,0),COLORWHITE;
DRAWRECTREL(0,250,175,999.4,IF(120,RGB(10,0,0),0));
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S),NODRAW;
大单:=(超B)-(超S),NODRAW;
大单:=(大B)-(大S),NODRAW;
中单:=(中B)-(中S),NODRAW;
小单:=(小B)-(小S),NODRAW;
DAZHI:=CONST(MAX(ABS(净流入),MAX(ABS(超大单),MAX(ABS(大单),MAX(ABS(中单),ABS(小单)))))),NODRAW;
DRAWRECTREL(0,CONST(830-(ABS(超大单)*500/DAZHI)),30,935,IF(CONST(超大单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(35,CONST(830-(ABS(大单)*500/DAZHI)),65,935,IF(CONST(大单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(70,CONST(830-(ABS(中单)*500/DAZHI)),100,935,IF(CONST(中单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(105,CONST(830-(ABS(小单)*500/DAZHI)),135,935,IF(CONST(小单)>0,RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(140,CONST(830-(ABS(净流入)*500/DAZHI)),170,935,IF(CONST(净流入)>0,RGB(255,0,0{255,255,255}),RGB(23,125,255)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.002,0.25,0,'资金搏弈 (万元)'),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.002,0.55,0,INTPART(超大单)),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.035,0.555,0,INTPART(大单)),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.070,0.550,0,INTPART(中单)),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.106,0.55,0,INTPART(小单)),COLORYELLOW;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.145,0.55,0,INTPART(净流入)),COLORYELLOW;
冠军1号QQ:=474131998;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.002,1,0,'超大'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.040,1,0,'大单'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.075,1,0,'中单'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.112,1,0,'小单'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.145,1,0,'净流'),COLORYELLOW;

通达信冠军1号VOL指标公式

 

相关文章