在线检测未来函数

大智慧非常给力的综合主图指标公式

来源:Internet,编辑:股旁网,2016-09-27

MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA30:MA(CLOSE,30);
MA60:MA(CLOSE,60),COLORCYAN;
MA120:MA(CLOSE,120),Colorff6633;
DRAWTEXTABS(30,10,'MA5 天均线:'+MA5),LINETHICK5;
DRAWTEXTABS(30,40,'MA10天均线:'+MA10),LINETHICK5;
DRAWTEXTABS(30,70,'MA20天均线:'+MA20),LINETHICK5;
DRAWTEXTABS(30,100,'MA30天均线:'+MA30),LINETHICK5;
DRAWTEXTABS(30,130,'MA60天均线:'+MA60),COLORCYAN,LINETHICK5;
DRAWTEXTABS(30,160,'MA120 天均线:'+MA120),Colorff6633,LINETHICK5;
a:="LTFunc4@FORLT2";
s1:="LTFunc4@LT_S1";
hs:="LTFunc4@LT_HS";
ls:="LTFunc4@LT_LS";
p1:="LTFunc4@LT_P1";
upp:="LTFunc4@LT_UPP";
udd:="LTFunc4@LT_UDD";
d1:=ema(abs("ddx.ddx"),60);
d2:=max("ddx.ddx"/d1+7.5,7.5);
d3:=min("ddx.ddx"/d1,10);
fb:=if(s1=0,hs,ls);
tr0:=ifs(p1=1,'明日收盘价<'+numtostrn(udd,2)+',出现S点\n','若明日收盘价>'+numtostrn(upp,2)+',出现B点\n');
{DRAWTEXT(p1=1 ,udd ,numtostrn(udd,2)+'s点' ),move1;DRAWTEXT(p1<>1,upp,numtostrn(upp,2)+'b点'),move1;}
DRAWTEXT(barstatus=2 ,ref(udd,1),numtostrn(ref(udd,1),2)+'S点');
DRAWTEXT(barstatus=2 ,ref(upp,1),numtostrn(ref(upp,1),2)+'B点');
{a3:if(93000<=time<=150000,ref((a1 or a2),1),a1 or a2);}
tr1:=ifs(s1=1,'明日收盘价<'+numtostrn(ls,2)+',短线卖出机会','若明日收盘价>'+numtostrn(hs,2)+'短线买入机会');
DRAWTEXT(barstatus=2,ref(ls,1),numtostrn(ref(ls,1),2)+'短卖'),move2;
DRAWTEXT(barstatus=2,ref(hs,1),numtostrn(ref(hs,1),2)+'短买'),move2;
tr2:=ifs(p1=1,ifs(cross(p1,0),'B点','持股'),ifs(cross(1,p1),'S点','持币'));
tr3:=ifs(s1=0,'向下,','向上,');
tr4:='3.能量级别:'+numtostrn(d3,1)+'级';
bs:=datestr(date)+'买卖点决策系统提示\n'+'1.BS点:'+tr2+','+tr0+'2.短线:'+tr3+tr1+'\n'+tr4;
drawflagtext(1,fb,bs);
STICKLINE(p1=1 and c>=o and o<>0,c,o,d2,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,c,o,7.5,0),colorblack;
STICKLINE(p1=1 and c>=o and o<>0,c,c,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,o,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<o,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<o,l,c,0.5,1),color5454ff;
STICKLINE(p1=1 and c<o,h,o,0.5,1),color5454ff;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,o,7.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,h,0.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,l,o,0.5,1),colorffff54;
drawbmp(p1=1 and ref(p1,1)=0,l,'buy1.bmp'),align1,valign0;
drawbmp(p1=0 and ref(p1,1)=1,h,'sell1.bmp'),align1,valign2;
drawbmp(s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))<>1,l,'bs.bmp'),align1,valign0;
drawbmp(s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))<>1,h,'ss.bmp'),align1,valign2;
总股本:=FINANCE2(35) ;
流通股:=FINANCE2(37);
限售A股:=FINANCE2(41);
每股收益:=FINANCE2(3);
市盈率:=DYNAINFO(39);
每股公积金:=FINANCE2(7);
所属板块:=BKNAME;
DRAWTEXTABS(320,14, '所属板块: '+所属板块){,COLORYELLOW};
DRAWTEXTABS(320,27,'每股收益: '+NUMTOSTRN(每股收益,3)+'元 利润增长:'+FINANCE2(10)+'% 市盈率:'+NUMTOSTRN(市盈率,1)+'倍 '+' 每股公积金:'+NUMTOSTRN(每股公积金,2)+'元'){,COLORYELLOW};
DRAWTEXTABS(320,40,'总 股 本: '+NUMTOSTRN(总股本,2)+'万股'+'流通A股:'+NUMTOSTRN(流通股,2)+'万股'+'限售A股:'+NUMTOSTRN(限售A股,2)+'万股'){,COLORYELLOW};
DRAWTEXTABS(320,53,'主 题 库:'+SELFSTRING('主题'));

大智慧非常给力的综合主图指标公式

 

相关文章