在线检测未来函数

通达信均线彩带主图指标公式

来源:Internet,编辑:股旁网,2016-09-30

DRAWBAND(MA(CLOSE,60),RGB(25,0,25),MA(CLOSE,90),RGB(16,16,16));
DRAWBAND(MA(CLOSE,20),RGB(255,255,0),MA(CLOSE,30),RGB(95,95,95));
DRAWBAND(MA(CLOSE,10),RGB(255,0,0),MA(CLOSE,20),RGB(85,150,255));
MA5:=MA(CLOSE,5),COLORFFFFFF,NODRAW;
MA10:MA(CLOSE,10),COLOR00FFFF,NODRAW;
MA20:MA(C,20),COLORFF00FF,LINETHICK1;
MA30:MA(C,30),COLOR00FF00,NODRAW;
MA60:=MA(CLOSE,60),COLORFF9988;
MA90:MA(CLOSE,90),COLOR999999;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
BDGD:=C=HHV(C,13);
GDSJ:=BARSLAST(FILTER(CROSS(0.8,BDGD),2))+1;
高点:REF(C,GDSJ),COLORFF00FF,POINTDOT;
突破:CROSS(C,REF(高点,1)),COLOR00FFFF,POINTDOT,NODRAW;
STICKLINE(GDSJ<=6,高点,高点,3,0),COLORFF00FF;
DRAWTEXT(突破,LOW,'↑'),COLOR00FFFF;
BDDD:=C=LLV(C,13);
DDSJ:=BARSLAST(FILTER(CROSS(0.8,BDDD),2))+1;
低点:REF(C,DDSJ),COLOR00FF00,POINTDOT;
STICKLINE(DDSJ<=6,低点,低点,3,0),COLOR00FF00;
STICKLINE(CLOSE>OPEN OR CLOSE=OPEN
AND CLOSE>REF(CLOSE,1),LOW,HIGH,0,0),COLORRED;
STICKLINE(CLOSE>OPEN OR CLOSE=OPEN
AND CLOSE>REF(CLOSE,1),OPEN,CLOSE,3,0),COLORRED;
STICKLINE(CLOSE<OPEN OR CLOSE=OPEN
AND CLOSE<=REF(CLOSE,1),LOW,HIGH,0,0),COLORCYAN;
STICKLINE(CLOSE<OPEN OR CLOSE=OPEN
AND CLOSE<=REF(CLOSE,1),OPEN,CLOSE,3,0),COLORCYAN;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR008800;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR009900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00AA00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0.8,0 ),COLOR00BB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0.6,0 ),COLOR00CC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0.4,0 ),COLOR00DD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0.2,0 ),COLOR00EE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0.1,0 ),COLOR00FF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLORFFBBFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLORFF00FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLORFF22FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLORFF44FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.8,0) ,COLORFF66FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.6,0) ,COLORFF88FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.4,0) ,COLORFF99FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.2,0) ,COLORFFAAFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.1,0) ,COLORFFBBFF;

通达信均线彩带主图指标公式

 

相关文章