在线检测未来函数

通达信安全图解指标公式

来源:Internet,编辑:股旁网,2016-09-01

RSVA1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
RSVA2:=100*(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9));
VAR21:=SMA(RSVA2,9,1)+100;
VAR11:=SMA(RSVA1,3,1);
VAR51:=SMA(VAR11,3,1)+100;
顶底线:=VAR51-VAR21+50;
VAR2:=LLV(LOW,33);
VAR3:=HHV(HIGH,21);
VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*100,10)*-1+100;
趋势:=100-EMA(0.191*REF(VAR4,1)+0.809*VAR4,1);
STICKLINE(C,100,90,4,0),COLORFFCC33;
STICKLINE(C,90,80,4,0),COLORFF9933;
STICKLINE(顶底线>REF(顶底线,1),20,80,4,0),COLOR9999FF;
STICKLINE(顶底线<REF(顶底线,1),20,80,4,0),COLOR009966;
STICKLINE((趋势>REF(趋势,1) AND 顶底线<REF(顶底线,1)),20,80,4,0),COLOR9999FF;
STICKLINE((趋势<REF(趋势,1) AND 顶底线>REF(顶底线,1)),20,80,4,0),COLOR009966;
STICKLINE(C,20,10,4,0),COLORFF6633;
STICKLINE(C,10,0,4,0),COLORFF3333;
底线:10,COLORWHITE;
顶线:90,COLORWHITE;
趋势线:100-EMA(0.191*REF(VAR4,1)+0.809*VAR4,1),LINETHICK2,COLORBLUE;
当前安全度:100-EMA(0.191*REF(VAR4,1)+0.809*VAR4,1),CIRCLEDOT,LINETHICK2,COLORRED;
DRAWTEXT(CURRBARSCOUNT=6,5,'高安全区'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=6,15,'安全区'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=6,45,'绿区持币'),COLORFFC000;
DRAWTEXT(CURRBARSCOUNT=6,50,'(投资区)'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=6,55,'粉区持股'),COLORFFC000;
DRAWTEXT(CURRBARSCOUNT=6,85,'风险区'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=6,95,'高风险区'),COLORWHITE;

通达信安全图解指标公式

 

相关文章