在线检测未来函数

通达信直观筹码KDJ指标公式

来源:Internet,编辑:股旁网,2016-09-01

M1:=3;
M2:=3;
获利筹码:EMA(WINNER(C)*70,5),COLORRED;
亏损筹码:EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,5),COLORF0FF00;
STICKLINE(亏损筹码>0,0,亏损筹码,2.5,0),COLOR66FF00;
主力控筹:IF(获利筹码>亏损筹码,获利筹码*2,获利筹码),,COLORRED;
STICKLINE(主力控筹>0,0,主力控筹,2.5,0),COLORFFFFFF;
STICKLINE(获利筹码>0,0,获利筹码,2.5,0),COLORFFFFFF;
动态底部:EMA(IF(L<= LLV(L,30),SMA(ABS(L-REF(L,1)),30,1)/SMA(MAX(L-REF(L,1),0),30,1),0),3)*10;
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
STICKLINE(((CLOSE > 0) AND DAY=2),20,121,40,1),COLORFFFFFF;
STICKLINE(((SAT <= 5) AND DAY=2),21,(20 + SAT),35,0),COLORFFFFFF;
STICKLINE((((SAT > 5) AND (SAT <= 20)) AND DAY=2),21,(20 + SAT),35,0),COLORCCFF88;
STICKLINE((((SAT > 20) AND (SAT <= 40)) AND DAY=2),21,(20 + SAT),35,0),COLORFF00FF;
STICKLINE(((SAT > 40) AND DAY=2),21,(20 + SAT),35,0),COLOR0000FF;
RSV:= (CLOSE-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
K:SMA(RSV,M1,1),COLORRED,LINETHICK2;
D:SMA(K,M2,1),COLORYELLOW,LINETHICK2;
J:3*K-2*D,COLORBLUE,LINETHICK2;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,30);
VAR6:=HHV(VAR4,30);
VAR7:=IF(MA(CLOSE,58),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=IF(VAR8>100,100,VAR8);
庄来了别放过:STICKLINE(VAR9>-120,0,VAR9,6,1),COLORRED;

通达信直观筹码KDJ指标公式

 

相关文章