在线检测未来函数

大智慧K线重心趋势主图指标公式

来源:Internet,编辑:股旁网,2016-09-09

DRAWGBKlast(c>0,strip(RGB(0,0,0),RGB(60,0,80),0));
{1.K线重心}
HL8:(MA(H,8)+MA(L,8))/2,COLOR00ff00,LINETHICK1;
MC8:EMA(C,8),COLOR0000ff,LINETHICK1;
fillrgn(HL8,MC8,HL8<MC8,RGB(150,0,0),HL8>MC8,RGB(0,150,0)),LAYER7;
{2.k线.正常上涨}
STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),COLOR0000ff;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5,0 ),COLOR0000ff;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLOR000077;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR0000bb;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR0000cc;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR0000dd;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000ee;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000ff;
{3.k线.正常下跌}
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5,0 ),COLORffFF00;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5,0 ),COLORffff00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLORff7700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLORff9900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLORffbb00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLORffcc00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLORffdd00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORffee00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORffFF00;
{4.K线带帽已见顶}
中:EMA(CLOSE,55),color999999,LINETHICK0;
顶:中*1.1,POINTDOT,COLORFF9900,LINETHICK3;
stickline((CLOSE >= 顶),H ,H*1.003,4,0),color00ffff;
{5.脚底穿鞋正在跌}
买:=EMA(C,3);
卖:=EMA(SLOPE(C,21)*21+C,43);
stickline(买<卖,L ,L*0.997,4,0),color00FF00;
{6.金黄K线转向升}
STICKLINE(cross(买,卖) ,CLOSE ,OPEN,6,0),COLOR0099ff,LAYER0;
STICKLINE(cross(买,卖),LOW,HIGH,2,0 ),COLOR0099ff;
{7.白色K线转向跌}
STICKLINE(cross(卖,买),CLOSE ,OPEN,6,0),COLORFFFFFF,LAYER0;
STICKLINE(cross(卖,买),LOW,HIGH,2,0 ),COLOR00FFff;
DRAWTEXTABS(0,5,'【1】头顶带帽已见顶'),Color00ffff,LINETHICK2;
DRAWTEXTABS(140,5,'【2】脚底穿鞋跌势'),Color00ff00,LINETHICK2;
DRAWTEXTABS(0,25,'【3】金黄K线转向升'),Color0099ff,LINETHICK2;
DRAWTEXTABS(140,25,'【4】白色K线转向跌'),ColorFFffff,LINETHICK2;
X:=BARSLAST(DISPSTATUS=1)+1;
P:=BACKSET(DISPSTATUS=2,X/2+1);
K:=BARSLAST(CROSS(P,0.5))+1;
KJ:=HHVALL(HIGH)-LLVALL(LOW);
平衡:=IF(K>=0,LLVALL(LOW)+KJ/2,0);
压力:=IF(K>=0,HHVALL(HIGH)-KJ*0.191,平衡);
支撑:=IF(K>=0,LLVALL(LOW)+KJ*0.191,平衡);
DRAWRECTABS(280,1,300+(HHVALL(HIGH))*300/C ,80 ,rgb(0,0,255)),Color0000FF,LINETHICK2,LAYER3;
DRAWRECTABS(285,4,300+(压力)*300/C ,70 ,rgb(140,0,60)),Color99FF99,LAYER2;
DRAWRECTABS(290,7,300+(平衡)*300/C ,60 ,rgb(0,120,0)),Colorff00FF,LAYER1;
DRAWRECTABS(295,10,300+(支撑)*300/C ,50 ,rgb(80,0,80)),Color00ffFF,LAYER0;
DRAWRECTABS(300,21,300+(C)*300/C ,39 ,rgb(10,10,10)),Color0077FF,LINETHICK1,LAYER0;
DRAWTEXTABS(270,90,'【支撑 '+NUMTOSTRn(支撑,2)+' 元】'),Color00FFff,LINETHICK2,LAYER0;
DRAWTEXTABS(405,90,'【平衡 '+NUMTOSTRn(平衡,2)+' 元】'),Color44FF99,LINETHICK2,LAYER0;
DRAWTEXTABS(540,90,'【压力 '+NUMTOSTRn(压力,2)+' 元】'),Color0044FF,LINETHICK2,LAYER0;
DRAWTEXTABS(320,23,'【四区周期:--→ '+K+'天】'),Color00FFFF,LINETHICK2,LAYER0;

大智慧K线重心趋势主图指标公式

 

相关文章