在线检测未来函数

通达信金玉良缘主图指标公式

来源:Internet,编辑:股旁网,2016-09-08

AA1:=MA(CLOSE,1);
AA2:=SMA(SMA(SMA(AA1,2,1),2,1),2,1);
AA3:=MA(AA2,3);
止损线:IF(LLV(MA(AA2,8),3)<AA2,LLV(MA(AA2,8),3),AA2),POINTDOT,LINETHICK1,COLORWHITE;
工作区:IF(AA2>AA3,AA2,DRAWNULL),COLOR0000DD,LINETHICK5;
休息区:IF(AA2<AA3,AA2,DRAWNULL),COLOR009900,LINETHICK4;
撑压线:HHV(MA(AA2,1),13),COLOR00FFFF;
AA4:=(2*CLOSE+HIGH+LOW)/4;
AA5:=MA(AA4,7);
AA6:=AA5-MA(AA4,7/2)<0;
AA7:=AA5-MA(AA4,7/2)>0;
AA8:=BARSLAST(AA6);
AA9:=0-BARSLAST(AA7);
STICKLINE(撑压线>AA2 AND AA2>AA3,撑压线,AA2,0,0),COLORBLUE;
STICKLINE(撑压线>AA3 AND AA2<AA3,撑压线,AA3,0,0),COLORBLUE;
AA0:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
BB1:=REF(AA0,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
BB2:=REF(BB1,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
BB3:=REF(BB2,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
BB4:=REF(BB3,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
BB5:=REF(BB4,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
BB6:=REF(BB5,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
BB7:=REF(BB6,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
BB8:=REF(BB7,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
BB9:=REF(BB8,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
BB0:=REF(BB9,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
CC1:=REF(BB0,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
CC2:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
CC3:=REF(CC2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
CC4:=REF(CC3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
CC5:=REF(CC4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
CC6:=REF(CC5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
CC7:=REF(CC6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
CC8:=REF(CC7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
CC9:=REF(CC8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
CC0:=REF(CC9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
DD1:=REF(CC0,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
DD2:=REF(DD1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
DD3:=REF(DD2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
DD4:=(REF((((((((((((CC2 OR CC3) OR CC4) OR CC5) OR CC6) OR CC7)
OR CC8) OR CC9) OR CC0) OR DD1) OR DD2) OR DD3),1) AND AA0);
DD5:=XMA(HIGH,21);
DD6:=MA(HIGH,9);
DD7:=LONGCROSS(DD5,DD6,1);
DD8:=(REF((((((((((((AA0 OR BB1) OR BB2) OR BB3) OR BB4) OR BB5) OR BB6)
OR BB7) OR BB8) OR BB9) OR BB0) OR CC3),1) AND CC4);
STICKLINE(DD8,OPEN,CLOSE,2,0),COLOR00FF00;
DD9:=AMOUNT/(VOL);
DD0:=MA(DD9,13);
EE1:=(CLOSE-DD0)/DD0*100;
EE2:=MA(CLOSE,22);
EE3:=EE2+2*STD(CLOSE,22);
EE4:=EE2-2*STD(CLOSE,22);
EE5:=(CLOSE-EE4)/(EE3-EE4);
EE6:=REF(EE1,1)<-15 AND REF(EE5,1)<0 AND EE1>REF(EE1,1);
EE7:=DD4 OR DD7;
STICKLINE(EE6>0,CLOSE,OPEN,4,0),COLOR0044CC;
STICKLINE(EE6>0,CLOSE,OPEN,2,0),COLOR3377DD;
STICKLINE(EE6>0,CLOSE,OPEN,1,0),COLOR66AAEE;
STICKLINE(EE6>0,CLOSE,OPEN,0,0),COLOR99DDFF;
STICKLINE(EE7,OPEN,OPEN+(CLOSE-OPEN)/3,5,0),COLOR003333;
STICKLINE(EE7,OPEN,OPEN+(CLOSE-OPEN)/3,4,0),COLOR116666;
STICKLINE(EE7,OPEN,OPEN+(CLOSE-OPEN)/3,3,0),COLOR229999;
STICKLINE(EE7,OPEN,OPEN+(CLOSE-OPEN)/3,2,0),COLOR33CCCC;
STICKLINE(EE7,OPEN,OPEN+(CLOSE-OPEN)/3,1,0),COLOR44FFFF;

通达信金玉良缘主图指标公式

 

相关文章