在线检测未来函数

飞狐判断大势指标公式

来源:Internet,编辑:股旁网,2016-10-04

Var1:=(EMA(CLOSE,12)-EMA(CLOSE,26))*100;
Var2:=EMA(Var1,9);
Var3:=2*(Var1-Var2);
FILLRGN(Var1>=0,0,Var1*0.8),COLOREEEEFF;
FILLRGN(Var1>=0,0,Var1*0.7),COLORDDDDFF;
FILLRGN(Var1>=0,0,Var1*0.6),COLORCCCCFF;
FILLRGN(Var1>=0,0,Var1*0.5),COLORBBBBFF;
FILLRGN(Var1>=0,0,Var1*0.4),COLORAAAAFF;
FILLRGN(Var1>=0,0,Var1*0.3),COLOR9999FF;
FILLRGN(Var1>=0,0,Var1*0.2),COLOR8888FF;
FILLRGN(Var1>=0,0,Var1*0.1),COLOR7777FF;
FILLRGN(Var1<0,0,Var1*0.8),COLORFFB0B0;
FILLRGN(Var1<0,0,Var1*0.7),COLORFF9D9D;
FILLRGN(Var1<0,0,Var1*0.6),COLORFF8E8E;
FILLRGN(Var1<0,0,Var1*0.5),COLORFF7D7D;
FILLRGN(Var1<0,0,Var1*0.4),COLORFF6A6A;
FILLRGN(Var1<0,0,Var1*0.3),COLORFF4D4D;
FILLRGN(Var1<0,0,Var1*0.2),COLORFF2D2D;
FILLRGN(Var1<0,0,Var1*0.1),COLORFF0000;
FILLRGN(Var2>=0,0,Var2*0.8),COLORD3FF60;
FILLRGN(Var2>=0,0,Var2*0.7),COLORC2FF24;
FILLRGN(Var2>=0,0,Var2*0.6),COLORBAFF02;
FILLRGN(Var2>=0,0,Var2*0.5),COLORAFF200;
FILLRGN(Var2>=0,0,Var2*0.4),COLORA4E100;
FILLRGN(Var2>=0,0,Var2*0.3),COLOR96CE00;
FILLRGN(Var2>=0,0,Var2*0.2),COLOR89BD00;
FILLRGN(Var2>=0,0,Var2*0.1),COLOR78A600;
FILLRGN(Var2<0,0,Var2*0.8),COLOR1EBE01;
FILLRGN(Var2<0,0,Var2*0.7),COLOR20CD01;
FILLRGN(Var2<0,0,Var2*0.6),COLOR22DC01;
FILLRGN(Var2<0,0,Var2*0.5),COLOR25F101;
FILLRGN(Var2<0,0,Var2*0.4),COLOR34FE10;
FILLRGN(Var2<0,0,Var2*0.3),COLOR49FE29;
FILLRGN(Var2<0,0,Var2*0.2),COLOR6BFE52;
FILLRGN(Var2<0,0,Var2*0.1),COLOR82FE6B;
安全区: -20;
风险区: 20;
Var4:=EMA((CLOSE-LLV(LOW,33))/(HHV(HIGH,21)-LLV(LOW,33))*100,20)*0.998;
Var5:=-50+EMA(0.667*REF(Var4,1)+0.333*Var4,1);
趋势: -50+EMA(0.667*REF(Var4,1)+0.333*Var4,1),COLORB2499B,LINETHICK4;
PARTLINE(趋势>20,趋势),colorred,LINETHICK4;
PARTLINE(趋势<-20,趋势),color67BBD2,LINETHICK4;
Var7:=SMA((SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,2,1)+3),2,1);
Var8:=EMA(EMA(((2*CLOSE+HIGH+LOW)/4-LLV(LOW,26))/(HHV(HIGH,34)-LLV(LOW,26))*100,16),4);
Var9:=SMA((HHV(HIGH,24)-CLOSE)/(HHV(HIGH,24)-LLV(LOW,24))*100,3,1);
Var10:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
Var11:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
Var12:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
Var15:=EMA((CLOSE-LLV(LOW,36))/(HHV(HIGH,30)-LLV(LOW,36))*4,4)*25;
背离: IF((Var15<10),40,50), , COLOR6365CC;
顶背离: IF((Var15>90),-40,-50), COLORRED;
兜底:STICKLINE(CROSS(ma(c,3),ma(c,5)) and hhv(if((Var10+Var11+Var12)/3<=-20,10,0),10),-40,-50,10,0),colorred ;
铁底:STICKLINE(CROSS(Var7,Var8),-40,-50,10,0),COLORMAGENTA;
DRAWTEXT(CROSS(Var8,Var9) AND Var8<50,20,'还涨')COLORMAGENTA;
DRAWICON(CROSS(Var8,Var9) AND Var8<50,20,4);
DRAWTEXT(CROSS(Var8,Var7) AND Var8>40,60,'快卖')COLORGREEN;
DRAWICON(CROSS(Var8,Var7) AND Var8>40,50,9);
DRAWTEXT(CROSS(Var7,Var8) AND Var8<50,-55,' 铁底')COLORRED;
DRAWTEXT(CROSS(Var7,Var9) ,10,'有戏')COLORblue;
DRAWICON(CROSS(Var7,Var9),20,6);
DRAWTEXT(CROSS(Var9,Var7) ,30,'不妙')COLORblue;
DRAWICON(CROSS(Var9,Var7),30,5);
DRAWTEXT(CROSS(Var9,Var8) AND Var8>50,-20,'还跌')COLORCYAN;
DRAWICON(CROSS(Var9,Var8) AND Var8>50,-20,5);

飞狐判断大势指标公式

 

相关文章