在线检测未来函数

飞狐奇妙支撑主图指标公式

来源:Internet,编辑:股旁网,2016-10-07

N:=5;
P:=13;
DRAWGBK(1,COLORRGB(265,0,0),COLORRGB(265,285,0),0);
AA1:=WMA(CLOSE,2);
BB1:=EMA(AA1,2);
A:=MA(BB1,3);
AA2:=WMA((HIGH+CLOSE+OPEN)/3,18);
DD3:=A>=AA2 AND CLOSE>AA2;
DD4:=A<AA2;
DD5:=A>AA2;
STICKLINE((DD4 OR DD5) AND OPEN<=CLOSE,HIGH,LOW,0.5,0),colorCC99;
STICKLINE((DD4 OR DD5) AND OPEN<=CLOSE,CLOSE,OPEN,7,0),colorCC99;
STICKLINE((DD4 OR DD5) AND OPEN>=CLOSE,HIGH,LOW,0.5,0),color3F8C3A;
STICKLINE((DD4 OR DD5) AND OPEN>=CLOSE,CLOSE,OPEN,7,0),color3F8C3A;
STICKLINE((DD3 OR CLOSE>AA2) AND OPEN<=CLOSE,CLOSE,OPEN,7,0),colorFF;
STICKLINE((DD3 OR CLOSE>AA2) AND OPEN<=CLOSE,HIGH,LOW,0.5,0),colorFF;
STICKLINE((DD3 OR CLOSE>AA2) AND OPEN>=CLOSE,CLOSE,OPEN,7,0),colorFF33FF;
STICKLINE((DD3 OR CLOSE>AA2) AND OPEN>=CLOSE,HIGH,LOW,0.5,0),colorFF33FF;
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
KK:=SMA(RSV1,3,1);
DD:=SMA(KK,3,1);
JJ:=3*KK-2*DD;
M:=BARSLAST(CROSS(DD,JJ));
G:=REF(HIGH,M);
撑压:STICKLINE(G,G,G,10,1),LINETHICK2,colorFFFF;
HH:=HIGH;
LL:=LOW;
TOP:=HIGH;
BOT:=LOW;
XX[1]:=1;
KK:=1;
FOR I=1 TO DATACOUNT DO BEGIN
IF XX[I]=1 THEN BEGIN
TOP[I]:=HH[I];
END;
IF XX[I-1]=1 THEN BEGIN
IF HH[I]>TOP[I-1] THEN BEGIN
TOP[I]:=HH[I];
XX[I]:=1;
END;ELSE BEGIN
TOP[I]:=TOP[I-1];
XX[I]:=2;
END;
END;
IF XX[I-1]=2 THEN BEGIN
IF HH[I]>TOP[I-1] THEN BEGIN
TOP[I]:=HH[I];
XX[I]:=1;
END;ELSE BEGIN
TOP[I]:=TOP[I-1];
BOT[I]:=LL[I];
XX[I]:=3;
END;
END;
IF XX[I-1]=3 THEN BEGIN
TOP[I]:=TOP[I-1];
IF LL[I]<BOT[I-1] THEN BEGIN
BOT[I]:=LL[I];
XX[I]:=3;
END;ELSE BEGIN
BOT[I]:=BOT[I-1];
XX[I]:=4;
END;
END;
IF XX[I-1]=4 THEN BEGIN
TOP[I]:=TOP[I-1];
IF LL[I]<BOT[I-1] THEN BEGIN
BOT[I]:=LL[I];
XX[I]:=3;
END;ELSE BEGIN
BOT[I]:=BOT[I-1];
XX[I]:=5;
END;
END;
IF XX[I-1]=5 THEN BEGIN
IF LL[I]<BOT[I-1] OR HH[I]>TOP[I-1] THEN BEGIN
TOP[I]:=HH[I];
BOT[I]:=HH[I];
XX[I]:=1;
END;ELSE BEGIN
BOT[I]:=BOT[I-1];
TOP[I]:=TOP[I-1];
XX[I]:=5;
END;
END;
END;
FOR J=1 TO DATACOUNT DO BEGIN
IF XX[J]=5 AND XX[J-1]=4 THEN BEGIN
FOR K=J-1 DOWNTO J-KK DO BEGIN
TOP[K]:=TOP[J];
BOT[K]:=BOT[J];
END;
END;
IF XX[J-1]=5 AND XX[J]=1 THEN
KK:=0;
KK:=KK+1;
END;
JJ:=BARSLAST(TOP<>REF(TOP,1));
上沿:STICKLINE(TOP,TOP,TOP,10,1),colorFFFF00;
DRAWNUMBER(TOP<>REF(TOP,1),REF(TOP,JJ)*1.015,TOP,2),colorFFFF00;
下沿:STICKLINE(BOT,BOT,BOT,10,1),colorFF0000;
DRAWNUMBER(TOP<>REF(TOP,1),REF(BOT,JJ)*0.99,BOT,2),colorFF0000;
X1:=REF(CLOSE,1);
X2:=(SMA(MAX(CLOSE-X1,0),N,1))/(SMA(ABS(CLOSE-X1),N,1))*100;
X3:=(3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-50)*1.032+50;
X4:=(X2+X3)/2;
奇妙:CLOSE+(X4/50-1)*(MA(CLOSE,30)/20)*P,PRECISION2,color98FF;

飞狐奇妙支撑主图指标公式

 

相关文章