在线检测未来函数

通达信BOLL基本面主图指标公式

来源:Internet,编辑:股旁网,2016-10-10

N:=20;
MIDA:=MA(C,N);
VART1:=POW((C-MIDA),2);
VART2:=MA(VART1,N);
VART3:=SQRT(VART2);
UPPERA:=MIDA+2*VART3;
LOWERA:=MIDA-2*VART3;
BOLL:REF(MIDA,1);
UB:REF(UPPERA,1);
LB:REF(LOWERA,1);
所属板块:=STRCAT(' 【所属板块】:',STRCAT(STRCAT(STRCAT(' [行业]——',HYBLOCK),STRCAT(' [地域]——',DYBLOCK)),STRCAT(' [概念]——',GNBLOCK)));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.02,0,所属板块),COLORMAGENTA;
{主题概念}
Z1:=STRCAT(HYBLOCK,'----');
Z2:=STRCAT(Z1,FGBLOCK);
Z3:=STRCAT(Z2,DYBLOCK);
Z4:=STRCAT(Z3,'----');
DRAWTEXT_FIX(1,0.00,0.06,0,' 【主题概念】:')COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.10,0.06,0,STRCAT(Z4,GNBLOCK)),COLORCYAN;
DRAWTEXT_FIX(1,0.07,0.24,0,EXTERNSTR(0,14))COLORYELLOW;
HH:=CONST(HHV(H,160));
LL:=CONST(LLV(L,160));{160可改成你习惯锁定的日K线数}
HL1:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.76,0.04));
HL2:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.80,0.08));
HL3:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.84,0.12));
HL4:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.88,0.16));
HL5:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.92,0.20));
HL6:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.96,0.24));
DRAWTEXT_FIX (1,0.80,HL1,0,'股本:');
DRAWNUMBER_FIX(1,0.84,HL1,0,CONST(FINANCE(1)/100000000));
DRAWTEXT_FIX (1,0.80,HL2,0,'流通:');
DRAWNUMBER_FIX(1,0.84,HL2,0,CONST(FINANCE(7)/100000000));
DRAWTEXT_FIX (1,0.80,HL3,0,'动PE:');
DRAWNUMBER_FIX(1,0.84,HL3,0,CONST(DYNAINFO(39)));
DRAWTEXT_FIX (1,0.80,HL4,0,'换手:');
DRAWNUMBER_FIX(1,0.84,HL4,0,CONST(DYNAINFO(37)*100));
DRAWTEXT_FIX (1,0.80,HL5,0,'量比:');
DRAWNUMBER_FIX(1,0.84,HL5,0,CONST(DYNAINFO(17)));
DRAWTEXT_FIX (1,0.80,HL6,0,'涨幅:');
DRAWNUMBER_FIX(1,0.84,HL6,0,CONST(DYNAINFO(14)*100)),COLORFF00FF;
DRAWNUMBER_FIX(1,0.84,HL6,0,IF(CONST(DYNAINFO(14)*100)<0,CONST(DYNAINFO(14)*100),DRAWNULL))COLOR00FF00;
字:=STRCAT(STRCAT(STRCAT('名称: ',STKNAME),' 代码: '),CODE);
DRAWTEXT_FIX(ISLASTBAR,0.5,0.10,0,字),COLORYELLOW;

通达信BOLL基本面主图指标公式

 

相关文章