在线检测未来函数

通达信慧华主图指标公式

来源:Internet,编辑:股旁网,2016-10-11

STICKLINE(C>1.095*REF(C,1),C,O,3,0),COLORYELLOW;
STICKLINE(C<0.905*REF(C,1),C,O,3,0),COLORWHITE;
比系数:=1.3;
金线:=1;
临界点:=0;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
均线:=MA5>REF(MA5,1) AND MA10<REF(MA10,1) AND MA20<REF(MA20,1);
一日前量:=REF(V,1);
二日前量:=REF(V,2);
三日前量:=REF(V,3);
一日前开盘价:=REF(C,1);
二日前开盘价:=REF(C,2);
三日前开盘价:=REF(C,3);
四日前开盘价:=REF(C,4);
一日前收盘价:=REF(O,1);
二日前收盘价:=REF(O,2);
三日前收盘价:=REF(O,3);
四日前收盘价:=REF(O,4);
价不破顶:=C>=三日前开盘价 AND 一日前开盘价>=三日前开盘价 AND 二日前开盘价>=三日前开盘价;
价不破底:=L>三日前收盘价 AND REF(L,1)>三日前收盘价 AND REF(L,2)>三日前收盘价;
均价:=AMOUNT/VOL/100;
一日前均价:=REF(均价,1);
二日前均价:=REF(均价,2);
阳柱:=C>=O OR (C<O AND 均价>一日前开盘价);
三日二阳:=COUNT(阳柱,3)>=2;
基价柱阳:=三日前开盘价>三日前收盘价;
价渐升:=(均价>=一日前均价 OR C>一日前开盘价) AND (一日前均价>=二日前均价 OR 一日前开盘价>=二日前开盘价);
均价升:=(C+一日前开盘价+二日前开盘价)/3>三日前开盘价;
量渐升:=V>一日前量 AND 一日前量>二日前量 ;
量渐减:=V<=一日前量 AND 一日前量<=二日前量 ;
均量减:=(V+一日前量+二日前量)/3<=三日前量 AND NOT(量渐升);
日价量比:=C/V;
日价量比升:=日价量比>=REF(日价量比,1) AND REF(日价量比,1)>=REF(日价量比,2);
均价升幅:=(C+一日前开盘价+二日前开盘价)/3/三日前开盘价;
均量升幅:=(V+一日前量+二日前量)/3/三日前量;
价量比:=比系数*均价升幅/均量升幅>1;
基前跳空:=三日前收盘价>四日前开盘价 AND 四日前开盘价>四日前收盘价;
黄金柱1T:=基价柱阳 AND 价渐升 AND 量渐减 AND 价不破顶 AND 价不破底 AND 基前跳空;
BACKSET101T:=BACKSET(黄金柱1T,5);
FILTER101T:=FILTER(BACKSET101T,4);
黄金柱1:=基价柱阳 AND 价渐升 AND 量渐减 AND 价不破顶 AND 价不破底 ;
BACKSET101:=BACKSET(黄金柱1,4);
FILTER101:=FILTER(BACKSET101,3);
黄金柱11:=黄金柱1 AND REF(黄金柱1,1);
BACKSET1011:=BACKSET(黄金柱11,4);
FILTER1011:=FILTER(BACKSET1011,3);
黄金柱12:=黄金柱1 AND REF(黄金柱1,2);
BACKSET1012:=BACKSET(黄金柱12,4);
FILTER1012:=FILTER(BACKSET1012,3);
黄金柱13:=黄金柱1 AND REF(黄金柱1,3);
BACKSET1013:=BACKSET(黄金柱13,4);
FILTER1013:=FILTER(BACKSET1013,3);
黄金柱2T:=基价柱阳 AND 价渐升 AND 均量减 AND NOT(量渐升) AND 价不破顶 AND 价不破底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱1T);
BACKSET201T:=BACKSET(黄金柱2T,5);
FILTER201T:=FILTER(BACKSET201T,4);
黄金柱2:=基价柱阳 AND 价渐升 AND 均量减 AND NOT(量渐升) AND 价不破顶 AND 价不破底 AND NOT(黄金柱1) AND NOT(黄金柱1T);
BACKSET201:=BACKSET(黄金柱2,4);
FILTER201:=FILTER(BACKSET201,3);
黄金柱21:=黄金柱2 AND REF(黄金柱2,1);
BACKSET2011:=BACKSET(黄金柱21,4);
FILTER2011:=FILTER(BACKSET2011,3);
黄金柱22:=黄金柱2 AND REF(黄金柱2,2);
BACKSET2012:=BACKSET(黄金柱22,4);
FILTER2012:=FILTER(BACKSET2012,3);
黄金柱23:=黄金柱2 AND REF(黄金柱2,3);
BACKSET2013:=BACKSET(黄金柱23,4);
FILTER2013:=FILTER(BACKSET2013,3);
黄金柱3T:=基价柱阳 AND 均价升 AND 量渐减 AND 价不破顶 AND 价不破底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱1T) AND NOT(黄金柱2T);
BACKSET301T:=BACKSET(黄金柱3T,5);
FILTER301T:=FILTER(BACKSET301T,4);
黄金柱3:=基价柱阳 AND 均价升 AND 量渐减 AND 价不破顶 AND 价不破底 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱1T) AND NOT(黄金柱2T);
BACKSET301:=BACKSET(黄金柱3,4);
FILTER301:=FILTER(BACKSET301,3);
黄金柱31:=黄金柱3 AND REF(黄金柱3,1);
BACKSET3011:=BACKSET(黄金柱31,4);
FILTER3011:=FILTER(BACKSET3011,3);
黄金柱32:=黄金柱3 AND REF(黄金柱3,2);
BACKSET3012:=BACKSET(黄金柱32,4);
FILTER3012:=FILTER(BACKSET3012,3);
黄金柱33:=黄金柱3 AND REF(黄金柱3,3);
BACKSET3013:=BACKSET(黄金柱33,4);
FILTER3013:=FILTER(BACKSET3013,3);
黄金柱4T:=基价柱阳 AND 均价升 AND 均量减 AND 价不破顶 AND 价不破底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱1T) AND NOT(黄金柱2) AND NOT(黄金柱2T) AND NOT(黄金柱3) AND NOT(黄金柱3T);
BACKSET401T:=BACKSET(黄金柱4T,5);
FILTER401T:=FILTER(BACKSET401T,4);
黄金柱4:=基价柱阳 AND 均价升 AND 均量减 AND 价不破顶 AND 价不破底 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱1T) AND NOT(黄金柱2T) AND NOT(黄金柱3T);
BACKSET401:=BACKSET(黄金柱4,4);
FILTER401:=FILTER(BACKSET401,3);
黄金柱41:=黄金柱4 AND REF(黄金柱4,1);
BACKSET4011:=BACKSET(黄金柱41,4);
FILTER4011:=FILTER(BACKSET4011,3);
黄金柱42:=黄金柱4 AND REF(黄金柱4,2);
BACKSET4012:=BACKSET(黄金柱42,4);
FILTER4012:=FILTER(BACKSET4012,3);
黄金柱43:=黄金柱4 AND REF(黄金柱4,3);
BACKSET4013:=BACKSET(黄金柱43,4);
FILTER4013:=FILTER(BACKSET4013,3);
黄金柱5T:=基价柱阳 AND 均价升 AND 价量比 AND 价不破顶 AND 价不破底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱4) AND NOT(黄金柱1T) AND NOT(黄金柱2T) AND NOT(黄金柱3T) AND NOT(黄金柱4T);
BACKSET501T:=BACKSET(黄金柱5T,5);
FILTER501T:=FILTER(BACKSET501T,4);
黄金柱5:=基价柱阳 AND 均价升 AND 价量比 AND 价不破顶 AND 价不破底 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱4) AND NOT(黄金柱1T) AND NOT(黄金柱2T) AND NOT(黄金柱3T) AND NOT(黄金柱4T);
BACKSET501:=BACKSET(黄金柱5,4);
FILTER501:=FILTER(BACKSET501,3);
黄金柱51:=黄金柱5 AND REF(黄金柱5,1);
BACKSET5011:=BACKSET(黄金柱51,4);
FILTER5011:=FILTER(BACKSET5011,3);
黄金柱52:=黄金柱5 AND REF(黄金柱5,2);
BACKSET5012:=BACKSET(黄金柱52,4);
FILTER5012:=FILTER(BACKSET5012,3);
黄金柱53:=黄金柱5 AND REF(黄金柱5,3);
BACKSET5013:=BACKSET(黄金柱53,4);
FILTER5013:=FILTER(BACKSET5013,3);
黄金柱6T:=基价柱阳 AND 均价升 AND 日价量比升 AND 价不破顶 AND 价不破底 AND 基前跳空 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱4) AND NOT(黄金柱5) AND NOT(黄金柱1T) AND NOT(黄金柱2T) AND NOT(黄金柱3T) AND NOT(黄金柱4T) AND NOT(黄金柱5T);
BACKSET601T:=BACKSET(黄金柱6T,5);
FILTER601T:=FILTER(BACKSET601T,4);
黄金柱6:=基价柱阳 AND 均价升 AND 日价量比升 AND 价不破顶 AND 价不破底 AND NOT(黄金柱1) AND NOT(黄金柱2) AND NOT(黄金柱3) AND NOT(黄金柱4) AND NOT(黄金柱5) AND NOT(黄金柱1T) AND NOT(黄金柱2T) AND NOT(黄金柱3T) AND NOT(黄金柱4T) AND NOT(黄金柱5T);
BACKSET601:=BACKSET(黄金柱6,4);
FILTER601:=FILTER(BACKSET601,3);
黄金柱61:=黄金柱6 AND REF(黄金柱6,1);
BACKSET6011:=BACKSET(黄金柱61,4);
FILTER6011:=FILTER(BACKSET6011,3);
黄金柱62:=黄金柱6 AND REF(黄金柱6,2);
BACKSET6012:=BACKSET(黄金柱62,4);
FILTER6012:=FILTER(BACKSET6012,3);
黄金柱63:=黄金柱6 AND REF(黄金柱6,3);
BACKSET6013:=BACKSET(黄金柱63,4);
FILTER6013:=FILTER(BACKSET6013,3);
FIL1:=(FILTER101 AND NOT(REF(FILTER101,4))) OR (FILTER1011 AND NOT(REF(FILTER1011,4))) OR (FILTER1012 AND NOT(REF(FILTER1012,4))) OR (FILTER1013 AND NOT(REF(FILTER1013,4)));
FIL2:=(FILTER201 AND NOT(REF(FILTER201,4))) OR (FILTER2011 AND NOT(REF(FILTER2011,4))) OR (FILTER2012 AND NOT(REF(FILTER2012,4))) OR (FILTER2013 AND NOT(REF(FILTER2013,4)));
FIL3:=(FILTER301 AND NOT(REF(FILTER301,4))) OR (FILTER3011 AND NOT(REF(FILTER3011,4))) OR (FILTER3012 AND NOT(REF(FILTER3012,4))) OR (FILTER3013 AND NOT(REF(FILTER3013,4)));
FIL4:=(FILTER401 AND NOT(REF(FILTER401,4))) OR (FILTER4011 AND NOT(REF(FILTER4011,4))) OR (FILTER4012 AND NOT(REF(FILTER4012,4))) OR (FILTER4013 AND NOT(REF(FILTER4013,4)));
FIL5:=(FILTER501 AND NOT(REF(FILTER501,4))) OR (FILTER5011 AND NOT(REF(FILTER5011,4))) OR (FILTER5012 AND NOT(REF(FILTER5012,4))) OR (FILTER5013 AND NOT(REF(FILTER5013,4)));
FIL6:=(FILTER601 AND NOT(REF(FILTER601,4))) OR (FILTER6011 AND NOT(REF(FILTER6011,4))) OR (FILTER6012 AND NOT(REF(FILTER6012,4))) OR (FILTER6013 AND NOT(REF(FILTER6013,4)));
FIL:=FIL1 OR FIL2 OR FIL3 OR FIL4 OR FIL5 OR FIL6;
STICKLINE(FIL ,OPEN,CLOSE,1.2,0),COLORYELLOW;{黄金柱}
HJZ:=FILTER(FIL,3);
STICKLINE(HJZ ,OPEN,CLOSE,1.75,0),COLORYELLOW;{根黄金柱}
STICKLINE(HJZ ,OPEN,CLOSE,0.75,0),COLORRED;
STICKLINE(FIL AND V/REF(V,1)>=1.95,OPEN,CLOSE,0.01,0),COLORBROWN{倍量黄金柱};
K1:=SUMBARS(HJZ,1);
STICKLINE(K1 AND 金线=1,REF(C,K1-1),REF(C,K1-1),10,0),COLORAA00FF;
STICKLINE(K1 AND 金线=1,REF(L,K1-1),REF(L,K1-1),10,0),COLORYELLOW;
{JZ:=REF(HJZ,3);
SRX:=SUMBARS(LLV(L,3),1);
HJX:=JZ AND SRX;
STICKLINE(HJX AND 金线=1,REF(L,HJX-1),REF(L,HJX-1),10,0),COLORLIBLUE;}
FIL1T:=(FILTER101T AND NOT(REF(FILTER101T,5)));
FIL2T:=(FILTER201T AND NOT(REF(FILTER201T,5)));
FIL3T:=(FILTER301T AND NOT(REF(FILTER301T,5)));
FIL4T:=(FILTER401T AND NOT(REF(FILTER401T,5)));
FIL5T:=(FILTER501T AND NOT(REF(FILTER501T,5)));
FIL6T:=(FILTER601T AND NOT(REF(FILTER601T,5)));
FILT:=FIL1T OR FIL2T OR FIL3T OR FIL4T OR FIL5T OR FIL6T;
STICKLINE(FILT ,OPEN,CLOSE,0.5,0),COLORMAGENTA;{元帅柱}
YSZ:=FILTER(FILT,3);
STICKLINE(YSZ AND NOT(REF(FILT,5)),OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(YSZ AND NOT(REF(FILT,5)),OPEN,CLOSE,1,0),COLORMAGENTA;{根元帅柱}
K2:=SUMBARS(FILT,1);
{STICKLINE(K2 AND 金线=1,REF(C,K2-1),REF(C,K2-1),10,0),COLORMAGENTA;}
STICKLINE(C>O AND REF(C,1)<REF(O,1) AND H<REF(O,1) AND C<((REF(O,1)-REF(C,1))/2+REF(C,1)),C,O,0.57,0),COLORGREEN;{假阳}
STICKLINE(O>C AND C>REF(C,1) AND REF(C,1)>=REF(O,1),C,O,0.37,0),COLORRED;{假阴}
DRAWICON((V<=MA(V,60)*1/3 AND V<REF(LLV(V,100),1)) OR (V/REF(V,1)<=0.51 AND V<REF(LLV(V,100),1) ) AND H>L,L*0.99,1);
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,FGBLOCK);
Z3:=STRCAT(Z2,DYBLOCK);
Z4:=STRCAT(Z3,ZDBLOCK);
Z5:=STRCAT(Z4,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z5,GNBLOCK)),COLORYELLOW;
{精准线}
N:=3;
L0:=0.00;{点位差参数}
{底精准线}
L1:=ABS(L-REF(L,1))<=L0;
L2:=ABS(L-REF(L,2))<=L0;
L3:=ABS(L-REF(L,3))<=L0;
L4:=ABS(L-REF(L,4))<=L0;
L5:=ABS(L-REF(L,5))<=L0;
精准线首次:=L1 OR L2 OR L3 OR L4 OR L5;
精准左:=FILTER(精准线首次,N) ;
天数:=BARSLAST(精准左);
LTS:=REF(L,天数);
精准右:=ABS(L-LTS)<=L0;
STICKLINE(精准左,L,L,31,-1),COLORMAGENTA;
{顶精准线}
G1:=ABS(H-REF(H,1))<=L0;
G2:=ABS(H-REF(H,2))<=L0;
G3:=ABS(H-REF(H,3))<=L0;
G4:=ABS(H-REF(H,4))<=L0;
G5:=ABS(H-REF(H,5))<=L0;
精准线首次1:=G1 OR G2 OR G3 OR G4 OR G5;
精准左1:=FILTER(精准线首次1,N) ;
天数1:=BARSLAST(精准左1);
HTS:=REF(H,天数1);
精准右1:=ABS(H-HTS)<=L0;
STICKLINE(精准左1,H,H,31,-1),COLORGREEN;
STICKLINE(C/REF(C,1)>=1.04 OR C/REF(C,1)<=0.96,(C+O)/2,(C+O)/2,2,1),COLORLIBLUE;{中分线};
STICKLINE(C/REF(C,1)>=1.04 OR C/REF(C,1)<=0.96,(MAX(O,C)-MIN(O,C))*2/3+MIN(O,C),(MAX(O,C)-MIN(O,C))*2/3+MIN(O,C),2,1),COLORLIBLUE;{上三一线};
STICKLINE(C/REF(C,1)>=1.04 OR C/REF(C,1)<=0.96,(MAX(O,C)-MIN(O,C))/3+MIN(O,C),(MAX(O,C)-MIN(O,C))/3+MIN(O,C),2,1),COLORLIBLUE;{下三一线};
中分线:(O+C)/2,COLORRED,NODRAW;
上31:(MAX(O,C)-MIN(O,C))*2/3+MIN(O,C),COLORMAGENTA,NODRAW;
下31:(MAX(O,C)-MIN(O,C))/3+MIN(O,C),COLORYELLOW,NODRAW;
{标缺口}
LL:=REF(L,1);HH:=REF(H,1);上跳:=L>HH;下跳:=H<LL;
STICKLINE(L>REF(H,1),L,REF(H,1),2.78,-1),COLORRED;
STICKLINE(REF(L,1)>H,REF(L,1),H,2.78,-1),COLORGREEN;

通达信慧华主图指标公式

 

相关文章