在线检测未来函数

通达信后羿指标公式

来源:Internet,编辑:股旁网,2016-10-17

{与沪深两大盘对比}
ZF1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
ZF1D1:=("999999$CLOSE"-REF("999999$CLOSE",1))/REF("999999$CLOSE",1)*100;
ZF1D2:=("399001$CLOSE"-REF("399001$CLOSE",1))/REF("399001$CLOSE",1)*100;
DPDB1:=ZF1-MAX(ZF1D1,ZF1D2);
ZF3:=(CLOSE-REF(CLOSE,3))/REF(CLOSE,3)*100;
ZF3D1:=("999999$CLOSE"-REF("999999$CLOSE",3))/REF("999999$CLOSE",3)*100;
ZF3D2:=("399001$CLOSE"-REF("399001$CLOSE",3))/REF("399001$CLOSE",3)*100;
DPDB3:=ZF3-MAX(ZF3D1,ZF3D2);
ZF5:=(CLOSE-REF(CLOSE,5))/REF(CLOSE,5)*100;
ZF5D1:=("999999$CLOSE"-REF("999999$CLOSE",5))/REF("999999$CLOSE",5)*100;
ZF5D2:=("399001$CLOSE"-REF("399001$CLOSE",5))/REF("399001$CLOSE",5)*100;
DPDB5:=ZF5-MAX(ZF5D1,ZF5D2);
RDD:=MAX(DPDB1,MAX(DPDB3,DPDB5));
MRDX:=SMA(RDD,3,1);
对比斜率:=SLOPE(MRDX,3)>0;
{排除类别}
S1:=DYNAINFO(4)>0;
S2:=IF(NAMELIKE('S'),0,1);
S3:=IF(NAMELIKE('*'),0,1);
SSS:=S1 AND S2 AND S3;
{图文显示}
MA3:=MA((HIGH+LOW+CLOSE)/3,3);
比过去自己:=SLOPE(MA3,3)>0;
TJZ:=MRDX>0 AND (对比斜率 OR 比过去自己);
QMX: FORCAST(MRDX,3),COLORWHITE,DOTLINE;
IF(FINANCE(3)=0,QMX,DRAWNULL),COLORBLUE,DOTLINE;
相对强度: IF(TJZ AND FINANCE(3)!=0,QMX,DRAWNULL),COLORRED;
板块热度: IF(TJZ AND FINANCE(3)=0,QMX,DRAWNULL),COLORCYAN;
{热点排序}
拟合排序: IF(TJZ AND SSS,QMX,0),COLORYELLOW,NODRAW;
斜率排序: IF(TJZ AND SSS,SLOPE(MRDX,3),0),COLORYELLOW,NODRAW;
DRAWTEXT(BARSTATUS=2,0,'大盘基线'),COLORGRAY;
DRAWTEXT_FIX(1,0,0,0,'【 个 股 & 板 块 VS 大 盘 指 标 】'),COLORGRAY;

通达信后羿指标公式

 

相关文章