在线检测未来函数

飞狐天地线波浪指标公式

来源:Internet,编辑:股旁网,2016-10-18

INPUT:N1(21,5,50),N2(34,10,100),N3(8,2,30),N4(5,2,20);
CJ:=(2*CLOSE+HIGH+OPEN+LOW)/5;
DIFF:=EMA(CJ,N1)-EMA(CJ,N2);
DEA:=EMA(DIFF,N3);
MACD:30*(DIFF-DEA),LINETHICK;
MARD:SMA(MACD,N4,1),LINETHICK;
G1:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3));
G2:=(DYNAINFO(5)<0.01 OR DYNAINFO(6)<0.01);
G3:=IF(G2,1,(G1<(DYNAINFO(5)+0.01) AND G1>(DYNAINFO(6)-0.01)));
CB:=SMA(IF(G3,DMA(AMOUNT/(100*VOL),100*VOL/FINANCE(7)),EMA((HIGH+LOW+2*CLOSE)/4,117)),3,1);
J1:=SMA(EMA(CB,2),3,1);J2:=EMA(J1,2);
J3:=EMA(J2,2);J4:=EMA(J3,2);
J5:=EMA(J4,2);J6:=EMA(J5,2);
地线1:=LLV(MARD,117);
天线1:=HHV(MARD,117);
STICKLINE(J1>J6,地线1[SYSPARAM(1)],天线1[SYSPARAM(1)],10,0),COLOR6F116F;
STICKLINE(J1<J6,地线1[SYSPARAM(1)],天线1[SYSPARAM(1)],10,0),COLOR3E3E3E;
FILLRGN(MACD>MARD,MARD,MACD),COLOR7D;
FILLRGN(MARD>MACD,MACD,MARD),COLOR64FA00;
W1:=BARSLAST(REF(CROSS(MACD,MARD),1));
背离:IF(REF(CLOSE,W1+1)>CLOSE AND MACD>REF(MACD,W1+1) AND CROSS(MACD,MARD) AND MACD<0,-1,0),COLORCD;
DRAWLINE(W1=0,MARD,底背离,MARD,0),COLORCD,LINETHICK2;
W2:=BARSLAST(REF(CROSS(MARD,MACD),1));
顶背离:REF(CLOSE,W2+1)<CLOSE AND REF(MACD,W2+1)>MACD AND CROSS(MARD,MACD) AND MACD>0,COLORYELLOW;
DRAWLINE(W2=0,MARD,顶背离,MARD,0),COLORYELLOW,LINETHICK2;
W3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*10;
W4:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*10;
W5:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*10;
WH:=(W3+2*W4+3*W5)/6;
随波:WH,COLOR3BFF,LINETHICK2;
零线:0,COLOR999999;
地线:地线1[SYSPARAM(1)];
天线:天线1[SYSPARAM(1)];

飞狐天地线波浪指标公式

 

相关文章