在线检测未来函数

大智慧史上最强操盘主图指标公式

来源:Internet,编辑:股旁网,2016-10-20

input:N2(1,1,100),N1(8,2,100),N3(10,5,100),N(9,1,100),M1(3,1,100),M2(3,1,100);
MA5:=MA(C,5);
MA10:MA(C,13);
MA20:=MA(C,20);
MA40:=MA(C,40);
MA60:MA(C,55);
MA125:=MA(C,125);
MA250:=MA(C,250);
DRAWTEXTABS(5,0,BKNAME ),colorDDDDDD;
DRAWTEXTABS(5,15,'流通盘:'+CAPITAL/100+'万股,利润增长:'+FINANCE2(10)+'%。每股收益:'+FINANCE2(3)+'元。' ),color00DDDD;
DRAWTEXTREL(455,10,' 千股千评:'+SELFSTRING('千股千评')),Color0000FF,LINETHICK2;
{量柱精要}
{DRAWRECTREL( 0,520,105,930,RGB(0,0,255));}
DRAWTEXTREL(7,650,'三日涨跌:'+ (C/REF(C,3)-1)*100 +'%'),COLORRED;
DRAWTEXTREL(7,700,'五日涨跌:'+ (C/REF(C,5)-1)*100 +'%'),COLORRED;
DRAWTEXTREL(7,750,'十日涨跌:'+ (C/REF(C,10)-1)*100 +'%'),COLORRED;
DRAWTEXTREL(7,800,'十五涨跌:'+ (C/REF(C,15)-1)*100 +'%'),COLORRED;
DRAWTEXTREL(7,850,'二十涨跌:'+ (C/REF(C,20)-1)*100 +'%'),COLORRED;
DRAWTEXTREL(7,900,'三十涨跌:'+ (C/REF(C,30)-1)*100 +'%'),COLORRED;
{大盘叠加}
C1:=EMA(INDEXC,500)/EMA(C,500);
D1:=INDEXO/C1; D2:=INDEXH/C1;
D3:=INDEXL/C1; D4:=INDEXC/C1;
STICKLINE(D4>=REF(D4,1),D3,D2,0,0),ColorFF00FF{COLOR00ff00};
STICKLINE(D4>=REF(D4,1),D4,D1,4,0),ColorFF00FF{COLORYELLOW};
STICKLINE(D4< REF(D4,1),D3,D2,0,0),COLOR00ff00;
STICKLINE(D4< REF(D4,1),D4,D1,4,0),COLOR00ff00;
{单阳不破}
ST:=STRFIND(stkname,'ST',1) OR STRFIND(stkname,'S',1);
ZF:=(c-ref(c,1))/ref(c,1)*100;
单阳:=ANY(ZF>7,1)and barscount(c)>30 and not(ST) ;
不破价:=REF(L,BARSLAST(单阳));
DRAWTEXT(单阳,L-L*0.02,'单阳'),COLOR00FFFF;
LS0:=BARSLAST(单阳);
LS11:=IF(1,LS0=1,单阳);
LS21:=IF(1,LLV(L,1)>REF(L,1),1);
单阳不破:=LS11 AND LS21;
STICKLINE(单阳不破,不破价----不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破,不破价----不破价*0.02,'1'),COLORGREEN;
LS12:=IF(2,LS0=2,单阳);
LS22:=IF(2,LLV(L,2)>REF(L,2),1);
单阳不破2:=LS12 AND LS22;
STICKLINE(单阳不破2,不破价----不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破2,不破价----不破价*0.02,'2'),COLORGREEN;
LS13:=IF(3,LS0=3,单阳);
LS23:=IF(3,LLV(L,3)>REF(L,3),1);
单阳不破3:=LS13 AND LS23;
STICKLINE(单阳不破3,不破价----不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破3,不破价----不破价*0.02,'3'),COLORGREEN;
LS14:=IF(4,LS0=4,单阳);
LS24:=IF(4,LLV(L,4)>REF(L,4),1);
单阳不破4:=LS14 AND LS24;
STICKLINE(单阳不破4,不破价----不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破4,不破价----不破价*0.02,'4'),COLORGREEN;
{波段涨跌幅-dzh主图}
ZL:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
F11:=ZIG(3,15);
FXx:=IF((F11> REF(F11,1)),5,105);
转向:=CROSS(ZL,FXx);
高点:=CROSS(fxx,ZL);
VERTLINE(转向,1),color00009f;
VERTLINE(高点,1),color009f00;
DRAWICON(转向,LOW,1),ALIGN1,VALIGN0;
DRAWICON(高点,H,2),ALIGN1,VALIGN0;
{背景K线}
FF:=EMA(CLOSE,3);
DRAWGBK(F11<FXx,STRIP(rgb(0,0,200),rgb(0,140,0),0));
{K线解盘}
早晨之星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND ABS(REF(OPEN,1)-
REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏之星:=REF(CLOSE,2)/REF(OPEN,2)>1.03 AND REF(OPEN,1)>REF(CLOSE,2) AND ABS(REF(OPEN,1)-
REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2);
长十字:=CLOSE=OPEN AND HIGH/LOW >1.03;
垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH;
早晨十字星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND REF(OPEN,1)
=REF(CLOSE,1) AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2)>1.05 AND REF(OPEN,1)>REF(CLOSE,2) AND REF(OPEN,1)
=REF(CLOSE,1) AND
CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);
射击之星:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE>MA(CLOSE,5);
倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE<MA(CLOSE,5);
锤头:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE<MA(CLOSE,5);
吊颈:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);
穿头破脚:=(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND
OPEN>REF(CLOSE,1))
OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF
(CLOSE,1));
乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND
CLOSE<REF(CLOSE,1);
曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND
CLOSE>REF(CLOSE,1);
身怀六甲:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)>0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005
AND
MAX(CLOSE,OPEN)<MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN)>MIN(REF(CLOSE,1),REF
(OPEN,1));
十字胎:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1)>0.04 AND CLOSE=OPEN AND
CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1));
平顶:=ABS(HIGH-REF(HIGH,1))/HIGH<0.001;
平底:=(ABS(LOW-REF(LOW,1))/LOW<0.001 AND ABS(REF(LOW,1)-REF(LOW,2))/REF(LOW,1)<=0.001);
大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW<CLOSE/OPEN+0.018;
三个白武士:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);
双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98;
孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND
REF(OPEN,1)>=REF(CLOSE,1) AND
(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF
(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND
(CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF
(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
出水芙蓉:=(OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60)) AND (C>MAX(EMA(C,20),MAX
(EMA(C,40),EMA(C,60))))
AND (V/MA(V,30)>1.2 AND C/REF(C,1)>1.049);
上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)
<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND
REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)
>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND
REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);
下跌三部曲:= REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)
>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND
REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF
(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,4);
跳空缺口:=HIGH<REF(LOW,1) OR LOW>REF(HIGH,1);
三只乌鸦:=REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF
(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1);
光脚阴线:=LOW=CLOSE AND HIGH<>LOW;
光头阳线:=HIGH=CLOSE AND HIGH<>LOW;
分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;
长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;
长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
十字星:=CLOSE=OPEN AND HIGH<>LOW;
大阴烛:=OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018;
好友反攻:=(REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF
(CLOSE,1))/CLOSE<0.002)
OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002);
倾盆大雨:=REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O>REF(O,1) AND C<REF(O,1);
解盘:='【K线形态解盘】'+
IFs(倾盆大雨,'★倾盆大雨,见顶信号;','')+
IFs(大阴烛,'★大阴烛,后市向淡,发生逆转;','')+
IFs(好友反攻,'★好友反攻,底部反转;','')+
IFs(跳空缺口,'★跳空缺口,注意向上还是向下跳空;','')+
IFs(光脚阴线,'★光脚阴线,下跌信号;','')+
IFs(光头阳线,'★光头阳线,后市看涨;','')+
IFs(三只乌鸦,'★三只乌鸦,可能见顶回落;','')+
IFs(分离,'★分离,注意看涨分离和看跌分离;','')+
IFs(长下影,'★长下影,持续下跌后出现,有可能止跌回升;在升势末期出现,须多加留意;','')+
IFs(长上影,'★长上影,表明行情上档压力沉重,升势受阻;','')+
IFs(下跌三部曲,'★下跌三部曲,下跌信号;','')+
IFs(上升三部曲,'★上升三部曲,上涨信号;','')+
IFs(早晨之星,'★早晨之星,见底回升;','')+
IFs(黄昏之星,'★黄昏之星,见顶回落;','')+
IFs(十字星,'★十字星,有转向意味,注意股价位置在顶部还是底部;','')+
IFs(长十字,'★长十字,注意在顶部还是底部;','')+
IFs(垂死十字,'★垂死十字,下跌信号;','')+
IFs(早晨十字星,'★早晨十字星,上涨信号,见底回升;','')+
IFs(黄昏十字星,'★黄昏十字星,下跌信号,见顶回落;','')+
IFs(射击之星,'★射击之星,可能见顶回落,可靠性低;','')+
IFs(倒转锤头,'★倒转锤头,可能见底回升;','')+
IFs(锤头,'★锤头,可能见底回升,如有量配合,信号强烈;','')+
IFs(吊颈,'★吊颈,上升行情中见顶回落,顶部出现,见顶信号;','')+
IFs(平顶,'★平顶,温和的反转;','')+
IFs(穿头破脚,'★穿头破脚,顶部出现,见顶回落信号;','')+
IFs(乌云盖顶,'★乌云盖顶,见顶回落信号;','')+
IFs(曙光初现,'★曙光初现,后市见底回升;','')+
IFs(身怀六甲,'★身怀六甲,出现在底部,是见底回升信号;出现在顶部,是见顶回落信意;','')+
IFs(十字胎,'★十字胎;','')+
IFs(平底,'★平底,温和的反转;','')+
IFs(大阳烛,'★大阳烛,看涨;','')+
IFs(三个白武士,'★三个白武士,每日收盘价上移,表示可能见底回升;','')+
IFs(双飞乌鸦,'★双飞乌鸦,行情将见顶回落;','')+
IFs(孕育线,'★孕育线,注意股价位置;','')+
IFs(多方炮,'★多方炮,在底部出现有上涨意味,在中间出现有可能是上涨中继,顶部出现是复 合见顶信号;','')+
IFs(出水芙蓉,'★出水芙蓉;','');
DRAWTEXTABS(6,30,解盘),LINETHICK1,COLORff00FF;
DRAWFLAGTEXT(倾盆大雨,c,'★倾盆大雨,见顶信号'),COLORFF00FF;
DRAWFLAGTEXT(大阴烛,c,'★大阴烛,后市向淡,发生逆转'),COLORFF00FF;
DRAWFLAGTEXT(好友反攻,c,'★好友反攻,底部反转'),COLORFF00FF;
DRAWFLAGTEXT(跳空缺口,c,'★跳空缺口,注意向上还是向下跳空'),COLORFF00FF;
DRAWFLAGTEXT(光脚阴线,c,'★光脚阴线,下跌信号'),COLORFF00FF;
DRAWFLAGTEXT(光头阳线,c,'★光头阳线,后市看涨'),COLORFF00FF;
DRAWFLAGTEXT(三只乌鸦,c,'★三只乌鸦,可能见顶回落'),COLORFF00FF;
DRAWFLAGTEXT(分离,c,'★分离,注意看涨分离和看跌分离'),COLORFF00FF;
DRAWFLAGTEXT(长下影,c,'★长下影,持续下跌后出现,有可能止跌回升;在升势末期出现,须多加留意'),COLORFF00FF;
DRAWFLAGTEXT(长上影,c,'★长上影,表明行情上档压力沉重,升势受阻'),COLORFF00FF;
DRAWFLAGTEXT(下跌三部曲,c,'★下跌三部曲,下跌信号'),COLORFF00FF;
DRAWFLAGTEXT(上升三部曲,c,'★上升三部曲,上涨信号'),COLORFF00FF;
DRAWFLAGTEXT(早晨之星,c,'★早晨之星,见底回升'),COLORFF00FF;
DRAWFLAGTEXT(黄昏之星,c,'★黄昏之星,见顶回落'),COLORFF00FF;
DRAWFLAGTEXT(十字星,c,'★十字星,有转向意味,注意股价位置在顶部还是底部'),COLORFF00FF;
DRAWFLAGTEXT(长十字,c,'★长十字,注意在顶部还是底部'),COLORFF00FF;
DRAWFLAGTEXT(垂死十字,c,'★垂死十字,下跌信号'),COLORFF00FF;
DRAWFLAGTEXT(早晨十字星,c,'★早晨十字星,上涨信号,见底回升'),COLORFF00FF;
DRAWFLAGTEXT(黄昏十字星,c,'★黄昏十字星,下跌信号,见顶回落'),COLORFF00FF;
DRAWFLAGTEXT(射击之星,c,'★射击之星,可能见顶回落,可靠性低'),COLORFF00FF;
DRAWFLAGTEXT(倒转锤头,c,'★倒转锤头,可能见底回升'),COLORFF00FF;
DRAWFLAGTEXT(锤头,c,'★锤头,可能见底回升,如有量配合,信号强烈'),COLORFF00FF;
DRAWFLAGTEXT(吊颈,c,'★吊颈,上升行情中见顶回落,顶部出现,见顶信号'),COLORFF00FF;
DRAWFLAGTEXT(平顶,c,'★平顶,温和的反转'),COLORFF00FF;
DRAWFLAGTEXT(穿头破脚,c,'★穿头破脚,顶部出现,见顶回落信号'),COLORFF00FF;
DRAWFLAGTEXT(乌云盖顶,c,'★乌云盖顶,见顶回落信号'),COLORFF00FF;
DRAWFLAGTEXT(曙光初现,c,'★曙光初现,后市见底回升'),COLORFF00FF;
DRAWFLAGTEXT(身怀六甲,c,'★身怀六甲,出现在底部,是见底回升信号;出现在顶部,是见顶回落信意'),COLORFF00FF;
DRAWFLAGTEXT(十字胎,c,'★十字胎'),COLORFF00FF;
DRAWFLAGTEXT(平底,c,'★平底,温和的反转'),COLORFF00FF;
DRAWFLAGTEXT(大阳烛,c,'★大阳烛,看涨'),COLORFF00FF;
DRAWFLAGTEXT(三个白武士,c,'★三个白武士,每日收盘价上移,表示可能见底回升'),COLORFF00FF;
DRAWFLAGTEXT(双飞乌鸦,c,'★双飞乌鸦,行情将见顶回落'),COLORFF00FF;
DRAWFLAGTEXT(孕育线,c,'★孕育线,注意股价位置'),COLORFF00FF;
DRAWFLAGTEXT(多方炮,c,'★多方炮,在底部出现有上涨意味,在中间出现有可能是上涨中继,顶部出现是复 合见顶信号'),COLORFF00FF;

大智慧史上最强操盘主图指标公式

 

相关文章