在线检测未来函数

通达信精品KDJ新算法指标公式

来源:Internet,编辑:股旁网,2016-10-24

M:=10;M1:=3;
DIFF: EMA(CLOSE,12) - EMA(CLOSE,26),COLORWHITE;
DEA: EMA(DIFF,9),COLORYELLOW;
MACD:=2*(DIFF-DEA), COLORSTICK;
RSV:(DIFF -LLV(DIFF ,M))/(HHV(DIFF ,M)-LLV(DIFF ,M))*100,COLORYELLOW;
K:SMA(RSV,M1,1),COLORWHITE;
D:SMA(K,M1,1),COLORBLUE;
J:3*K-2*D,COLORF00FF0;
VAR1:=MA(LOW,1);
VAR3:=MA(CLOSE,2);
VAR7:=REF(VAR3,1);
VAR8:=SMA(MAX(VAR3-VAR7,0),13,1)/SMA(ABS(VAR3-VAR7),13,1)*100;
VARB:=MA(INDEXC,3)*100/MA(INDEXC,10)-100;
VARE:=IF(VARB>10,10,VARB);
VARF:=IF(VARE<-10,-10,VARE);
VAR12:=REF(VARB,1);
VAR13:=100*(VAR3-REF(VAR3,1))/REF(VAR3,1);
VAR14:=INDEXC;
VAR15:=REF(VAR14,1);
VAR16:=100*(VAR14-VAR15)/VAR14;
VAR17:=MA(VAR13,3);
VAR18:=MA(VAR16,3);
VAR19:=(3*CLOSE+VAR1+OPEN+HIGH)/6;
VAR1A:=(20*VAR19+19*REF(VAR19,1)+18*REF(VAR19,2)+17*REF(VAR19,3)+16*REF(VAR19,4)+15*REF(VAR19,5)+14*REF(VAR19,6)+13*REF(VAR19,7)+12*REF(VAR19,8)+11*REF(VAR19,9)+10*REF(VAR19,10)+9*REF(VAR19,11)+8*REF(VAR19,12)+7*REF(VAR19,13)+6*REF(VAR19,14)+5*REF(VAR19,15)+4*REF(VAR19,16)+3*REF(VAR19,17)+2*REF(VAR19,18)+REF(VAR19,20))/210;
VAR1B:=MA(VAR1A,12);
VAR1D:=ABS(VAR1A-VAR1B);
VAR1E:=REF(VAR3,1)*0.015;
VAR1F:=REF(INDEXC,1);
【强弱】:=SMA(MAX(VAR3-VAR7,0),5,1)/SMA(ABS(VAR3-VAR7),5,1)*100;
DRAWTEXT(DAY=1 AND VAR17>VAR18,100,' 个股强盘!'),COLORFF00FF;
DRAWTEXT(DAY=1 AND VAR12>VARF,80,' 盘处下道'),COLORCCFF99;
DRAWTEXT(DAY=1 AND VAR18>=VAR17,60,' 个股弱盘!'),COLOR00FFFF;
DRAWTEXT(DAY=1 AND VAR1A>VAR1B AND VAR1D>VAR1E AND NOT(CROSS(75,VAR8)),40,' 持股待涨!'),COLOR0099FF;
DRAWTEXT(DAY=1 AND VAR1A<VAR1B AND VAR1D>VAR1E AND NOT(CROSS(【强弱】,20)),120,' 下调减持!'),COLORFF9900;
DRAWTEXT(DAY=1 AND VAR1D<=VAR1E,90,' 盘整阶段!'),COLORFF9900;
DRAWTEXT(DAY=1 AND (INDEXC-VAR1F)/VAR1F>0.035,50,'井喷行情!'),COLORRED;

通达信精品KDJ新算法指标公式

 

相关文章