在线检测未来函数

通达信新涨停回马枪指标公式

来源:Internet,编辑:股旁网,2016-10-25

STICKLINE(C>0,0,10,20,0),COLOR663300;
0,COLORWHITE;
10,COLORWHITE;
DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:= EMA(DIFF,9);
MACD:= 2*(DIFF-DEA);
A1:= BARSLAST((C/REF(C,1)-1)*100>9.5);
A2:= IF(REF(L,A1)>REF(H,A1+1),REF(C,A1+1),REF(O,A1));
A3:= BETWEEN(A1,2,13);
A4:= C>=A2 AND BETWEEN(L/A2,1.035,0.97);
A5:= V<REF(V,1) AND V<MA(V,5);
A6:= ABS(C/O-1)*100<5;
A7:= LLV(C,A1)>=A2;
A8:= MACD>-1;
关注:=A3 AND A4 AND A5 AND A6 AND A7 AND A8;
A9:=MA(C,5)>=A2 AND C>A2 AND C>=MA(C,5) AND REF(C,1)<=REF(MA(C,5),1)
AND LLV(L,A1)<A2*1.045;
买入:=REF(A3,1)>0 AND A9;
ZTF:=IF((C/REF(C,1)-1)*100>9.5,1,0);
STICKLINE(ZTF,0,5,2.4,0),COLOR335555;
STICKLINE(ZTF,0,5,1.8,0),COLOR338888;
STICKLINE(ZTF,0,5,1.2,0),COLOR33AAAA;
STICKLINE(ZTF,0,5,0.6,0),COLOR33CCCC;
STICKLINE(ZTF,0,5,0.1,0),COLOR33EEEE;
DRAWTEXT(ZTF,7,'涨停'),COLOR33EEEE;
STICKLINE(关注 AND NOT(ZTF),0,5,2.4,0),COLOR550055;
STICKLINE(关注 AND NOT(ZTF),0,5,1.8,0),COLOR880088;
STICKLINE(关注 AND NOT(ZTF),0,5,1.2,0),COLORAA00AA;
STICKLINE(关注 AND NOT(ZTF),0,5,0.6,0),COLORCC00CC;
STICKLINE(关注,0,5,0.1,0),COLOREE00EE;
DRAWTEXT(关注,7,'关注'),COLOREE00EE;
STICKLINE(买入 AND NOT(ZTF),0,5,2.4,0),COLOR000055;
STICKLINE(买入 AND NOT(ZTF),0,5,1.8,0),COLOR000088;
STICKLINE(买入 AND NOT(ZTF),0,5,1.2,0),COLOR0000AA;
STICKLINE(买入 AND NOT(ZTF),0,5,0.6,0),COLOR0000CC;
STICKLINE(买入,0,5,0.1,0),COLOR0000EE;
DRAWTEXT(买入,7,'买入'),COLOR0000EE;

通达信新涨停回马枪指标公式

 

相关文章