在线检测未来函数

通达信大杂烩指标公式

来源:Internet,编辑:股旁网,2016-10-25

VAR1:=1;
VAR2:=1/WINNER(CLOSE);
VAR3:=MA(CLOSE,13);
VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);
VAR5:=LLV(LOW,75);
VAR6:=HHV(HIGH,75);
VAR7:=(VAR6-VAR5)/100;
VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);
VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);
VARA:=3*VAR8-2*SMA(VAR8,15,1);
VARB:=3*VAR9-2*SMA(VAR9,15,1);
VARC:=100-VARB;
主力:(100-VARA)*VAR1,COLOR31A5FB,LINETHICK2;
散户: MA(WINNER(CLOSE*0.95)*100,3)*VAR1,COLOR37D8F4,LINETHICK2;
新庄: (100-IF(VAR2>5,IF(VAR2<100,VAR2,VAR4-10),0))*VAR1,COLORGREEN,LINETHICK1,POINTDOT ;
VARD:=散户>VAR4;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
STICKLINE(VARD,VAR4,散户,3,0),COLORWHITE;
STICKLINE(1,新庄,100,1,0),COLORGREEN;
STICKLINE(VAR20,0,80,3,0),COLORRED,LINETHICK3 ;
VAR26:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VAR28:=SMA(VAR26,3,1);
VAR1J:=IF(DATE<1090906 AND DATE>900101,1,1);
神: SMA(VAR28,3,1)*VAR1J,COLORYELLOW,LINETHICK2;
鬼: SMA(神,3,1)*VAR1,COLORYELLOW,LINETHICK2;
地狱:IF(CROSS(神,鬼) AND 神<40,35,0)*VAR1,COLOR0066FF ,LINETHICK2 ;
天堂:IF(CROSS(鬼,神) AND 鬼>75,70,100)*VAR1,COLORGREEN ,LINETHICK2 ;
DRAWTEXT(CROSS(神,鬼) AND 神<40,25,'★逢低吸呐 !'),COLORWHITE ;
DRAWTEXT(CROSS(鬼,神) AND 鬼>75,85,'☆逢高减磅!'),COLORFFFF00 ;
天:IF(神>=鬼,神,鬼),LINETHICK2,COLORFF00FF;
浪:IF(鬼-神,鬼,神),LINETHICK2,COLORBLUE;
发:=天-浪;
个:=浪-神;
STICKLINE(FILTER(发<REF(发,1) AND (神>=浪),3),鬼,神,3,1),COLORGREEN;
STICKLINE(FILTER(个<REF(个,1) AND (天<=浪),3),鬼,神,3,1),COLORRED;

通达信大杂烩指标公式

 

相关文章