在线检测未来函数

通达信涨停赌一把副图及选股指标公式

来源:Internet,编辑:股旁网,2016-10-26

涨幅:=(C-REF(C,1))/REF(C,1)*100;昨天涨幅:=REF(涨幅,1);
DIF:=EMA(CLOSE,13)-EMA(CLOSE,26);DEA:=EMA(DIF,3);MACD:=(DIF-DEA)*2;
BIAS:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA60:=MA(CLOSE,60);
A1:=IF(C>=MA5,1,-1);
A2:=IF(C>=MA10,1,-1);
A3:=IF(C>=MA20,1,-1);
A4:=IF(MA5>=REF(MA5,1),1,-1);
A5:=IF(MA10>=REF(MA10,1),1,-1);
A6:=IF(MA20>=REF(MA20,1),1,-1);
趋势:=(A1+A2+A3+A4+A5+A6)/6*100;
底部:=-10;
SSRCJL:=EMA(VOL,13);
SSRCJE:=EMA(AMOUNT,13);
SSRCBJX:=((SSRCJE / SSRCJL) / 100);
SSRGL:=(((CLOSE - SSRCBJX) / SSRCBJX) * 100);
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
短期底部:=LLV(OPEN,30);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
SG:=EMA(HHV(HIGH,1),8);
X1:=EMA(CLOSE,8);
X30:=((X1 < REF(X1,1)) AND (CLOSE < X1));
X31:=IF(((SG < REF(SG,1)) OR X30),1,0);
全仓出击:=((((COUNT((X31 = 1),4) = 3) AND (X31 = 0)) AND (((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) > 0.085)) * 89);
STICKLINE(全仓出击 AND MACD>=-0.01 AND CAPITAL<15000000 AND REF(涨幅,1)<6,3.9,0,3,0),COLORRED;
DRAWTEXT((全仓出击 >= 89 AND MACD>=-0.01 AND CAPITAL<15000000 AND REF(涨幅,1)<6),3.5,'--赌一把'),COLORYELLOW;
次上趋势:=MA(LOW,20)*1.08;
主升浪:=BIAS>8 AND 趋势=100;
STICKLINE(主升浪=1,1,3,3,0),COLORRED;
STICKLINE(J>=D AND 趋势=100 AND C>=次上趋势,0,1,3,0),COLORYELLOW;
JS:=100*(CLOSE-REF(CLOSE,5))/(5*REF(CLOSE,5));MAJS1:=MA(JS,5);MAJS2:=MA(JS,10);
振10:=(HHV(H,10)/LLV(L,10)-1)*100;振幅前10:=REF(振10,1);
赌一把:=ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,2) AND C/REF(C,1)>1.071
AND BIAS-REF(BIAS,1)>6 AND MA5>MA10 AND MA10>MA20 AND MA10>MA60
AND CROSS(J,D) AND MAJS1>REF(MAJS1,1) AND MAJS2>REF(MAJS2,1)
AND 振幅前10<15;
DRAWICON(赌一把,3.3,1);

{
选股公式:

涨幅:=(C-REF(C,1))/REF(C,1)*100;昨天涨幅:=REF(涨幅,1);
DIF:=EMA(CLOSE,13)-EMA(CLOSE,26);DEA:=EMA(DIF,3);MACD:=(DIF-DEA)*2;
BIAS:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA60:=MA(CLOSE,60);
A1:=IF(C>=MA5,1,-1);
A2:=IF(C>=MA10,1,-1);
A3:=IF(C>=MA20,1,-1);
A4:=IF(MA5>=REF(MA5,1),1,-1);
A5:=IF(MA10>=REF(MA10,1),1,-1);
A6:=IF(MA20>=REF(MA20,1),1,-1);
趋势:=(A1+A2+A3+A4+A5+A6)/6*100;
底部:=-10;
SSRCJL:=EMA(VOL,13);
SSRCJE:=EMA(AMOUNT,13);
SSRCBJX:=((SSRCJE / SSRCJL) / 100);
SSRGL:=(((CLOSE - SSRCBJX) / SSRCBJX) * 100);
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
短期底部:=LLV(OPEN,30);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
SG:=EMA(HHV(HIGH,1),8);
X1:=EMA(CLOSE,8);
X30:=((X1 < REF(X1,1)) AND (CLOSE < X1));
X31:=IF(((SG < REF(SG,1)) OR X30),1,0);
全仓出击:=((((COUNT((X31 = 1),4) = 3) AND (X31 = 0)) AND (((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) > 0.085)) * 89);
次上趋势:=MA(LOW,20)*1.08;
主升浪:=BIAS>8 AND 趋势=100;
JS:=100*(CLOSE-REF(CLOSE,5))/(5*REF(CLOSE,5));MAJS1:=MA(JS,5);MAJS2:=MA(JS,10);
振10:=(HHV(H,10)/LLV(L,10)-1)*100;振幅前10:=REF(振10,1);
赌一把:ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,2) AND C/REF(C,1)>1.071
AND BIAS-REF(BIAS,1)>6 AND MA5>MA10 AND MA10>MA20 AND MA10>MA60
AND CROSS(J,D) AND MAJS1>REF(MAJS1,1) AND MAJS2>REF(MAJS2,1)
AND 振幅前10<15;
}

通达信涨停赌一把副图及选股指标公式

 

相关文章