在线检测未来函数

通达信超漂亮的MACD指标公式

来源:Internet,编辑:股旁网,2016-10-27

DIFF:(EMA(C,12)-EMA(C,26))*20,COLORWHITE,LINETHICK1;
DEA:EMA(DIFF,9),COLORYELLOW,LINETHICK1;
MACD:=2*(DIFF-DEA);
MACD1:=2*(DIFF-DEA);
MACD2:=EMA((3*MACD1+2*REF(MACD1,1)+REF(MACD1,2))/6,1);
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLORYELLOW;
STICKLINE(MACD1<MACD2,0,MACD1,0,0),COLORCYAN;
S1:=MACD<0;
S2:=(MACD>=0);
S3:=BARSLAST(CROSS(DIFF,DEA));
S4:=REF(S3,S3+1);
S5:=DEA>REF(DEA,S4);
S6:=DEA;
上成立:IF(CROSS(DIFF,DEA) AND S5,3,0),COLORYELLOW;
下成立:IF(CROSS(DIFF,DEA) AND S6,3,0),COLOR000098;
L1:=(EMA(C,3)-EMA(C,13));
L2:=EMA(L1,9);
变盘:=CROSS(L1,L2){ AND L2};
STICKLINE(变盘,5,-5,1,1),COLORD6FF9C;
成立距今:BARSLAST(CROSS(DIFF,DEA)),NODRAW;
DRAWICON(CROSS(L1,L2),DIFF,1);
DRAWICON(CROSS(L2,L1),DIFF,2);
MD:=REF(DEA,S3),POINTDOT,COLORGREEN;
金山:IF(L1>L2,MD,DRAWNULL),CIRCLEDOT,COLOR0088FF;
钻坑:IF(MACD<0,MD,DRAWNULL),CIRCLEDOT,COLORFFAA00;
IF(DIFF>DEA,DIFF,DRAWNULL),COLORFF11CC,LINETHICK1;
LS:=IF(DIFF>DEA AND DIFF>0,1,0);
加速上扬:IF(REF(LS=0,1) AND LS=1,3,0),COLOREEEEEE;
{XG1:=CROSS(MACD1,MACD2) AND MACD1<0,LINETHICK0;
XG2:=CROSS(DIFF,DEA),LINETHICK0};
M1:=MACD>REF(MACD,1) AND DIFF<DEA;
绿柱短了:=M1 AND COUNT(M1,10)=1 AND C>MA(C,55) AND COUNT(MACD<0,5)>=5;
DRAWTEXT(绿柱短了,MACD-2.8,'绿柱短了');

通达信超漂亮的MACD指标公式

 

相关文章