在线检测未来函数

通达信潜龙主图指标公式

来源:Internet,编辑:股旁网,2016-11-04

MA5:MA(C,5),COLORWHITE;
MA11:MA(C,11),COLORYELLOW;
MA21:MA(C,21),COLORMAGENTA;
MA31:MA(C,41),COLORGREEN;
MA60:MA(C,61),COLORBLUE;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
龙:=(AV + NEWVOL);
AA:=MA(C,40)>REF(MA(C,40),1) AND REF(MA(C,40),1)>REF(MA(C,40),2);
BB:=MA(C,60)>REF(MA(C,60),1) AND REF(MA(C,60),1)>REF(MA(C,60),2);
CC:=MA(C,20)>REF(MA(C,20),1) AND REF(MA(C,20),1)>REF(MA(C,20),2);
EE:=(AA OR BB OR CC);
DRAWTEXT(CROSS(龙,0) AND EE,L*0.98,'潜'),COLORRED;
V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
HY1:=REF(EMA(V1,3),1);
上收:=C;
{
上开:=O;
上高:=H;
上低:=L;
JJ:=(上开+上高+上低)/3;
A:=EMA(JJ,4);
黄金线:A,COLORFFFF00,LINETHICK1;
能量线:=DMA(((CLOSE + OPEN) / 2),(VOL / (SMA(VOL,4,1) *4)));
}
箱顶:MA(REF(HHV(上收,30),1),2),COLORBLUE,LINETHICK1;
箱底:MA(REF(LLV(上收,30),1),2),COLORBLACK,LINETHICK1;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR12:=(HIGH+LOW+CLOSE)/3;
VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));
VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));
VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);
VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);
VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR18:=100-ABS(VAR17);
VAR19:=IF(VAR18<90,VAR18,100);
VAR1A:=IF(VARE>0,VARE,0);
VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,HIGH*1.05,'大笔出'),LINETHICK1,COLORFFCC66;
VAR2:=(2*CLOSE+HIGH+LOW)/4;
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4);
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2);
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L*0.92,'吸'),COLORRED;
DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H*1.02,'抛'),COLORGREEN;
VVAR3:=REF(CLOSE,1);
VVAR4:=SMA(MAX(CLOSE-VVAR3,0),6,1)/SMA(ABS(CLOSE-VVAR3),6,1)*100;
DRAWTEXT(CROSS(84,VVAR4),H*1.05,'逃'),COLORYELLOW ;
VVAR5:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VVAR6:=SMA(ABS(LOW-VVAR5),13,1)/SMA(MAX(LOW-VVAR5,0),10,1);
VVAR7:=EMA(VVAR6,10);
VVAR8:=LLV(LOW,33);
VVAR9:=EMA(IF(LOW<=VVAR8,VVAR7,0),5);
主力:=FILTER(VVAR9>REF(VVAR9,1),5);
DRAWTEXT(主力,L*0.9,'入'),COLORRED;
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.96),'建'),COLORYELLOW;

通达信潜龙主图指标公式

 

相关文章