在线检测未来函数

同花顺牛头马面指标公式

来源:Internet,编辑:股旁网,2016-11-18

BIAS1 := (CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
BIAS2 := (CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
BIAS3 := (CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100;
BIASAA:=(BIAS1+BIAS2+BIAS3)/3;
dif:=(EMA(BIASAA,5)-EMA(BIASAA,34));
de:=EMA(dif,9);
MACD:3*(dif-de);
//////////////
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,3,0),COLOR0000AA;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2.7,0),COLOR0000BB;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2.3,0),COLOR0000CC;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,2,0),COLOR0000CC;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,1.6,0),COLOR0000DD;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,1.2,0),COLOR0000EE;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.8,0),COLOR0000FF;
STICKLINE(MACD>0 AND MACD>REF(MACD,1),MACD,0,0.5,0),colorred;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,3,0),color0090FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,2.7,0),color009FFF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,2.3,0),color00a6FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,2,0),color00b5FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,1.6,0),color00c4FF;;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,1.2,0),Color00d3ff;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.8,0),color00e2FF;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.5,0),color00FFFF;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,3,0),COLORFF0000;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,2.7,0),COLORFF3300;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,2.3,0),COLORFF5500;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,2,0),COLORFF7700;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,1.6,0),COLORFF9900;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,1.2,0),COLORFFBB00;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,0.8,0),COLORFFDD00;
STICKLINE(MACD<0 AND MACD<REF(MACD,1),MACD,0,0.5,0),COLORFFFF00;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,3,0),ColorFF00a9;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,2.7,0),ColorFF00a1;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,2.3,0),ColorFF00aa;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,2,0),ColorFF00bb;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,1.6,0),ColorFF00cc;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,1.2,0),ColorFF00dd;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.8,0),ColorFF00ee;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.5,0),ColorFF00ff;
/////////
b5:=SMA(BIAS1,2,1),colorgreen,LINETHICK1,LINEDOT;
b13:=SMA(BIAS2,2,1),LINETHICK0,colorred;
b34:=SMA(BIAS3,5,1),colorwhite,LINETHICK1;
m13_5:EMA(b13,5),colorwhite,LINETHICK1;
m13_10:EMA(b13,10),colorcyan,LINETHICK1;
m34_5:=EMA(b34,5),colorgreen,,LINEDOT;
m34_10:=EMA(b34,10),colormagenta,LINEDOT;
cysm13:b13,LINETHICK0,colorbrown;
牛头:m34_5,colorgreen,,LINEDOT;
马面:m34_10,colormagenta,LINEDOT;
/////////
DRAWICON(CROSS(b13,m13_5),m13_5,12),ALIGN;
DRAWICON(CROSS(m13_5,b13),m13_5,11),ALIGN;
DRAWICON(CROSS(m13_5,m13_10) AND b13>REF(b13,1),0,3),ALIGN;
DRAWICON(CROSS(m34_5,m13_10) AND b13>REF(b13,1) ,0,1),ALIGN;
/////////////
AAA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AAA,0),5,1)/SMA(ABS(CLOSE-AAA),5,1)*1000;
HHH:=BBB-LLV(BBB,10);
SS:=(MA(HHH,2)*3+HHH*13)/16;
短线买点:=IF(SS>13,MA(SS,2),SS)/6;
短线出击:IF(CROSS(短线买点,1) AND (短线买点<30),10,0),colorwhite,LINETHICK2;

同花顺牛头马面指标公式

 

相关文章