在线检测未来函数

通达信均线三态指标公式

来源:Internet,编辑:股旁网,2016-11-23

MA1:=MA(C,5);
MA2:=MA(C,10);
MA3:=IF(FINANCE(42)>=30,MA(C,30),EMA(C,30));
MA4:=IF(FINANCE(42)>=60,MA(C,60),EMA(C,60));
MA5:=IF(FINANCE(42)>=120,MA(C,120),EMA(C,120));
MA6:=IF(FINANCE(42)>=250,MA(C,250),EMA(C,250));
GZ:=MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA3>REF(MA3,1) AND MA4>REF(MA4,1) AND MA5>REF(MA5,1) AND MA6>REF(MA6,1);
DT:=MA1>MA2 AND MA2>MA3 AND MA3>MA4 AND MA4>MA5 AND MA5>MA6;
均线粘合:MAX(MAX(MAX(MAX(MAX(MA1,MA2),MA3),MA4),MA5),MA6)/MIN(MIN(MIN(MIN(MIN(MA1,MA2),MA3),MA4),MA5),MA6),COLORGREEN;
六线共振:BARSLASTCOUNT(GZ),COLORYELLOW,NODRAW;
均线多头:BARSLASTCOUNT(DT),COLORRED,NODRAW;
三线粘合:MAX(MAX(MA1,MA2),MA3)/MIN(MIN(MA1,MA2),MA3),NODRAW;
四线粘合:MAX(MAX(MAX(MA1,MA2),MA3),MA4)/MIN(MIN(MIN(MA1,MA2),MA3),MA4),NODRAW;
五线粘合:MAX(MAX(MAX(MAX(MA1,MA2),MA3),MA4),MA5)/MIN(MIN(MIN(MIN(MA1,MA2),MA3),MA4),MA5),NODRAW;
PLOYLINE(均线粘合,均线粘合),COLORGREEN;
STICKLINE(均线多头,1.1,均线粘合,3,0),COLOR000088;
STICKLINE(均线多头,1.1,均线粘合,2.5,0),COLOR000099;
STICKLINE(均线多头,1.1,均线粘合,2,0),COLOR0000AA;
STICKLINE(均线多头,1.1,均线粘合,1.5,0),COLOR0000BB;
STICKLINE(均线多头,1.1,均线粘合,1.0,0),COLOR0000DD;
STICKLINE(均线多头,1.1,均线粘合,0.5,0),COLOR0000FF;{//红柱}
STICKLINE(均线粘合<=1.1 AND 均线多头=0 ,1.1,均线粘合,3,0),COLOR008800;
STICKLINE(均线粘合<=1.1 AND 均线多头=0,1.1,均线粘合,2.5,0),COLOR00AA00;
STICKLINE(均线粘合<=1.1 AND 均线多头=0,1.1,均线粘合,2,0),COLOR00BB00;
STICKLINE(均线粘合<=1.1 AND 均线多头=0,1.1,均线粘合,1.5,0),COLOR00DD00;
STICKLINE(均线粘合<=1.1 AND 均线多头=0,1.1,均线粘合,1,0),COLOR00FF00;{//绿柱};
STICKLINE(六线共振 AND 均线多头=0,1.1,均线粘合,2,0),COLORYELLOW;

通达信均线三态指标公式

 

相关文章