在线检测未来函数

通达信K线小夜曲主图指标公式

来源:Internet,编辑:股旁网,2016-11-24

LC:=REF(C,1);
MA5:=MA(C,5);
K:=BARSLAST(CURRBARSCOUNT=250);
高1:=CONST(IF(ISLASTBAR=1,HHV(H,K),0));
低0:=CONST(IF(ISLASTBAR=1,LLV(L,K),0)),COLOR00FF00;
KJ:=高1-低0;
GD4:=IF(CURRBARSCOUNT<=250/2,高1,DRAWNULL);
顶:=REFDATE(高1,DATE),COLORFF8800;
高压:=IF(1=1,低0+KJ*0.873,DRAWNULL),COLOR0000FF,NODRAW;
压力:=IF(1=1,低0+KJ*0.809,DRAWNULL),COLORFF00FF,NODRAW;
上中:=IF(1=1,低0+KJ*0.618,DRAWNULL),COLORMAGENTA,NODRAW;
中线:=IF(1=1,低0+KJ/2,DRAWNULL),COLORCCCCCC,POINTDOT;
下中:=IF(1=1,低0+KJ*0.382,DRAWNULL),COLORMAGENTA,NODRAW;
支撑:=IF(1=1,低0+KJ*0.191,DRAWNULL),COLORFFAA00,NODRAW;
超跌:=IF(1=1,低0+KJ*0.127,DRAWNULL),COLORFFAA00,;
{该行设置背景色}
STICKLINE(1=1,GD4,高压,10,0),COLOR110000;
STICKLINE(1=1,高压,压力,10,0),COLOR330000;
STICKLINE(1=1,压力,上中,10,0),COLOR550000;
STICKLINE(1=1,上中,下中,10,0),COLOR770000;
STICKLINE(1=1,下中,支撑,10,0),COLOR990000;
STICKLINE(1=1,支撑,低0,10,0),COLORAA0000;
黄金分割中线:IF(1=1,低0+KJ/2,DRAWNULL),COLORCCCCCC,POINTDOT;
卖:MA5*1.1,LINETHICK1,COLOR00CCFF;
高:MA5*1.05,LINETHICK1,COLOR0000FF;
中:MA5,LINETHICK1,COLOR999999;
低:MA5*0.945,LINETHICK1,COLORFFAA00;
买:MA5*0.88,LINETHICK1,COLOR00FF00;
STICKLINE(C>LC AND C>O,H,H*0.92,0,0),COLORFFFFFF;
STICKLINE(C>LC AND C>O AND C>高,H,H*0.9,0,0),COLORFFFFFF;
STICKLINE(1=1,H,L,0,0),COLORFFFFFF;
STICKLINE(C<LC AND C<O,L,L*1.08,0,0),COLORFFFFFF;
STICKLINE(C<LC AND C<O AND C<低,L,L*1.1,0,0),COLORFFFFFF;
IF(C>=LC AND C>O,H,DRAWNULL),POINTDOT,LINETHICK9,COLOR000099;
IF(C>=LC AND C<O,L*0.98,DRAWNULL),POINTDOT,LINETHICK9,COLORFF5500;
IF(C<=LC AND C<O,L,DRAWNULL),POINTDOT,LINETHICK9,COLORFF5500;
IF(C<=LC AND C>O,H*0.995,DRAWNULL),POINTDOT,LINETHICK9,COLORFF5500;
IF(C<=MA5*0.945,L*1.03,DRAWNULL),POINTDOT,LINETHICK9,COLORFFFF00;
IF(C<=MA5*0.945,L,DRAWNULL),POINTDOT,LINETHICK9,COLORFFFF00;
IF(C<=买 AND C<O,L*1.03,DRAWNULL),POINTDOT,LINETHICK9,COLOR00FF00;
IF(C<=买 AND C<O,L,DRAWNULL),POINTDOT,LINETHICK7,COLOR00FA00;
IF(C>=MA5*1.05 AND L>MA5*0.945,H*0.97,DRAWNULL),POINTDOT,LINETHICK9,COLOR0000FF;
IF(C>=MA5*1.05 AND L>MA5*0.945,H,DRAWNULL),POINTDOT,LINETHICK9,COLOR0000FF;
IF(C>=MA5*1.1,H*0.97,DRAWNULL),POINTDOT,LINETHICK9,COLOR00CCFF;
IF(C>=MA5*1.1,H,DRAWNULL),POINTDOT,LINETHICK9,COLOR00CCFF;
DRAWICON(FILTER(C<MA5*0.945,10),H*1.235,26);
DRAWTEXT(FILTER(C<MA5*0.945,10),H*1.28,'《'),COLORCC00FF;
{DRAWTEXT(FILTER(C<MA5*0.945,10),H*1.22,'◆'),COLOR00CCFF;}
DRAWTEXT(FILTER(C<MA5*0.945,10),H*1.25,'〓'),COLORCC00FF;
DRAWTEXT(FILTER(C<MA5*0.945,10),H*1.25,'◆'),COLORCC00FF;
DRAWTEXT(FILTER(C<MA5*0.945,10),H*1.22,'《'),COLORCC00FF;
{DRAWTEXT(FILTER(C<MA5*0.945,10),H*1.225,'▲●'),COLOR00CCFF;}
IF(FILTER(C<MA5*0.945,10),H*1.28,DRAWNULL),POINTDOT,LINETHICK4,COLOR000000;
IF(FILTER(C<MA5*0.945,10),H*1.225,DRAWNULL),POINTDOT,LINETHICK5,COLOR000000;
IF(FILTER(C<MA5*0.945,10),H*1.25,DRAWNULL),POINTDOT,LINETHICK9,COLOR00CCFF;
IF(FILTER(C<MA5*0.945,10),H*1.25,DRAWNULL),POINTDOT,LINETHICK5,COLORAA0000;
IF(FILTER(C<MA5*0.945,10),H*1.25,DRAWNULL),POINTDOT,LINETHICK3,COLOR00CCFF;
DRAWTEXT(FILTER(C<MA5,30),卖,'#'),COLORFFFFFF;

通达信K线小夜曲主图指标公式

 

相关文章