在线检测未来函数

通达信超跌组合指标公式

来源:Internet,编辑:股旁网,2016-11-28

VARAA:=AMOUNT/(100*VOL);
CYC13:=MA(VARAA,13);
CYC34:=MA(VARAA,34);
CYCMAX:=DMA(C,VOL/CAPITAL);
CYS13:=(C-CYC13)/CYC13*100;
CYS34:=(C-CYC34)/CYC34*100;
CYSMAX:=(C-CYCMAX)/CYCMAX*100;
亏损程度:
IF(CYS13<=-7,7,0),COLORWHITE,STICK,LINETHICK3;
IF(CYS13<=-10,10,0),COLORFFFF33,STICK,LINETHICK3;
IF(CYS13<=-16,16,0),COLORBLUE,STICK,LINETHICK3;
IF(CYS13<=-20,20,0),COLOR00FF77,STICK,LINETHICK3;
IF(CYS13<=-25,25,0),COLORYELLOW,STICK,LINETHICK3;
IF(CYS13<=-30,30,0),COLORFF00FF,STICK,LINETHICK3;
VAR1:=COST(10)*0;
VAR2:=REF(HIGH,1)*1.1;
VAR3:=HIGH*1.1;
VAR4:=(VAR3*VOL+VAR2*(CAPITAL-VOL))/CAPITAL;
VAR5:=REF(LOW,1)*0.9;
VAR6:=LOW*0.9;
VAR7:=(VAR6*VOL+VAR5*(CAPITAL-VOL))/CAPITAL;
VAR8:=EMA(VAR7,30);
VAR9:=EMA(VAR4,30);
VARA:=VAR9-2;
VARB:=IF(CLOSE<=VAR8,VARA,VAR9);
超跌:=VARB*2.5,COLOR00FF00;
TAO:=100*(1-WINNER(C));
A:=1.1*C;
B:=0.9*C;
ASR:=100*(WINNER(A)-WINNER(B));
筹码超跌:IF((ASR<10) AND (TAO>90),30,0),COLOR0099FF;
短中长线超跌:IF((CYS13<(-16)) AND (CYS13>(-100)) AND (CYS34<(-20)) AND (CYS34>(-100)),40,0),COLORDDDDFF;
IF((CYS34<(-20)) AND (CYS34>(-100)) AND (CYSMAX<(-30)) AND (CYSMAX>(-100)),50,0),COLORFFCC00;
反弹:=VARA*2.5,COLORFF00FF;
风:IF(超跌=反弹 AND CYS13<=-10 AND 筹码超跌=30,-30,0),COLORYELLOW,STICK,LINETHICK3;
云:IF(超跌=反弹 AND CYS13<=-16 AND 筹码超跌=30 AND 短中长线超跌=40,-20,0),COLORRED,STICK,LINETHICK3;
VARF:=REF(LOW,1)*0.9;
VAR10:=LOW*0.9;
VAR11:=(VAR10*VOL+VARF*(CAPITAL-VOL))/CAPITAL;
VAR12:=EMA(VAR11,30);
VAR13:=CLOSE-REF(CLOSE,1);
VAR14:=MAX(VAR13,0);
VAR15:=ABS(VAR13);
VAR16:=SMA(VAR14,7,1)/SMA(VAR15,7,1)*100;
VAR17:=SMA(VAR14,13,1)/SMA(VAR15,13,1)*100;
VAR18:=BARSCOUNT(CLOSE);
VAR19:=SMA(MAX(VAR13,0),6,1)/SMA(ABS(VAR13),6,1)*100;
VAR1A:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1B:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1C:=SMA((SMA(VAR1B,4,1)-50)*2,3,1);
VAR1D:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1E:=SMA(VAR1D,4,1);
VAR1F:=SMA(VAR1E,3,1);
VAR20:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR21:=VAR19<=25 AND VAR1A<-95 AND VAR20>20 AND VAR1C<-30 AND VAR1F<30 AND VAR12-CLOSE>=-0.25 AND VAR16<22 AND VAR17<28 AND VAR18>50;
血战超跌: STICKLINE(VAR21,0,60,5,0);
RG1:=MA(CLOSE,27);
RG2:=((CLOSE - RG1)/(RG1))*(100);
RG3:=MA(RG2,2);
RG4:=BARSLAST((CROSS((-10),RG3) = 1));
RG5:=(RG3 < (-10)) AND (RG4 > 3);
V1:=C/REF(MA(C,36),6)*10;
RF1:=EMA(CLOSE,3);
RF2:=((SMA(MAX((CLOSE - RF1),0),9,1) / SMA(ABS((CLOSE - RF1)),9,1)) * 100);
RF3:=((100 - (3 * SMA((((CLOSE - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),30,1))) + (2 * SMA(SMA((((CLOSE - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),30,1),21,1)));
RF4:=((100 - (3 * SMA((((OPEN - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),30,1))) + (2 * SMA(SMA((((OPEN - LLV(LOW,75)) / (HHV(HIGH,75) - LLV(LOW,75))) * 100),30,1),21,1)));
RF5:=((((HHV(HIGH,21) - CLOSE) / (HHV(HIGH,21) - LLV(LOW,21))) * 100) - 10);
RF6:=(((CLOSE - LLV(LOW,21)) / (HHV(HIGH,21) - LLV(LOW,21))) * 100);
RF7:=SMA(SMA(RF6,16,8),25,8)-SMA(RF5,30,8);
K0:=IF((RF2< 14) AND L<REF(L,1) AND V1<8.8 AND RF7<-65,50,0);
K1:=IF(K0>1 AND C>O,50,0),STICK,COLOR10FFFF,LINETHICK3;
K2:=IF(K0>1 AND C/L>1.045,50,0);
K3:=IF(REF(K0,1)>0 AND K0=0,10,0);
准备1:IF(K0>3 AND RG5=0,16,0),STICK,COLOR10FFFF,LINETHICK3;
K4:=IF(MAX(MAX(K1,K2),K3) AND REF(准备1,1)>0,30,0);
进场1:IF(K4>0 AND REF(K4,1)=0,30,0),STICK,COLOR00FF00,LINETHICK3;
DRAWTEXT(进场1,28,进场1),COLOR10FF10;
DRAWTEXT(准备1,12,准备1),COLOR10FFFF;
准备2:IF(K0>3 AND RG5>0,16,0),STICK,COLORFF00FF,LINETHICK3;
K5:=IF(MAX(MAX(K1,K2),K3) AND REF(准备2,1)>0,30,0);
进场2:IF(K5>1 AND REF(K5,1)=0,30,0),STICK,COLORFFFF00,LINETHICK3;
DRAWTEXT(进场2,28,进场2),COLORFFFF00;
DRAWTEXT(准备2,12,准备2),COLORFF00FF;
BIAS1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
短跌选股:IF(BIAS1<=-6,40,0),COLORFFFFFF;
中跌选股:IF(BIAS2<=-10,50,0),COLORFF00FF;
长跌选股:IF(BIAS3<=-16,60,0),COLOR00FF00;

通达信超跌组合指标公式

 

相关文章