在线检测未来函数

通达信最佳组合主图指标公式

来源:Internet,编辑:股旁网,2016-11-30

M1:=4;
M2:=5;
M3:=6;
M4:=21;
M5:=55;
LMA1:MA(LOW,M1);
LMA2:MA(LOW,M2);
LMA3:MA(LOW,M3);
LMA4:MA(LOW,M4)LINETHICK3;
LMA5:MA(LOW,M5)LINETHICK3;
VAR1:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
VAR2:=CROSS(VAR1,0.9);
VAR3:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
VAR4:=CROSS(VAR3,0.9);
压力:= REF(HIGH,BARSLAST(VAR2)), POINTDOT,COLOREA91B5;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2)),REF(HIGH,BARSLAST(VAR2)),2,1),COLOREA91B5,LINETHICK3;
支撑:= REF(LOW,BARSLAST(VAR4)), POINTDOT,COLOR00B4FF;
STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4)),REF(LOW,BARSLAST(VAR4)),2,1),COLOR00B4FF,LINETHICK3;
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
ARSV:=SMA(下档线,3,1);
AK:=SMA(ARSV,3,1);
AD:=((3 * ARSV) - (2 * AK));
AJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
ARSV24:=SMA(AJ12,3,1);
AK24:=SMA(ARSV24,3,1);
AD24:=((3 * ARSV24) - (2 * AK24));
撑:=IF(CROSS(AD24,AD),HIGH,REF(HIGH,BARSLAST(CROSS(AD24,AD))));
撑压位:=IF(ISLASTBAR ,撑,DRAWNULL);
底底:=LLV(HIGH,30);
底:=IF(ISLASTBAR ,底底,DRAWNULL);
STICKLINE(ISLASTBAR ,撑压位,撑压位,100,1),LINETHICK1,COLORFFFFFF;
STICKLINE(ISLASTBAR ,底,底,80,1),COLOR00FF00,LINETHICK1;
AAA0:=(3*C+H+L+O)/6;
短趋:=(8*AAA0+7*REF(AAA0,1)+6*REF(AAA0,2)+5*REF(AAA0,3)+4*REF(AAA0,4)+3*REF(AAA0,5)+2*REF(AAA0,6)+REF(AAA0,8))/36;
中趋:=(LLV(短趋,2)+LLV(短趋,4)+LLV(短趋,6))/3;
TTJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>短趋;
立桩量:=FILTER(TTJ1,5);
TTJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破:=TTJ2=1;
TTJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TTJ3=1;
成立:=三天法则 AND 突破;
条件成立:=FILTER(成立,3);
DRAWICON(条件成立,L*0.91,1);
DRAWTEXT(条件成立,L*0.91,'立桩'),COLORFF26FF;
价格重心:=(O+L+H+C)/4;
CBZX:=AMOUNT/VOL/100;
成本重心:=IF(CBZX>H OR CBZX<L,价格重心,CBZX);
重心偏离:(成本重心-价格重心)*100,NODRAW;
涨跌引力:((C-成本重心)+(价格重心-O))*100,NODRAW;
STICKLINE(1,成本重心,成本重心,1,0),COLORFF00FF;
STICKLINE(1,价格重心,价格重心,1,0),COLORFF8800;

通达信最佳组合主图指标公式

 

相关文章