在线检测未来函数

通达信中线魔轨指标公式

来源:Internet,编辑:股旁网,2016-12-01

P1:=0;
P2:=IF(CLOSE>MA(CLOSE,5),P1+10,P1-10);
P3:=IF(CLOSE>MA(CLOSE,10),P2+10,P2-10);
P4:=IF(CLOSE>MA(CLOSE,10),P3+10,P3-10);
P5:=IF(MA(CLOSE,5)>MA(CLOSE,10),P4+10,P4-10);
P6:=IF(MA(CLOSE,10)>MA(CLOSE,20),P5+10,P5-10);
BD:=P6;
STICKLINE(BD>=-50,-50,BD,2,0),COLORMAGENTA;
STICKLINE(BD>=-30,-30,BD,2,0),COLORLIBLUE;
STICKLINE(BD>=0,0,BD,2,0),COLORLIGREEN;
STICKLINE(BD<=50 AND BD>=30,30,BD,2,0),COLORRED;
STICKLINE(BD<=80 AND BD>=50,50,BD,2,0),COLORYELLOW;
VAR1:=3*SMA((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100,10,1)-2*SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,10,1),6,1);
中线魔轨: VAR1, CIRCLEDOT,COLORF00FF0;
RSV1:=(CLOSE-LLV(LOW,35))/(HHV(HIGH,35)-LLV(LOW,35))*100;
K1:=SMA(RSV1,8,1);
D1:=SMA(K1,8,1);
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1) ,EMA(D1,3) ,REF(EMA(D1,3),1) ,11 ,0),COLORRED;
STICKLINE(EMA(D1,3)<REF(EMA(D1,3),1) ,EMA(D1,3) ,REF(EMA(D1,3),1) ,11 ,0 ),COLORCYAN;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),COLORWHITE;
D:SMA(K,3,1),COLORYELLOW;
J:3*K-2*D,COLORRED;
DRAWICON(K<20 AND CROSS(K,D),D,1);
周金:DRAWTEXT(CROSS("KDJ.K#WEEK"(9,3,3),"KDJ.D#WEEK"(9,3,3)) ,D,'周买'),COLORRED;
周叉:DRAWTEXT(CROSS("KDJ.D#WEEK"(9,3,3),"KDJ.K#WEEK"(9,3,3)) ,D*1.5,'周卖'),COLORGREEN;
月金:DRAWTEXT(CROSS("KDJ.K#MONTH"(9,3,3),"KDJ.D#MONTH"(9,3,3)) ,D,'月买'),COLORWHITE;
月叉:DRAWTEXT(CROSS("KDJ.D#MONTH"(9,3,3),"KDJ.K#MONTH"(9,3,3)) ,D*1.5,'月卖'),COLORYELLOW;
VAR22:=REF(LOW,1);
VAR23:=((SMA(ABS((LOW - VAR22)),3,1) / SMA(MAX((LOW - VAR22),0),3,1)) * 100);
VAR24:=EMA(IF((CLOSE * 1.2),(VAR23 * 10),(VAR23 / 10)),3);
VAR25:=LLV(LOW,38);
VAR26:=HHV(VAR24,38);
VAR27:=IF(LLV(LOW,90),1,0);
VAR28:=((EMA(IF((LOW <= VAR25),((VAR24 + (VAR26 * 2)) / 2),0),3) / 618) * VAR27);
主力秘密筹码:STICKLINE(VAR28,-50,VAR28-50,6,1),COLORRED;
动态底部:EMA(IF(L<= LLV(L,30),SMA(ABS(L-REF(L,1)),30,1)/SMA(MAX(L-REF(L,1),0),30,1),0),3)*10,STICK,COLORYELLOW,LINETHICK2;
VAR4A:=(2*CLOSE+HIGH+LOW)/4;
VAR5A:=LLV(LOW,34);
VAR6A:=HHV(HIGH,34);
散户:=EMA((VAR4A-VAR5A)/(VAR6A-VAR5A)*100,12),LINETHICK1,COLORRED;
新庄:=EMA(0.667*REF(散户,1)+0.333*散户,4),COLORBLACK;
高减:IF(CROSS(新庄,散户) AND 新庄>80,80,90),COLOR14BA14;
低吸:IF(CROSS(散户,新庄) AND 散户<25,10,0),LINETHICK4,COLORYELLOW;

通达信中线魔轨指标公式

 

相关文章