在线检测未来函数

通达信跑了不悔指标公式

来源:Internet,编辑:股旁网,2016-12-01

CS:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
YJD: (EMA(CS,3)-50)*2;
YJD,COLORSTICK;
YJF:MA(YJD,5),COLORYELLOW;
VAR18:=(HIGH+LOW+CLOSE)/3;
VAR19:=(VAR18-MA(VAR18,14))/(0.015*AVEDEV(VAR18,14));
VAR1A:=(VAR18-MA(VAR18,70))/(0.015*AVEDEV(VAR18,70));
VAR1B:=IF(VAR19>=150 AND VAR19<200 AND VAR1A>=150 AND VAR1A<200,-10,0);
VAR1C:=IF(VAR19<=-150 AND VAR19>-200 AND VAR1A<=-150 AND VAR1A>-200,10,0);
VAR1D:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR1E:=100-ABS(VAR1D);
风险2:IF(BARSCOUNT(CLOSE)<13,60,IF(VAR1E<88 AND VAR1D>0,40,60)),COLORCCFFCC,LINETHICK2;
出击2:IF(BARSCOUNT(CLOSE)<13,-60,0-IF(VAR1E<92 AND VAR1D<0,40,60)),COLORF00FF0,LINETHICK2;
风险1:IF(BARSCOUNT(CLOSE)<70,80,IF(VAR1A>=200 AND VAR19>=150,-15,VAR1B)+80),LINETHICK2,COLORCCFF66;
出击1:IF(BARSCOUNT(CLOSE)<70,-80,IF(VAR1A<=-200 AND VAR19<=-150,15,VAR1C)-80),COLORRED,LINETHICK2,;
DRAWTEXT(ISLASTBAR,-80,' 高安全区'),COLORWHITE;
DRAWTEXT(ISLASTBAR,-60,' 安全区'),COLORWHITE;
DRAWTEXT(ISLASTBAR,60,' 风险区'),COLORWHITE;
DRAWTEXT(ISLASTBAR,80,' 高风险区'),COLORWHITE;

通达信跑了不悔指标公式

 

相关文章