在线检测未来函数

通达信猎手之路指标公式

来源:Internet,编辑:股旁网,2016-12-05

M1:=5;
M2:=10;
ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//小筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100;{//小股民套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{//主力控盘筹码比率}
ZCMZL:=MA(ZLCM+SHCM,13);{//市场筹码总量}
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);{//走牛天数}
ZSHJJ:=EMA(ZSHTL,89);{//小股民警戒}
ZZLJJ:=EMA(ZZLKP,89);{//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);{//资金流入强度}
SH8:=EMA(ZSHTL,8);
DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);
{//------【数值显示】}
散户套牢系数:INTPART(ZSHTL),NODRAW;
主力控盘系数:INTPART(ZZLKP),COLOR4080FF,NODRAW;
资金流入强度:ZJLRQD,NODRAW,COLOR00FFFF;
{☆精确风险}
{【参数定义】}
RSV:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
K1:=SMA(RSV,10,1);
D1:=SMA(K1,5,1);
KK:=INTPART(K1);
DD0:=INTPART(D1);
TFXXS:=KK+DD0;{//变异KD风险系数}
TGLD:=MOD(TFXXS,10);{//踏浪涨停概率点}
TGLXS:=(TFXXS-REF(TFXXS,1))*10;{//变异KD乖离系数}
TYCFX:=TFXXS+TGLXS;{//变异KD预测风险}
乖离系数:TGLXS,LINETHICK0,COLORGREEN,NODRAW;
{【图解模板】}
{级别拐点}
{乖离系数}
STICKLINE(TGLXS>0,100,100+TGLXS,3,0),COLOR000088;
STICKLINE(TGLXS>0,100,100+TGLXS,2.5,0),COLOR000099;
STICKLINE(TGLXS>0,100,100+TGLXS,2,0),COLOR0000AA;
STICKLINE(TGLXS>0,100,100+TGLXS,1.5,0),COLOR0000BB;
{STICKLINE(TGLXS>0,100,100+TGLXS,1.2,0),COLOR0000CC;}
STICKLINE(TGLXS>0,100,100+TGLXS,1.0,0),COLOR0000DD;
{STICKLINE(TGLXS>0,100,100+TGLXS,0.8,0),COLOR0000EE;}
STICKLINE(TGLXS>0,100,100+TGLXS,0.5,0),COLOR0000FF;{//红柱}
STICKLINE(TGLXS<0,100,100+TGLXS,3,0),COLOR008800;
{STICKLINE(TGLXS<0,100,100+TGLXS,2.8,0),COLOR009900;}
STICKLINE(TGLXS<0,100,100+TGLXS,2.5,0),COLOR00AA00;
STICKLINE(TGLXS<0,100,100+TGLXS,2,0),COLOR00BB00;
{STICKLINE(TGLXS<0,100,100+TGLXS,1.8,0),COLOR00CC00;}
STICKLINE(TGLXS<0,100,100+TGLXS,1.5,0),COLOR00DD00;
{STICKLINE(TGLXS<0,100,100+TGLXS,1.2,0),COLOR00EE00;}
STICKLINE(TGLXS<0,100,100+TGLXS,1,0),COLOR00FF00;{//绿柱}
STICKLINE(TGLXS=0 AND REF(TGLXS,1)>=0,100,100+TGLXS,8,0),COLORRED;
STICKLINE(TGLXS=0 AND REF(TGLXS,1)<0,100,100+TGLXS,8,0),COLORFFFFFF;
{【数值显示】}
风险系数:TFXXS,LINETHICK2,COLORYELLOW,NODRAW;
预测风险:TYCFX,LINETHICK1,COLORFFFFFF,NODRAW;
T1:=CONST( ZCMZL>REF(ZCMZL,1) AND DKB=1);
T2:=CONST( ZCMZL>REF(ZCMZL,1) AND DKB=0);
T3:=CONST( ZCMZL=REF(ZCMZL,1));
T4:=CONST( ZCMZL<REF(ZCMZL,1) AND DKB=1);
T5:=CONST( ZCMZL<REF(ZCMZL,1) AND DKB=0);
T6:=CONST(TFXXS<=50 );
T7:=CONST(TFXXS>=160 );
T8:=CONST(TFXXS>50 AND TFXXS<160 AND TFXXS>=REF(TFXXS,1) AND TFXXS<=100 );
T9:=CONST( TFXXS>50 AND TFXXS<160 AND TFXXS>=REF(TFXXS,1) AND TFXXS>100);
T10:=CONST(TFXXS>50 AND TFXXS<160 AND TFXXS<REF(TFXXS,1) AND TFXXS>100 );
T11:=CONST(TFXXS>50 AND TFXXS<160 AND TFXXS<REF(TFXXS,1) AND TFXXS<=100 );
T12:=CONST( ZSHTL>90 );
T13:=CONST( ZZLKP>75 );
T14:=CONST(CROSS(ZCMZL,ZZLJJ) AND ZZLKP>ZZLJJ AND ZZLKP>10 AND ZZLJJ>REF(ZZLJJ,1) AND ZCMZL>REF(ZCMZL,1) );
T15:=CONST(CROSS(ZCMZL,ZZLKP) AND ZZLKP>ZZLJJ AND ZZLKP<ZSHTL AND ZZLKP>10 AND ZZLJJ>REF(ZZLJJ,1) AND ZCMZL>REF(ZCMZL,1) );
T16:=CONST( CROSS(ZCMZL,ZSHTL) AND ZSHTL>ZZLKP AND ZCMZL>REF(ZCMZL,1));
T17:=CONST( CROSS(ZCMZL,100) AND ZCMZL>REF(ZCMZL,1));
T18:=CONST(REF(ZSHTL,1)>90 AND ZSHTL<90 );
TS1:=IF(T1=1,0+0.03,0);
TS2:=IF(T2=1,TS1+0.03,TS1);
TS3:=IF(T3=1,TS2+0.03,TS2);
TS4:=IF(T4=1,TS3+0.03,TS3);
TS5:=IF(T5=1,TS4+0.03,TS4);
TS6:=IF(T6=1,0+0.73,0);
TS7:=IF(T7=1,TS6+0.03,TS6);
TS8:=IF(T8=1,TS7+0.03,TS7);
TS9:=IF(T9=1,TS8+0.03,TS8);
TS10:=IF(T10=1,TS9+0.03,TS9);
TS11:=IF(T11=1,TS10+0.03,TS10);
TS12:=IF(T12,0+0.03,0);
TS13:=IF(T13=1,TS12+0.03,TS12);
TS14:=IF(T14=1,TS13+0.03,TS13);
TS15:=IF(T15=1,TS14+0.03,TS14);
TS16:=IF(T16=1,TS15+0.03,TS15);
TS17:=IF(T17=1,TS16+0.03,TS16);
TS18:=IF(T8=1,TS17+0.03,TS17);
DRAWTEXT_FIX(T1,0.66,TS1,0,'★监控:主力增仓'),COLOR8080FF;
DRAWTEXT_FIX(T2,0.66,TS2,0,'★监控:主力减仓'),COLORFFFF00;
DRAWTEXT_FIX(T3,0.66,TS3,0,'★监控:多空平衡'),COLORGRAY;
DRAWTEXT_FIX(T4,0.66,TS4,0,'★监控:主力回补'),COLORFF9933;
DRAWTEXT_FIX(T5,0.66,TS5,0,'★监控:主力出逃'),COLORFFFF00;
DRAWTEXT_FIX(T6,0.86,TS6,0,'★操作:买入风险'),COLORYELLOW;
DRAWTEXT_FIX(T7,0.86,TS7,0,'★操作:卖出风险'),COLORFFFF00;
DRAWTEXT_FIX(T8,0.86,TS8,0,'★操作:追涨博弈'),COLOR8080FF;
DRAWTEXT_FIX(T9,0.86,TS9,0,'★操作:稳健持股'),COLOR8080FF;
DRAWTEXT_FIX(T10,0.86,TS10,0,'★操作:盘跌减仓'),COLORFFFF00;
DRAWTEXT_FIX(T11,0.86,TS11,0,'★操作:杀跌空仓'),COLORFFFF00;
DRAWTEXT_FIX(T12,0.36,TS12,0,'☆特别提示:筑底散兵坑 '),COLOR66FFCC;
DRAWTEXT_FIX(T13,0.36,TS13,0,'☆特别提示:铸顶风险区'),COLORFFFF00;
DRAWTEXT_FIX(T14,0.36,TS14,0,'☆特别提示:穿越主力 '),COLOR8080FF;
DRAWTEXT_FIX(T15,0.36,TS15,0,'☆特别提示:穿越主力 '),COLORYELLOW;
DRAWTEXT_FIX(T16,0.36,TS16,0,'☆特别提示:穿越散户 '),COLORGREEN;
DRAWTEXT_FIX(T17,0.36,TS17,0,'☆特别提示:全盘穿越 '),COLOR3399FF;
DRAWTEXT_FIX(T18,0.36,TS18,0,'☆特别提示:神秘黑洞 '),COLOR9966FF;
{AAA:=REFDATE(HHV(H,30),DATE);
T1A:=CONST(IF(ZZNTS,1,0));
TS1A:=IF(T1A=1,0+0.03,0);}
{DRAWTEXT(T1A=1 AND CURRBARSCOUNT=45 AND PERIOD=5,AAA-(AAA*TS1A),'【走牛天数判断】'),COLORRED,LINETHICK6;}
{DRAWNUMBER(T1A=1 AND CURRBARSCOUNT=45-12 AND PERIOD=5,AAA-(AAA*TS1A),CONST(ZZNTS)),COLORRED,LINETHICK6;};
三日最低:=EMA((REF(L,4)+REF(L,3)+REF(L,2))/3,3);
三日最高:=EMA((REF(H,4)+REF(H,3)+REF(H,2))/3,3),COLORWHITE;
高:=CROSS(CROSS(三日最高,C),0.6),STICK,COLORWHITE;
DRAWICON(高>0,高,2);
F:=100*(C-REF(C,1))/REF(C,1);
博尔:=IF(C<REF(O,1) AND F<0,1,0);
P1:=博尔;
量化:=IF(C<REF(O,2) AND F<0,1,0);
P2:=量化;
P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,STICK,COLORFF00FF,LINETHICK1;
DRAWICON(P1=0>0,P1=0,1);
量:V,VOLSTICK;
PJJ:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN)))); XVL:=(IF((CLOSE > OPEN),(QJJ * (HIGH - LOW)),IF((CLOSE < OPEN),(QJJ * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2))) + IF((CLOSE > OPEN)
,(0 - (QJJ * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (QJJ * (HIGH - LOW))),(0 - (VOL / 2)))));
ZLL:=(VOL / CAPITAL);
HSL1:=IF((ZLL > 10),10,ZLL);
HSL:=((XVL / 20) / 1.15);
进攻流量:=(((HSL * 0.55) + (REF(HSL,1) * 0.33)) + (REF(HSL,2) * 0.22));
GJJ:=EMA(进攻流量,8); LLJX:=EMA(进攻流量,3);
动态天量:=CONST(IF(V=HHV(V,20),V,REF(V,BARSLAST(V=HHV(V,20))))),COLOR00FF00,POINTDOT;
STICKLINE(((HSL * 0.4) >= 0),动态天量+((HSL * 0.4) +LLJX)*20,动态天量,3,0),COLORYELLOW;
STICKLINE(((HSL * 0.4) < 0),动态天量+((HSL * 0.4) +LLJX)*20,动态天量,3,0),COLOR00FF00;
资金流入:=IF((HSL*0.4+LLJX)>0,(HSL*0.4+LLJX),DRAWNULL),COLORRED;
资金流出:=IF((HSL*0.4+LLJX)<0,(HSL*0.4+LLJX),DRAWNULL),COLOR00FF00;
资金收支:=(HSL*0.4+LLJX),LINETHICK0;
万元:=AMOUNT/10000{0000},VOLSTICK,COLORFF00FF;
资金净收支:IF((HSL*0.4+LLJX)>0,资金流入,资金流出),COLORWHITE,POINTDOT;
收支比例%:IF((HSL*0.4+LLJX)>0,资金流入/万元*100,资金流出/万元*100),COLORYELLOW;
连红天1:=BARSLASTCOUNT(资金净收支>0),,COLORA20FFD,NODRAW;
连红天2:=IF(连红天1=0,REF(连红天1,1),连红天1),,COLORA20FFD,NODRAW;
连红天3:=IF(连红天2=0,REF(连红天1,2),连红天2),,COLORA20FFD,NODRAW;
连红天4:=IF(连红天3=0,REF(连红天1,3),连红天3),,COLORA20FFD,NODRAW;
近期连红天:IF(连红天4=0,REF(连红天1,4),连红天4),COLORYELLOW,NODRAW;
三日资金:SUM(资金收支,3),COLORWHITE,NODRAW;
五日资金:SUM(资金收支,5),COLORFF00FF,NODRAW;
十日资金:SUM(资金收支,10),COLOR0000FF,NODRAW;
资金流量:=LLJX,LINETHICK0,COLOR0000FF;
STICKLINE((资金流量 > 0),动态天量+资金流量*20,动态天量,3,0),COLOR0000FF;
STICKLINE((资金流量 < 0),动态天量+资金流量*20,动态天量,3,0),COLOR008000;
万手:VOL/10000,LINETHICK0;
BB:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VVOL:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1,VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
MAVOL1:MA(VOLUME,M1),COLOR80FFFF,LINETHICK1;
MAVOL2:MA(VOLUME,M2),COLORFF00FF,LINETHICK1;
{变色彩带}
VAR1:=(2*CLOSE+HIGH+LOW)/4;
操盘线: (EMA(VAR1,2)+EMA(VAR1,3)+EMA(VAR1,5)+EMA(VAR1,8)+EMA(VAR1,11)+EMA(VAR1,13))/6.4,COLORFFFF00,LINETHICK1,CIRCLEDOT;
IF(操盘线>REF(操盘线,1),操盘线,DRAWNULL),COLOR0000FF,LINETHICK1,CIRCLEDOT;

通达信猎手之路指标公式

 

相关文章