在线检测未来函数

通达信股市热度排序指标公式

来源:Internet,编辑:股旁网,2016-12-07

M:=120;{过滤掉,上市日期不足120个交易日的股票,数值可根据自己需要更改}
N:=20;{统计20日最高涨跌幅,数值20可调整}
五日涨跌幅:IF(TOTALBARSCOUNT>=M AND DYNAINFO(4)>0 AND COUNT(COUNT((DATETODAY(DATE)-REF(DATETODAY(DATE),1))>10,BARSLASTCOUNT((C=H AND C>REF(C,1)*1.098) OR (C=L AND C<REF(C,1)*0.902))),5)=0,IF(C>REF(C,5),(C/LLV(C,6)-1),(C/HHV(C,6)-1))*100,0);
十日涨跌幅:IF(TOTALBARSCOUNT>=M AND DYNAINFO(4)>0 AND COUNT(COUNT((DATETODAY(DATE)-REF(DATETODAY(DATE),1))>10,BARSLASTCOUNT((C=H AND C>REF(C,1)*1.098) OR (C=L AND C<REF(C,1)*0.902))),10)=0,IF(C>REF(C,10),(C/LLV(C,11)-1),(C/HHV(C,11)-1))*100,0);
N日涨跌幅:IF(TOTALBARSCOUNT>=M AND DYNAINFO(4)>0 AND COUNT(COUNT((DATETODAY(DATE)-REF(DATETODAY(DATE),1))>10,BARSLASTCOUNT((C=H AND C>REF(C,1)*1.098) OR (C=L AND C<REF(C,1)*0.902))),N)=0,IF(C>REF(C,N),(C/LLV(C,N+1)-1),(C/HHV(C,N+1)-1))*100,0);

通达信股市热度排序指标公式

 

相关文章