在线检测未来函数

通达信CCI上穿背离指标公式

来源:Internet,编辑:股旁网,2016-12-14

N:=14;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
RSI1:=CCI;
AA:=REF(RSI1,N)=HHV(RSI1,2*N+1);
BB:=BACKSET(AA,N+1);
CC:=FILTER(BB,N) AND RSI1=HHV(RSI1,N+1);
A1:=BARSLAST(REF(CC,1));
背离:REF(CLOSE,A1+1)<CLOSE AND REF(RSI1,A1+1)>RSI1 AND CC,;
DRAWICON(顶背离,CCI*0.9,2);
DRAWLINE(CC,RSI1,FILTER(顶背离>0,5),RSI1,0),COLORGREEN,LINETHICK1;
AA2:=REF(RSI1,N)=LLV(RSI1,2*N+1);
BB2:=BACKSET(AA2,N+1);
CC2:=FILTER(BB2,N) AND RSI1=LLV(RSI1,N+1);
A2:=BARSLAST(REF(CC2,1));
底背离:REF(CLOSE,A2+1)>CLOSE AND REF(RSI1,A2+1)<RSI1 AND CC2;
DRAWLINE(CC2,RSI1,FILTER(底背离>0,5),RSI1,0),COLORMAGENTA,LINETHICK1;
DRAWICON(底背离,-130,1);
CCI底背离:=底背离 AND CROSS(CCI,-100);
DRAWICON(CCI底背离,-150,3);
DRAWTEXT(底背离,-130,'上穿-100是才能买入'),COLOR00FF00;
X:=CROSS(CCI,-100);
DRAWICON(X,-100,5);
IF(CCI>=100,CCI,DRAWNULL),COLORGREEN;
IF(CCI<=-100,CCI,DRAWNULL),COLORRED;

通达信CCI上穿背离指标公式

 

相关文章