在线检测未来函数

通达信创B专用线主图指标公式

来源:Internet,编辑:股旁网,2016-12-19

N:=3;
M:=7;
N1:=20;
N2:=11;
Q:=132;
N1:=200;
A4:EMA(C,N) COLORRED LINETHICK2;
A7:EMA(C,M) COLORYELLOW LINETHICK2;
A12:EMA(C,N2);
A30:EMA(C,28);
A20:EMA(C,N1);
UA:=(H+C+O)/3*(A4/A7);
顶:IF(UA>=A12,UA,DRAWNULL)COLORWHITE LINETHICK3;
LA:=L*(A7/A12) COLORYELLOW;
低:IF(UA<=A30,LA,DRAWNULL) COLORGREEN LINETHICK3;
低1:IF(UA<=A12 OR UA>=A30,LA,DRAWNULL)COLORWHITE DOTLINE;
DRAWTEXT(A4>0 AND ISLASTBAR,A4,' A4');
DRAWTEXT(A4>0 AND ISLASTBAR,A7,' A7');
DRAWTEXT(A4>0 AND ISLASTBAR,A12,' A12');
DRAWTEXT(A4>0 AND ISLASTBAR,A30,' A30');
DRAWTEXT(A4>0 AND ISLASTBAR,顶,' 顶');
DRAWTEXT(A4>0 AND ISLASTBAR,低 ,' 底');
DRAWTEXT(A4>0 AND ISLASTBAR,低1 ,' 底');
STICKLINE(A4>=A7 AND A4>REF(A4,1),H,H*1.0005,1,0)COLORRED;
DRAWICON(CROSS(A4,A7),L,25);
IF(REF(顶,1)/顶<=5.98/5.99,顶,DRAWNULL)COLORRED LINETHICK3;
HH:HHV(顶,16);
LL:LLV(低 ,16);
LL1:LLV(低1,16);
DRAWTEXT(CROSS(A12,A7),H,'大跌') COLORRED;
H1:=(XMA(H,4)-XMA(L,4))+XMA(H,4)COLORRED DOTLINE;
L1:=XMA(L,4)-(XMA(H,4)-XMA(L,4)) COLORGREEN DOTLINE;
H2:=(XMA(H,7)-XMA(L,7))+XMA(H,7)COLORRED DOTLINE;
L2:=XMA(L,7)-(XMA(H,7)-XMA(L,7)) COLORGREEN DOTLINE;
H3:=(XMA(H,13)-XMA(L,13))+XMA(H,13)COLORRED DOTLINE;
L3:=XMA(L,13)-(XMA(H,13)-XMA(L,13)) COLORGREEN DOTLINE;
H4:=(XMA(H,2)-XMA(L,2))+XMA(H,2)COLORRED DOTLINE;
L4:=XMA(L,2)-(XMA(H,2)-XMA(L,2)) COLORGREEN DOTLINE;
HH11:(H1+H2+H3)/3 COLORRED DOTLINE;
LL11:(L1+L2+L3)/3 COLORGREEN DOTLINE;
DRAWTEXT(A4>0 AND ISLASTBAR,LL11 ,' 波底');
DRAWTEXT(A4>0 AND ISLASTBAR,HH11 ,' 波顶');
IF(HH11<REF(HH11,1),HH11,DRAWNULL) COLORGREEN DOTLINE;
STICKLINE(C<O,O,C,3,0),COLORFF6600;
STICKLINE(C<O,O,C,2,0),COLORFF9900;
STICKLINE(C<O,O,C,1.2,0),COLORFFCC00;
STICKLINE(C<O,O,C,0.2,0),COLORCYAN;
STICKLINE(C>O,O,C,3,0),COLOR000099;
STICKLINE(C>O,O,C,2,0),COLOR0000CC;
STICKLINE(C>O,O,C,1.3,0),COLOR0000FF;
STICKLINE(C>O,O,C,0.3,0),COLORCC66FF;
{DRAWICON(L/低1<=1.001 AND L/低1>=0.999,L,24);};
GG:=A4+0.005;
DRAWICON(CROSS(A4,A7-0.003),L,25);
DRAWICON(L/低<=100.21/99.62 AND CROSS(A4,A7-0.003) AND HH11>REF(HH11,1) ,L-0.05,23);
DRAWICON(L/低1<=100.21/99.62 AND CROSS(A4,A7-0.003) AND HH11>REF(HH11,1) ,L-0.05,27);
DRAWTEXT(L/低<=100.21/99.62 AND CROSS(A4,A7-0.003) AND HH11>REF(HH11,1) ,LL11-0.05,'打上轨') COLORRED;
DRAWTEXT(L/低1<=100.21/99.62 AND CROSS(A4,A7-0.003) AND HH11>REF(HH11,1) ,LL11-0.05,'打上轨1') COLORRED;
四:=SUMBARS(VOL,CAPITAL/5),NODRAW; 二:=SUMBARS(VOL,CAPITAL/1.3),NODRAW; 中期成本:MA(C,二),NODRAW{中期成本均线};
短期成本:MA(C,四),NODRAW{近期成本均线};
牛市底线:EMA(C,66) CROSSDOT COLORWHITE LINETHICK2;
熊市必到128:EMA(C,128) CIRCLEDOT COLORMAGENTA LINETHICK1;
熊市必到256:EMA(C,256) CIRCLEDOT COLORBROWN;
EMA(C,512);
EMA(C,1024);
EMA(C,2048);
EMA(C,4096);
STICKLINE(C>0,(MAX(C,O)+MIN(C,O))*0.5,(MAX(C,O)+MIN(C,O))*0.5,3,0),COLORRED;
STICKLINE(C>0,(MAX(C,O)-MIN(C,O))/4+MIN(C,O),(MAX(C,O)-MIN(C,O))/4+MIN(C,O),3,0),COLORGREEN;
STICKLINE(C>0,MAX(C,O)-(MAX(C,O)-MIN(C,O))/4,MAX(C,O)-(MAX(C,O)-MIN(C,O))/4,3,0),COLORGREEN;
STICKLINE(C>0,MAX(H,L)-(MAX(H,L)-MIN(H,L))/4,MAX(H,L)-(MAX(H,L)-MIN(H,L))/4,3,0),COLORRED;
STICKLINE(C>0,(MAX(H,L)-MIN(H,L))/4+MIN(H,L),(MAX(H,L)-MIN(H,L))/4+MIN(H,L),3,0),COLORRED;
{主题概念}
Z1:=STRCAT(HYBLOCK,'----');
Z2:=STRCAT(Z1,FGBLOCK);
Z3:=STRCAT(Z2,DYBLOCK);
Z4:=STRCAT(Z3,'----');
DRAWTEXT_FIX(1,0.00,0.46,0,' 【主题概念】:')COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.07,0.46,0,STRCAT(Z4,GNBLOCK)),COLORCYAN;
DRAWTEXT_FIX(1,0.07,0.24,0,EXTERNSTR(0,14))COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.05,0.15,0,STRCAT('收益',STRCAT(CON2STR(FINANCE(38),3),'元'))),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.05,0.25,0,STRCAT('每股未分配',STRCAT(CON2STR(FINANCE(32),3),'元'))) COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.05,0.35,0,STRCAT('净利同比',STRCAT(CON2STR(FINANCE(43),4),'%'))) COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.25,0.15,0,STRCAT('股票吸引力',STRCAT(CON2STR(FINANCE(32)*10*(FINANCE(43))/C,4),'帕斯卡'))) COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.25,0.25,0,STRCAT('穷富公司',STRCAT(CON2STR((FINANCE(25)+FINANCE(22))/CAPITAL*(FINANCE(25)/FINANCE(22)),4),'战力'))) COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.25,0.35,0,STRCAT('重组能力',STRCAT(CON2STR((CAPITAL*C)/FINANCE(10)*100,4),'GOD'))) COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.05,0.55,0,STRCAT('市值',STRCAT(CON2STR(FINANCE(1)*C/100000000,0),'亿元'))) COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.25,0.45,0,STRCAT('流通市值',STRCAT(CON2STR(FINANCE(7)*C/100000000,0),'亿元'))) COLORYELLOW;
箱顶:=MA(REF(HHV(C,30),1),2);
买线:=EMA(C,2);卖线:=EMA(SLOPE(C,21)*20+C,42);
DRAWTEXT(CROSS(买线,卖线)AND
箱顶>=REF(箱顶,1),LOW-0.01,'★跟'),COLOR00FFFF;
最低:=TROUGHBARS(L,10,1);{调整之字幅度找到低位起点}
低价:=REF(L,BARSLAST(最低=0));
低价_:DRAWLINE(最低=0,L,ISLASTBAR,低价,0),COLORFFFF00;
FU:=C-低价_;
幅度:=FU/低价_*100,NODRAW;
DRAWTEXT(ISLASTBAR,低价_,'低价_'),COLOR208FFF;
_5%:DRAWLINE(最低=0,L*1.05,ISLASTBAR,低价*1.05,0),COLORFFFF00 DOTLINE;
_10%:DRAWLINE(最低=0,L*1.10,ISLASTBAR,低价*1.10,0),COLORFFFF00 DOTLINE;
_15%:DRAWLINE(最低=0,L*1.15,ISLASTBAR,低价*1.15,0),COLORFFFF00 DOTLINE;
_20%:DRAWLINE(最低=0,L*1.2,ISLASTBAR,低价*1.2,0),COLORFFFF00 DOTLINE;
_25%:DRAWLINE(最低=0,L*1.25,ISLASTBAR,低价*1.25,0),COLORFFFF00 DOTLINE;
_30%:DRAWLINE(最低=0,L*1.30,ISLASTBAR,低价*1.30,0),COLORFFFF00 DOTLINE;
_50%:DRAWLINE(最低=0,L*1.5,ISLASTBAR,低价*1.5,0),COLORFFFF00 DOTLINE;
_100%:DRAWLINE(最低=0,L*2,ISLASTBAR,低价*2,0),COLORFFFF00 DOTLINE;
_200%:DRAWLINE(最低=0,L*3,ISLASTBAR,低价*3,0),COLORFFFF00 DOTLINE;
DRAWTEXT(ISLASTBAR,_5%,'5%'),COLOR208FFF;
DRAWTEXT(ISLASTBAR,_10%,'10%'),COLOR208FFF;
DRAWTEXT(ISLASTBAR,_15%,'15%'),COLOR208FFF;
DRAWTEXT(ISLASTBAR,_20%,'20%'),COLOR208FFF;
DRAWTEXT(ISLASTBAR,_25%,'25%'),COLOR208FFF;
DRAWTEXT(ISLASTBAR,_30%,'30%'),COLOR208FFF;
DRAWTEXT(ISLASTBAR,_50%,'50%'),COLOR208FFF;
DRAWTEXT(ISLASTBAR,_100%,'100%'),COLOR208FFF;
DRAWTEXT(ISLASTBAR,_200%,'200%'),COLOR208FFF;
转强:=100*(C-REF(C,12))/REF(C,12);
超强:=((H+L+C)/3-MA((H+L+C)/3,88))/(0.015*AVEDEV((H+L+C)/3,88));
通道:=1.07*DMA(C,ABS((2*C+H+L)/4-MA(C,26))/MA(C,26));
趋势:=MA(ATAN(通道-REF(通道,1)),3);
QS1:=IF((C>O OR C<O) AND H>=REF(C,1),ATAN(MA(H,5)*1.02-REF(MA(C,5)*1.02,1)),0);
QS2:=IF((C>O OR C<O) AND H<REF(C,1),-ATAN(REF(MA(C,5)*1.02,1)-MA(H,5)*1.02),0);
分界:=MA(REF((QS1+QS2),1),26);
强势:=趋势>分界 AND 趋势>REF(趋势,1) ;
天量:=V>REF(HHV(V,BARSLAST(BARSCOUNT(C)=1)+1),1) ;
超级牛股:=强势 AND 超强>200 AND 转强>20 AND C>REF(C,1) ;
DRAWTEXT(超级牛股,L*0.95,'超牛'),COLORRED,LINETHICK2;
A1:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,23))/EMA(CLOSE,23));
A2:=DMA(((2.15*CLOSE+LOW+HIGH)/4),A1);
金线王:EMA(A2,NQ)*1.118,LINETHICK2,COLORYELLOW;
金线王2:EMA(A2,NQ)*1.118,LINETHICK1,COLORRED;
买:=EMA(C,4) LINETHICK3;
卖:=EMA(SLOPE(C,20)*10+C,35) LINETHICK3;
DRAWTEXT(CROSS(卖,买),HIGH*1.02,'卖'),COLORGREEN;
A71:=C-REF(C,1);
A8:=100*EMA(EMA(A71,6),6)/EMA(EMA(ABS(A71),6),6);
买1:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
DRAWTEXT(FILTER(买1=1,5),LOW,'↖买进'),COLORYELLOW;

通达信创B专用线主图指标公式

 

相关文章