在线检测未来函数

通达信乖离通道抄底指标公式

来源:Internet,编辑:股旁网,2016-12-22

长期乖离:(CLOSE-MA(CLOSE,55))/MA(CLOSE,55)*100,COLORYELLOW,STICK,LINETHICK3;
IF(长期乖离<=0,长期乖离,0),COLORWHITE,STICK,LINETHICK3;
中期乖离:(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100,COLORFF00FF,STICK,LINETHICK3;
IF(中期乖离<=0,中期乖离,0),COLORFFFF33,STICK,LINETHICK3;
短期乖离:(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100,COLORRED,STICK,LINETHICK3;
IF(短期乖离<=0,短期乖离,0),COLORBLUE,STICK,LINETHICK3;
VAR2:=REF(HIGH,1)*1.1;{{昨日最高价*系数}
VAR3:=HIGH*1.1;{当日最高价*系数}
VAR4:=(VAR3*VOL+VAR2*(CAPITAL-VOL))/CAPITAL;
VAR5:=REF(LOW,1)*0.9; {昨日最低价*系数}
VAR6:=LOW*0.9;{当日最低价*系数}
VAR7:=(VAR6*VOL+VAR5*(CAPITAL-VOL))/CAPITAL;
VAR8:=EMA(VAR7,30);{求30日VAR7的移动平均}
VAR9:=EMA(VAR4,30);{求30日VAR4的移动平均}
VAR10:=VAR9-2;
VAR11:=IF(CLOSE<=VAR8,VAR10,VAR9);
VAR12:=VAR11*2.5;
VAR13:=VAR10*2.5;
STICKLINE(VAR12=VAR13,中期乖离,0,2,1),COLOR408000;
通道上:MA(短期乖离,20)+1.618*STD(长期乖离,20),COLOR0099FF,LINETHICK2;
通道下:MA(短期乖离,20)-1.618*STD(长期乖离,20),COLOR0099FF,LINETHICK2;
轨迹:短期乖离,COLOR00FF00,LINETHICK2;

通达信乖离通道抄底指标公式

 

相关文章