在线检测未来函数

通达信捉妖神器主图和选股指标公式

来源:Internet,编辑:股旁网,2016-12-23

CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上轨:(1+7/100)*DD,COLORGREEN;
上轨1:(1+5/100)*DD,COLORGREEN;
下轨:(1-7/100)*DD,COLORGREEN;
中轨:(上轨+下轨)/2,COLORGREEN;
疯狂:(1+14/100)*DD,COLORGRAY,POINTDOT;
抄底:(1-14/100)*DD,COLORGRAY,POINTDOT;
上轨红:IF(上轨>=REF(上轨,1),上轨,DRAWNULL),COLORRED,LINETHICK1;
中轨红:IF(中轨>=REF(中轨,1), 中轨,DRAWNULL),COLORRED, LINETHICK1;
下轨红:IF(下轨>=REF(下轨,1), 下轨,DRAWNULL),COLORRED,LINETHICK1;
{中期临界点90:DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,90),VOL),CIRCLEDOT,COLORGRAY;}
{年:DMA(MA(CLOSE+REF(CLOSE,5)/CLOSE*0.098,250),VOL),CIRCLEDOT,COLORGRAY;}
DIR2:=ABS(CLOSE-REF(CLOSE,10));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);
ER2:=DIR2/VIR2;
CS2:=ER2*(0.8-2/24)+2/24;
CQ2:=CS2*CS2;
{AMA2:EMA(DMA(CLOSE,CQ2),2),COLORLIBLUE,LINETHICK2;}
{无穷均线:DMA(CLOSE,(VOL)/(CAPITAL)),LINETHICK1,COLORFF00FF;}
{STICKLINE((CLOSE>=中轨) AND (CLOSE>=OPEN),CLOSE,OPEN,3,0),COLORRED;}
{STICKLINE((CLOSE>=中轨) AND (CLOSE>=OPEN),HIGH,LOW,0,0),COLORRED;}
{STICKLINE((CLOSE>=中轨) AND (CLOSE<OPEN),CLOSE,OPEN,3,1),COLORRED;}
{STICKLINE((CLOSE>=中轨) AND (CLOSE<OPEN),OPEN,HIGH,0,0),COLORRED;}
{STICKLINE((CLOSE>=中轨) AND (CLOSE<OPEN),CLOSE,LOW,0,0),COLORRED;}
{STICKLINE((CLOSE<中轨) AND (CLOSE>OPEN),CLOSE,OPEN,3,1),COLORGREEN;}
{STICKLINE((CLOSE<中轨) AND (CLOSE<=OPEN),CLOSE,OPEN,0,1),COLORGREEN;}
{STICKLINE((CLOSE<中轨) AND (CLOSE<=OPEN),HIGH,LOW,3,1),COLORGREEN;}
{STICKLINE((CLOSE<中轨) AND (CLOSE>OPEN),CLOSE,HIGH,0,1),COLORGREEN;}
{STICKLINE((CLOSE<中轨) AND (CLOSE>OPEN),OPEN,LOW,0,1),COLORGREEN;};
ZDT:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDT>7.0,O,C,2,0),COLORYELLOW;
STICKLINE(ZDT<-7.8,O,C,2,0),COLOR00FF00;
涨停1:=ZDT>7.0;
不破价:=REF(L,BARSLAST(涨停1));
Z:=(L+H+C*2)/4;
Z1:=EMA(Z,14)COLORBLUE,LINETHICK2;
Z2:=EMA(Z,25)COLORLIBLUE,LINETHICK2;
Z1B:=(Z1-REF(Z1,1))/REF(Z1,1)*100;
Z2B:=(Z2-REF(Z2,1))/REF(Z2,1)*100;
考虑打击:IF(Z1B>=0 AND BARSLAST(CROSS(Z1B,0))>0,REF((C+O)/2,BARSLAST(CROSS(Z1B,0))),DRAWNULL);
DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIF,9);
AAA:=(DIF-DEA)*2*60;
启动:=CROSS(AAA-REF(AAA,1),15),COLORRED,LINETHICK2;
DRAWTEXT(启动,L*0.97,'↖金牛启动'),COLORYELLOW,LINETHICK2;
AA:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
BB:=EMA(AA,2);
TP:=(CROSS(AA,BB) OR CROSS(C,AA)) AND C>=EMA(C,55);
CC1:=EMA(CLOSE,12)-EMA(CLOSE,26);
DD1:=EMA(CC1,9);
主升启动:=TP AND CROSS(CC1,DD) AND (DD1<=-0.07)*CC1;
DRAWICON(主升启动,L*0.996,1);
DRAWTEXT(主升启动,L,'↖LSP牛');
DRAWTEXT_FIX(1,0,0,0,'总股本(亿):'),COLORFF36FF,LINETHICK3;
DRAWNUMBER_FIX(1,0.09,0,0,CONST(FINANCE(1)/100000000)),COLORFF36FF,LINETHICK3;
DRAWTEXT_FIX(1,0.23,0,0,'流通股(亿):'),COLORFF36FF,LINETHICK3;
DRAWNUMBER_FIX(1,0.5,0,0,CONST(CAPITAL/1000000)),COLORFF36FF,LINETHICK3;
DRAWTEXT_FIX(1,0,0,0,EXTERNSTR(0,1))COLOR00FF00;
DRAWTEXT_FIX(1,0,0,0,EXTERNSTR(0,3))COLORFF88FF;
DRAWTEXT_FIX(1,0,0,0,EXTERNSTR(0,2))COLORFFFFFF;

{
选股公式:

DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIF,9);
AAA:=(DIF-DEA)*2*60;
金牛启动:CROSS(AAA-REF(AAA,1),15);
}

通达信捉妖神器主图和选股指标公式

 

相关文章