在线检测未来函数

通达信经典BBI主图指标公式

来源:Internet,编辑:股旁网,2016-12-26

N1:=5;
N2:=10;
N3:=20;
N4:=30;
{画K线}
STICKLINE(C>=BBI,O,C,2.5,1),COLOR0000EE;
STICKLINE(C>=BBI AND C>=O,C,H,0,1),COLOR0000EE;
STICKLINE(C>=BBI AND C>=O,O,L,0,1),COLOR0000EE;
STICKLINE(C>=BBI AND C<O,O,H,0,1),COLOR0000EE;
STICKLINE(C>=BBI AND C<O,C,L,0,1),COLOR0000EE;
STICKLINE(C<BBI,O,C,2.5,1),COLORBLUE;
STICKLINE(C<BBI AND C>=O,C,H,0,1),COLORBLUE;
STICKLINE(C<BBI AND C>=O,O,L,0,1),COLORBLUE;
STICKLINE(C<BBI AND C<O,O,H,0,1),COLORBLUE;
STICKLINE(C<BBI AND C<O,C,L,0,1),COLORBLUE;
BBI:(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4,COLORRED,LINETHICK2;
BB:=BBI<REF(BBI,1);
IF(BB,BBI,DRAWNULL)COLORGREEN,LINETHICK2;
DRAWICON(CROSS(C,BBI),BBI*0.975,1);
DRAWICON(CROSS(BBI,C),BBI*1.015,2);
BS:=EMA(C,5),COLORWHITE;
升升不息:EMA(BS,30),COLORMAGENTA,LINETHICK2;
重心:(H+L+3*C+O)/6,NODRAW;
STICKLINE(重心>0,重心,重心*1.001,0.1,0),COLORLIRED;
重心转向:重心>REF(重心,1) AND REF(重心,1)<REF(重心,2),NODRAW;
STICKLINE(重心转向,L,MAX(C,O),0.1,0),COLORYELLOW;
STICKLINE(重心转向,L,L*1.001,2,0),COLORYELLOW;
N:=33;
高:=EMA(H/REF(CLOSE,1),N)*C,COLORCYAN,DOTLINE;
低:=EMA(L/REF(CLOSE,1),N)*C,COLORRED,DOTLINE;
卖:IF(CURRBARSCOUNT=1,高,DRAWNULL),COLORLIRED;
买:IF(CURRBARSCOUNT=1,低,DRAWNULL),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1,卖,'_____'),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=1,买,'_____'),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=1,卖*1.01,卖),COLORLIRED;
DRAWNUMBER(CURRBARSCOUNT=1,买*1.01,买),COLORYELLOW;
VAR6:=REF(C,1);
VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;
DRAWTEXT(CROSS(82,VAR7),H*1.01,'高抛'),COLORYELLOW;

通达信经典BBI主图指标公式

 

相关文章